Plugged device in grey for "run on "

Hi everyone,
I’m trying to test the app on my Iphone. I can see the phone when plugged via usb in but it is in grey, therefore I can not change the "run on " . is there something I need to do / Missing ?

Thanks !

Hi @Lionel_M

Make sure you did set the Team Code Signing profile for the iOS app under the “Build Settings”… besides that the iOS device itself has been enabled for “Developer Mode”.

Maybe you’ll find useful too this entry in the Documentation.

Thanks Javier, the issue was indeed around the signing. I clicked on refresh , then I was able to select my profile. Trying now to run on the mobile, Xojo says that I need a dev profile when building an Ios App.
I went Through the link you shared but as it is a pretty old article, I guess I’m missing one step which i snow required… I was able to create a profile and save it on my Mac desktop but what am I supposed to do with ■■■ ?
Thanks !

Double click on it so it gets installed. Anyway, probably this blog post is more current :wink:

Before going deeper on the “crazy …”, when I try running the app , it complains about device beeing awake and unlocked, which is the case as you can guess …
I tried to set all settings to neverlock, never screensave… is the message buggy and it "s an error with other stuff in the profile or a trick exist ? ( btw, app seems to be created on the mobile, the cloud with the small arrow is below, don’t know which status it means for debugging an app …)
[EDIT] Trying with Xcode with an empty project ( hello world ) , the app installs and run

Did you look at my blog post from Jan 2022 about this?

@Greg_O do you mean this one ? : The Crazy Exercise that is the Apple Signing Process – Xojo Programming Blog
If so , yes I alrzady found it , this is what I mentionned in my previous post " before goin on the ’ Crazy exercice…etc’. I was wondering if the message is not the right one and the locking of the screen as nothing to do with the problem and it is a profile issue ? do you think it is ?

No. There’s one about iOS debugging…

However it contains an error (which I’ve reported). The Build For property needs to be set to App Store.

Ok, I tried to clean all the stuff I have done, and the “good news” is that I don’t have anymore complains about the fact that the screen must be unlocked. I have now the "usual error " which says that a Developer profile is required.
going through your steps in your post , I have my cert

I’m able to create a profile and import it correctly
When I set the build for appstore, it just change the error message asking for a distribution rather than a dev profile, but it is the same

I checked extra like Bundle Identifier is unique for sure.
on the Iphone, the app setting to approve my developer app to run is set to approve. I tried to build an app with Xcode and it works straight forward.
am I missing something now ?

What if you change “Build For” to “Development”? That always worked for me… :wink:

1 Like

It was set like that at first , I tried to switch to App Store based on @Greg_O insights.
Same result and error ( just wording changed )

It must be set to App Store for on-device debugging.

I’m going to suggest that you download and run my profile triage tool:

Thanks Gerg,
Here is what I get

I understood that I don’t need a dev account to use Xojo, but maybe that the issue ? to do some test on a real device, I need a dev account ?

Um… you do need some sort of Apple dev account to create the profiles you have there and you definitely need one to upload anything to the App Store for distribution.

The error there is wrong though. If you haven’t created an App Store Connect API account, it can’t know if the profile exists in your account.

Edit: I’ve pushed out Profile Triage 2.1.1 with fixes for users who don’t have API account credentials entered.

I did a lot of tests and read other topics in some Xcode Forums. My Understanding is that I don’t need a dev. Account but just a dev profile : as I’m able to build and create an app with Xcode, I should be able to do the exact same thing with Xojo as it relies on the same mechanism ( ie , to be clear and accurate, I can “just” build an app and get it working on a device which is set for dev mode and connected to my Mac, no store at all . @Javier_Menendez , do you have a dev account or would you confirm my understanding ? @Greg_O same question would you confirm my logic and understanding ( aside the xojo bug you mentioned ) ?
Thanks !

You definitely need Xcode. The IDE relies on some of the tools that ship with it. Make sure the tool location in Xcode is set properly in preferences (second to last tab).

You need two things that I would expect you to get from an Apple developer account:

  1. A development certificate
  2. A development profile which contains the certificate, the app identifier and the devices it’s allowed to run on.

I have no idea how you’re thinking that you can get all this without having a developer account.

Sorry for my bad english Greg, seams that I was not really clear.
Yes, I understand that I need Xcode. let me rephrase my explanation as short as possible .
As I’m able with Xcode to build and push an app to my Iphone, I should be able to do the same with Xojo as Xojo relies on Xcode. Am I right stating this ?

Or maybe : I have already all I need ( cert, profile …etc ) as I’m able to build and run an app on my Iphone built with Xcode

As long as the app identifier is the same, I guess.

I made some tests with a MacOS run through vmware and got some steps forward, so I decided to reinstall from scratch both Mac and Phone : I’m now able to build the app in debug mode , get it pushed to the Phone but execution fails as . At first run, I got a warning from Iphone saying the developper was not trusted, so went into pref, device …Etc… and allowed the developper.
I think my problem is solved regarding dev profiles & misc…
After Build is complete, app is copied to the phone but I get the error " cannot connect to the debugger". @Greg_O In this article iOS app on real iPad can't connect to the debugger - #16 by Greg_O and the one your previously shared, you mentionned that when the app is pushed at first ( or if you delete it completly ), you are prompted to allow connection for local network

is it only for debugging with network or should I get it was well with USB link only ?
If so, then , what else could prevent the connection with the debugger ?
Thanks !