error installing Xojo 2019r1.1 in Ubuntu 19.04

Hello all,

I’ve been trying to install Xojo 2019r1.1 in an Ubuntu 19.04 system using the deb package and gdebi (after seeing the default GUI installer fail silently)
The error message I’m getting is

This package is uninstallable
Dependency is not satisfiable: libwebkit2gtk-4 (>= 1.0.0)|libwebkit2gtk-3 (>= 1.0.0)|libwebkitgtk-3.0-0 (>= 1.0.0)

Any ideas how to get this working?
Thanks.

Use the TGZ instead ?

I urge all Linux users to use the TGZ and the added steps described in https://forum.xojo.com/52647-prep-fedora-centos-suse-for-xojo-use.

either the DEB nor the RPM will install without custom effort on your part.

[quote=440738:@Tim Jones]I urge all Linux users to use the TGZ and the added steps described in https://forum.xojo.com/52647-prep-fedora-centos-suse-for-xojo-use.

either the DEB nor the RPM will install without custom effort on your part.[/quote]
FWIW, the deb package does install properly on Linux Mint.

The tgz distribution appears to be working ok, thanks for your suggestion.

In this particular case it’s not really important how a working piece of software got installed, so I wouldn’t lose my sleep over it, I’m just mentioning it in case anyone wants to do something about it (if I’m not the only one with this issue)

Nevertheless, I find it a pity for such a neat and ordered way of distributing xojo not to work on a current OS release.

…which by itself is a weird thing: it kind of defeats the purpose of distributing software in packages and have a package manager take care of any configuration needed, isn’t it?

I’ve also installed the deb package on Mint in the past, without any problems.
It might have to do with the fact that the current version of Mint is based on Ubuntu 18.04 and I tried 19.04, don’t know…

LOL

Not any more! :slight_smile:

Although this is the feedback app, it includes the main xojo IDE as well (I just didn’t screen grab it, I really thought I did…)

https://forum.xojo.com/61480-unsatisfiable-dependencies-installing-feedback-application-on-f/p1#p497962

I did make a post about it though at http://forum.xojo.com/conversation/post/497865 :

[quote=497865:@Dave Matthews]I wish I’d seen this post a few hours ago. I’ve had xojo running on ubuntu 18.04 but wanted to clean my system out anyway so I blew it out today and have installed Linux Mint (20.04) as Mint is the “suggested” installation.

Trying to install from the .deb file there are dependency errors, specifically “not satisfiable” type dependency errors . I really love that wording.

dave@redmint:~$ sudo apt install gtk3 gtk3- gtk3-engines-breeze gtk3-engines-unico gtk3-im-libthai gtk3-nocsd dave@redmint:~$ sudo apt install gtk3 gtk3-
There doesn’t even appear to be a development branch.

So I’m guessing I need some added repos here, but which/what?

Looking at the output of ldd Xojo there is no entry for this missing package.
[/quote]

If this has been an issue for over a year now and new LTS branches don’t have the dependencies available to install xojo, it must really be time to update the dependencies to something thats included or remove that install method. I wasted a few hours on this yesterday and another couple tonight trying to work out if I actually need these dependencies or not (I’m having an issue elsewhere and it may be the result of that, I’m still trying to debug it.

I will stand by my original statement:

[quote=440738:@Tim Jones]I urge all Linux users to use the TGZ and the added steps described in https://forum.xojo.com/52647-prep-fedora-centos-suse-for-xojo-use.

Neither the DEB nor the RPM will install without custom effort on your part.[/quote]
I know that Greg “thinks” they got the DPKG sorted, but they never did.

Regardless, be prepared for a sluggish IDE and memory leaks out the ear. Plan on relaunching the IDE ever 2 hours or so as you work in it. And be aware of these outstanding reports:

feedback://showreport?report_id=55479
feedback://showreport?report_id=55283
feedback://showreport?report_id=54940
feedback://showreport?report_id=54909
feedback://showreport?report_id=54868
feedback://showreport?report_id=54552
feedback://showreport?report_id=54205
feedback://showreport?report_id=54116
feedback://showreport?report_id=50863
feedback://showreport?report_id=50680
feedback://showreport?report_id=49534
feedback://showreport?report_id=49454
feedback://showreport?report_id=49440

There re many others and some of those are marked as “Unable to duplicate” and “Closed”, but they all still occur under multiple distributions here in 19r3.2 and the currently available Feedback app on Linux.

Hi Georgios,
I’m currently running Xojo IDE under Mint 20.
I can open and execute projects, speed is ok on my I.3 cpu

Though, the Feedback App will not complete its install due to the same error message of missing libwebkit2-gtk …3 …the vers 4 is installed according to Synaptic…but there is no V.3 installed at all…
cant be satisfied

if any Linux users knows how to fix this - if at all possible - or any other way to complete the xojofeedback App …thanks for any “easy” sugestions :

:penguin: :penguin: :penguin:
Xojo Version installed : Version 2020 R. 1.
PC System: Kernel: 5.4.0-45-generic x86_64
bits: 64 compiler: gcc v: 9.3.0
Desktop: MATE 1.24.0
wm: marco dm: LightDM
Distro: Linux Mint 20 Ulyana
base: Ubuntu 20.04 focal

2019R3.2 makes the same problems with Ubuntu Focal (20)

Libwebkit2gtk has no v3 right?
You may want this one

libwebkit2gtk-4.0-37

https://packages.debian.org/search?keywords=libwebkit2gtk

Thanks @DerkJ
… it doesnt displays very big in the Synaptic capture - but i believe that this is the reference of the one installed in my system. Top line…

dont know if I should understand that feedback still needs an extra :

  • libwebkit2gtk-3
    and libwebkitgtk-3.0.0 >= 1.0.0
    …I cant find those within synaptic…
    :man_shrugging:

Because it is old Lessie stable release and will not install on later systems without tricking it out. Only stable is 37 and it is instaled by default if I am right. So with the latest webkit it is not working correctly. I guess could be a bug. I reported this before longer time but there is no fixing at all. Only 2020R1 works without complaining in install but makes later problems with the package management. This needs wo uninstall xojo package later. Given at 3 Ubuntu 20 Systems in my House.

2 Likes

No problems* here on latest Debian Buster… must be something with your Ubuntu… I always prefer to stick with the “original”.

(*) despite known issues in GTK font decorations

:cold_face: :cold_face: :cold_face:

Guys, do you think I could “force” an install of those 2 ? without breaking my working install of the Xojo builder ?
I was thinking that maybe the Xojo builder is not making use of those 2 : libwebkit2gtk-3 and libwebkitgtk-3.0.0 …and that only the Feedback App would need those… no idea, just a thought :thinking:

I am working with the TGZ Archive, unpacked and started xojo directly from the directory with double click after making it executable. It works without problems and needs no installation and rund for 2020 and 2019r3.2 and 3.1 as far as I was testing. It is only than not installed but working on your computer and also licensing is working correctly.

hmm ? :hushed: …never worked with those TGZ files before… seems to offer an interesting way to run Xojo then ?
If you can share a step by step detailed note on how you process… I might try to reproduce it on my station…

Yes it works without limitations except the feedback system witch is not recognizing installed Xojo versions correctly than. But you can work and it helps. When starting with sh script you can do in this wise:

cd /home/thorsten/xojo2019r3.2
./Xojo
and it works. Please do not forget: for 2020 there are the renamings of folder and program!!!

@Thorsten: Well, this could be the difference. I am working with .deb using dpkg for instalation. it seperates different xojo versions within /opt (the only one and right place, where it should be).

Maybe but it is not working with Ubuntu V20 and it is known by xojo. They had no solution and I had to find a way to be able to work under linux. When the deb is working under debian linux it is okay but all of my users have ubuntu linux and I have wo work with it in this case cause we decided this detail long time before the decision for xojo.