Can't Load Provisioning Profile

Hi all,

This morning I made some changes to my app entitlements and set up a new development provisioning profile. I downloaded it but Xcode won’t load it. I get the following error:


I’ve basically gone back to the settings I had originally but it still won’t load. Obviously, I am doing something wrong, but I can’t figure out what!



Make sure the device is in your device list and that it is included in the profile.

Which Device? I’ve got 4 and they are all listed. Never had this issue before.

Yeah won’t install…

From the profile entry on the Apple Developer Site:




The Identifiers match up. Everything is there. But won’t install. Rebooted computer, phone, etc…

Wait, what are you trying to do here? Provisioning profiles are typically embedded in apps when they are built, signed and transferred to the device, not independently of that.

I changed some entitlements for my app. Adding iCloud. So this needed me go download a new provisioning profile both for development and the store.

The new profile won’t load. This is the error that happens. I try double clicking it and I get this error. That’s what I asked “What device?”

I’m able to load the store profile without error but Xojo won’t recognize it.

I’ve had this problem, too.

A couple of suggestions:

  1. Remove any existing profiles for the app.
  2. Try to install from Xcode:
    • Open Xcode.
    • Open Preferences.
    • Select Accounts.
    • Click Download Manual Profiles.
    This has worked (at least for me).

Note: The whole process is seriously nuts.

1 Like

Thanks, Bob. Where do you remove the profiles? You’d think Apple would have a Profiles window where you could add and remove the profiles. But that would be too easy.

The easiest way to do this is to manually empty the folder. It’s located at:

~/Library/MobileDevice/Provisioning Profiles

macOS profiles have a .provisionprofile extension. iOS profiles have a .mobileprovision extension.

If you don’t want to remove EVERY profile, then @Greg_O also has a nifty profile lister which shows each installed profile and various data on it, and the newest version has the ability to right click any individual profile and delete it. More info and a link to his project is here

OK. I used the “Download Manual Profiles” in Xcode and that seems to have done it.

Ugh. Now getting this:


Still won’t work!

I can build the app now which is good but I still can’t install it which tells me the development profile is still no bueno.

I have absolutely no idea what I am doing incorrectly…

My SWAG may be the difference between a development and distribution profile vs what build option you are using in Xojo. But I don’t have enough experience with Xojo iOS builds to tell you. I pretty much only use Enterprise licenses, so I just apply them which let me install on any device…

I’m able to build for the store. That works. I was able to load the app to TestFlight and download it onto my phone.

But the development profile is what is not working.

Just tried debugging on my iPad to see if it was something with my phone. Nope. Won’t run.

OK. Some more info here. What started this mess in the first place was I wanted to add some iCloud capabilities to my app - well, right now I want to experiment with something.

So I enabled iCloud in Xojo. Well that required me to set that up in the entitlements in the profiles. So I did that.

This is when things started breaking.

I just tried doing a development build w/o the iCloud enablement in Xojo. It loaded just fine.

So something with my iCloud settings is what is hosing this up…

Seems like I have the same issue with one of my apps. I can build for app store, send it to testflight and download to my device.
But I can’t install the app on my device directly from xcode. I can live with it, but still an inconvenience.

1 Like

let me see if I can replicate that…

Did either of you enable anything in the options?

This is what I enabled:

And this:

I enabled everything.