Xojo will not launch

VB6 Programmer. Just downloaded Xojo. Program appears to load but will not launch. Any clues? Tried reloading several times. Have Windows 7 oS

any error message?
You build an exe which did not launch?

Not even that far. I download the xojo program and when finished go to the installation. It then shows that several sections are being installed “framework, on line help” and many more. At the end of all of them I end up with the screen I started with the desk top. I have looked into the Task Manager and this confirms that the xojo program IDE is not running.

I would suggest downloading DebugView from Microsoft if you don’t already have it.

Launch it first, and then (try to) launch Xojo. You will see a fairly large number of debug messages being written by Xojo as it starts up. Maybe you’ll be able to tell something from what it reports, and/or where in the process it stops.

FWIW, I don’t think this is a common problem, or we would see more reports here. Good luck…

Are you sure you’re not just installing Xojo instead of running it?
You should see a shortcut to Xojo under the start menu.
What happens if you click that one?

Hi Dirk
Yes I have tried running it. I have uninstalled several times and reinstalled it. I downloaded the Microsoft Debugview and the following is the result.
00000001 0.00000000 [3188] FTH: (3188): *** Fault tolerant heap shim applied to current process. This is usually due to previous crashes. ***
00000002 10.37979317 [3188] !!! Advanced types not yet implemented!!!
00000003 12.23301029 [3188] Loaded: RBAddressBook.rbx
00000004 13.05792332 [3188] Loaded: RBAppearancePak.rbx
00000005 13.64561462 [3188] Loaded: RBCrypto.rbx
00000006 14.00076389 [3188] Loaded: RBGameInput.rbx
00000007 14.39676476 [3188] Loaded: RBGUIKit.rbx
00000008 14.98501110 [3188] Loaded: RBGZip.rbx
00000009 15.61180019 [3188] Loaded: RBHTMLViewer.rbx
00000010 15.93861485 [3188] Loaded: RBInternetEncodings.rbx
00000011 18.32665253 [3188] Loaded: RBOpenGLSurface.rbx
00000012 19.14919281 [3188] Loaded: RBQT.rbx
00000013 22.55151939 [3188] Loaded: RBREALSQLDatabase.rbx
00000014 23.72787094 [3188] Loaded: RBRegEx.rbx
00000015 47.52459335 [3188] Loaded: RBScript.rbx
00000016 48.02688980 [3188] Loaded: RBShell.rbx
00000017 48.82443619 [3188] Loaded: RBSQLiteDatabase.rbx
00000018 49.43659210 [3188] Loaded: RBSSL.rbx
00000019 49.83251953 [3188] Loaded: RBXML.rbx
00000020 51.03548813 [3188] Loading plugins…
00000021 51.24232101 [3188] Loaded: MSSQLServerPlugin.rbx
00000022 51.80017090 [3188] Loaded: MySQLCommunityPlugin.rbx
00000023 52.03430939 [3188] Loaded: ODBCPlugin.rbx
00000024 52.29216003 [3188] Loaded: OraclePlugin.rbx
00000025 52.70023727 [3188] Loaded: PostgreSQLPlugin.rbx
Can anyone see a problem with the above - may be “!!! Advanced types not yet implemented!!!”

I am impressed so far with the help I am getting. I am looking forward to trying the program as it looks so much like the VB I have been using over the past many years.


Sorry, don’t see what is wrong. It seems to load the plugins which it is supposed to do. After that nothing is in the list?
You could always mail support (custserv@xojo.com). I’m sure they’ll be able to help you.
BTW don’t forget to mention what version of Windows 7 you are using.
Is it 32-bit or 64-bit. Is it English or another language.
Support will need this information to be able to help.
I’m using Windows 7 64-bit Dutch language and it works here. So Windows 7 should work.
Sorry I can’t be more helpful.

Have a look at the registry

HKEY_CURRENT_USER\Software\Xojo\Xojo\StudioMainWindow Bounds

its probably got huge numbers in it, delete these and restart xojo.

Thank Dirk. I am also using Windows 7 64 bit English. I am down loading the Xojo 2013V3.3 I thought I saw somewhere that this was only released a day or so ago. May be that is my problem. I will look for an earlier version.

Xojo is 32 bits.

Yes, I know that Xojo is 32 bit, but my question was if it was running on Windows 32 or 64-bit. It does make a difference.
Apparently it’s (not) running on 64 bit Windows for him.

No; I just checked, and my installation reports that as well (and then goes on to launch successfully). Sorry not to be more help…

Unfortunately, I’ve not seen this issue on any of the Windows version I’ve tested with. I have no idea what could cause it.

Some other things you might try to isolate the issue:

  • Try to Run As Admin
  • Try a different user account
  • Try installing Xojo in a VM or a different Windows installation

Russ Lunn suggested that I look in my registry and that I should see HKEY_CURRENT_USER\Software\Xojo\Xojo\StudioMainWindow Bounds

In my registry I have HKEY_CURRENT_USER\Software\Xojo\Xojo\
(Default) REG_SZ Dictionary
Control Font REG_SZ System
Control Font Size REG_DWORD 0x00000000 (0)
License Mod Time REG_SZ 3.466713186e+9
Save Compiled Debug Code REG_DWORD 0x00000001 (1)

Is this where I have my launching problem?

I have just downloaded, installed and launched Xojo 2013r3.3 and it’s working fine here on Windows 7 home premium.

With some older versions (I think it was RB2012), when I launched the IDE, it would not show, but the RB icon would be added to the hidden icons of the notification area. I never new why, or why it doesn’t happen now.

Could you check there and see if you got it?


Hi Julen
I have an xojo icon on my desktop from the last instal. When I double click on it to open the program I immediately get an Xojo icon in the notification area. The computer loads and I get the hourglass (circle) for quite a few seconds. Then the icon in the notification area disappears and I get control of the computer back. However - when I run the task master/Applications there is an indication of Xojo running but it drop our at the end of the load. But in the Task Master/Processes I can see xojo.exe * 32 using 115,000 K of memory (CPU 13) and a lot of CPU time is being used 10-12%. The memory usage is increasing by about 10k per second. After about 5 minutes the xojo.exe * 32 disappears and the CPU usage drops back to zero %.

That’s really strange. I hope you e-mailed support.
I also hope you get it to work, because coming from VB6, you should be very happy with Xojo. It really does offer about everything you need from VB6 but with the added bonus of being cross platform.

Thanks Dirk
I have contacted support and they requested more info. I directed them to this forum, I hope that they can use it to fill in some of the work that has been tried. I spent today on maintenance with my computer. I got rid of all the old programs, and cleaned up the register. I hope I don’t have to re load windows. This is a machine only about one year old, the last one died and left me in a difficult position. I now make regular backups.

Just another thought. Do you have an anti-virus program running?
If so, what happens if you disable the anti-virus and run Xojo then.
We’ve had problems in the past with some AV programs.

If it had worked I would have kicked myself. But I disabled it and still no luck. I had tried the firewall and that did not help.