Xojo on Chromebook

I installed Xojo on an Acer C720 Chromebook using instructions I found here.

I was hesitant to do this because it requires entering Developer mode which has less security (mainly because of the risks associated with installing apps) but I am glad I did it. Xojo runs great on this computer. I don’t see nearly as much sluggishness in the Xojo IDE on the Chromebook as I do on both Windows PCs I have tried so far (both bought in the last year or so; one with i3 and one with AMD; both have 4 GB of RAM). There is still sluggishness on Chromebook (for example, moving a WebButton in the visual editor) but it isn’t nearly as bad. On PCs the IDE is so slow it feels like it has crashed. I find myself trying to not use the visual editor which seems to help. For example, if I want to move a WebButton on PC, i am in the habit of typing new position in Inspector rather than moving it in the visual editor.

This was a very important step for me to be able to use a Chromebook at work. It was just an experiment but, as I said, it works so much better I might be using it more than I thought I would.

Thanks for providing the Linux version.

Curious which chrome book ?

The speedup probably has more to do with the Chromebook using an SSD instead of a harddisk.

But 2 GB RAM and just a 16 GB SSD don’t give much space in the future. 11in screen isn’t ideal either.

As you have several computers I presume money isn’t the only consideration. You might want to try a second-hand Mac next time.

First line: Acer C720 Chromebook

DUH me :stuck_out_tongue:

I have a Mac at work as well. I love Mac. In fact, the app I am converting to Web was created on a Mac for deployment on Mac. I don’t like the initial cost of Mac and the cost to keep it updated/upgraded. [Not to mention, the RB IDE was sluggish on the Mac too.] I am not saying Macs aren’t worth the cost, just that I am not sure I personally need to spend the extra money.

I honestly didn’t think the Chromebook would be good enough to run Xojo. That’s one reason I was hesitant. I am surprised at how well it runs. SSD certainly has something to do with it but I think the efficiency of Ubuntu 13.10 has something to do with it too.

There are many different Acer models, some might have Atom processors (which Xojo does not support). The processor in mine is Intel Celeron 4955U Dual Core at 1.4 GHz.

Sorry. Got the processor number wrong: Intel 2955U Dual Core at 1.4 GHz.

I think you are wrong here.
I have a Toshiba Encore Tablet with an Intel Atom processor running Windows 8 and the Xojo IDE and also running Linux Mint 16 and the Linux IDE from Xojo.

Ok. Glad to hear it. I was basing my response on this post but maybe things have changed.

The Chromebook in that thread was ARM not Atom. ARM is a RISC processor and Atom is x86.

Sorry about that. I need to pay better attention.

No reason to be sorry, confusion happens. As an avid ARM user myself I tend to notice when it is mentioned.

@Loren Staplin - Thanks for your post. I just got a C720 and did a search to see if anyone else had. It’s a snappy little CB - I love it so far :slight_smile:

BTW, you can set your Chromebook a bit more secure when running Dev mode by doing the following (It only keeps you from installing or running a different kernel) or one that has been altered in any way. At the shell:

$ sudo crossystem dev_boot_usb=0 dev_boot_signed_only=1

EDIT: For others who might want to try as well, the Crouton github page has a great readme on using Crouton (the Linux env for Chromebooks). This boots parallel to ChromeOS and you can hot-key between the two OS’s … oh and check out the wiki too :wink:

Just made this work… Here are some links.

Acer C720P touchscreen Chromebook – $299.

Installing Linux via Crouton. Read through first if you want Unity instead of XFCE.

This is light on apps. You’ll need Chrome browser for sure:

sudo apt-get install libxss1 wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb sudo dpkg -i google-chrome*.deb

You’ll need to install 32-bit support:

sudo apt-get install ia32-libs

Then hit the Xojo page, download Xojo, and install.


The C720P has 2GB RAM and 32GB SSD. You can self-upgrade the SSD (voiding warranty) to 128 GB for $100-ish. RAM is not upgradeable. Screen is 1366x768, which is typical for any Windows laptop under $800-ish, same as MacBook Air. Haven’t tried HDMI out while running Linux.

You can hot-switch between ChromeOS and Ubuntu. I see using Ubuntu for Xojo and a POP3 client. I’ll post thoughts on how well it works as I use it more.

If you need a git client, SmartGit/Hg works well. It’s a Java app, so you’ll need to install a JDK first:

apt-get install openjdk-7-jdk

Then download SmartGit. Commercial license is $79, plus there are support options, but you can evaluate it for free without giving up an email address.

When you download SmartGit, you’ll get a .zip package. Unzip in your home directory. Go into the /bin and /lib directories and make sure all the .sh files have executable permissions.

SmartGit seems to work great with a GitHub account. I may switch to it on the Mac as well. Or maybe not.

Some observations…

Chromebook trackpad doesn’t seem to have a right button, and this install of Ubuntu doesn’t seem to recognize control-click as a right click. You will probably need a USB mouse to get around the Unity interface easier.

Xojo is pretty usable on this device. There are some UI quirks in the Linux version. For example, the WebStyle editor is a mess. But I was able to run all my current web projects without any hiccups, and comfortably do real work on one for a couple hours.

Xojo with a touch screen is nice. Navigator responsive enough to finger and thumb touches.

On that subject I just love the never ending acronyms of today’s ever growing techno geeks
“Chromium OS Universal Chroot Environment (Crouton)”

Crouton’s wtf :slight_smile: lol

Brad - I have right-click on trackpad (C720, not C720P) so I am betting you do too but I actually use the feature where you can right-click with two finger tap (requires you to enable tap-to-click in Touchpad settings). Xojo right-click mouseevent works for me too. I can’t find specs on c720p trackpad but I read one review that said they had trouble with right-click (implying it does have a right-click).

Are there right-click settings for touchscreen? Maybe these settings interfere with trackpad right-click.

Do deployed apps with right-click work in chrome os for you?

If you figure out what’s going on with right-click I’d like to know. I might be interested in getting the c720p in future (I use touchscreens a lot in my work) so it would be nice to know if there is a way to fix (or perhaps an acer or chrome or ubuntu update that fixes it).

I have a few Xojo/Ubuntu issues I haven’t solved (yet) but I can live with them: 1) highlighted item in Xojo menu is white on gray (nearly disappears when you mouse over it), 2) Feedback app doesn’t work and 3) Language Reference won’t load. Not show stoppers but somewhat annoying.

I will be on the lookout for a right-click fix. I’m hoping/guessing its something simple on the ChromeOS side. And yeah, I’m going to start reporting Linux issues. I can be pretty productive with Xojo on Ubuntu on the Chromebook, but still have to venture back to my office Mac for some tasks.

[quote=77244:@Loren Staplin]Are there right-click settings for touchscreen? Maybe these settings interfere with trackpad right-click.

Touch Screen standard for right click is “Long Tap”, which means when one holds for half a second or so, the system reacts as if it was a right click.

Unfortunately, Xojo does not manage it, and unless Linux takes care of transforming Long Tap into Right Click, you will need to handle it in your code. This was discussed for a web app and I offered a working solution here :