Xojo Android first impression

New proyect, add a button, add a MessageBox object :expressionless: Single line of code and clicked run…

A dialog to open a folder pops out… WTF? Open what? The IDE should at least tell me what is the problem and what it needs.

Ok, not so RAD anymore, no click and run, waste some time on the docs and xojo needs the full Android studio :man_facepalming:t2:

It could just offer a download with the SDK and android build tools but… Ok, lets install a whole other application development tool besides xojo…

Ok, downloaded and installed the 1+ Gb of Android studio, open it and just then, it downloads the actual SDK And emulator :roll_eyes:

Done, opened xojo again, same steps, click run… several minutes go by just for xojo to tell me it had a compiler error. Restart, launch again, same error.

Launch again, this time just a button with no code, this time xojo launches the Android studio emulator instead using the already running Genymotion one :man_facepalming:t2:. Harcode the use of an emulator instead of using the standard Android Debug Bridge is not a good sign. Fun fact, support for Genymotion was sugested SIX YEARS AGO… 45688 - Android : please don't use only the simulator from the Android SDK This days the Android emulator has many more features but flexibility is a plus.

10 minutes and xojo was frozen, kill the emulator, xojo responded …

Try again, this time started the emulator before running the app, click run, and WTF???


Xojo cant run the emulator but if I oppen the emulator first xojo can run alogside Android studio?..

Close all Android studio related… Same Error

Close Genymotion?? (no way that can be) Yes, Xojo sees Genymotion as Android Studio :man_facepalming:t2:

(close genymotion) And xojo FINALLY runs the app in the emulator…

Created a simple container, put an integter property ad it to the inspector behavior bit it is NOT shown in the inspector…

Fisrt impression:

  • The experience is very Messy

  • The many error messages are not helpful

  • No controlsets :face_with_raised_eyebrow:

  • Custom controls with containers not working?

  • If after so many years of testing, something so basic as the MessageBox class, causes a compiler error , is hard to thing that the rest of the platform is in better shape…


Thanks for looking at Android (Beta)!

The initial dialog (which only appears if Android Studio is not installed in the default location) does show a prompt in the folder selector on Mac, but apparently not on Windows or Linux. I’ll add a separate one for that.

No, Genymotion is not yet supported. We have to start somewhere and using the standard Emulator made the most sense.

Like with iOS with Xcode, we do require a full Android Studio install. I suspect that will change over time, but pinpointing all the independent correct pieces to grab and install is not something we have done yet.

The Android Debug Bridge does not like to share its connection so it is easiest to keep Android Studio closed as it tries to grab the connection. There is a preference switch in Android Studio that can work around that, but you have to toggle it back and forth should you actually want to use Android Studio.

Don’t expect control sets as they are also not on iOS. I don’t think they are on web either.

Also, after closing all, Xojo.exe hangs, using a lot of CPU. I waited 10 minutes to see if it was doing something but at the end I had to kill the process.

Android Compiler
An internal Android Compiler error occurred.
Please create an Issue (xojo.com/issues) and attach your project (privately, if necessary) so that Xojo can investigate the error.

I also found the same problem。

I tested the release with a friend’s authorization, and the result prompts “Could not find output folder.”, why?

Windows Subsystem for Android might be an easier implementation than genymotion on windows. Once the dev mode is enabled, the platform is visible on adb ready to receive the build and execute it.

“Could not find outputs folder.” is a Windows-specific error indicates that the compile ran, but did not output an app. This is not something that was encountered in pre-release testing.

Please create an Issue with the project you use and any specifics of your system setup, such as Android Studio version and install location.

Hi All

I’m just a hobbyist and have been using xojo for a year and android for the last month. I couldn’t agree more that there are some bugs and issues that really should have been picked up before release.

However, that said, I’ve always found a way to get around issues with a bit of thought (and a lot of help from the forum) to get the end result I’m after. If I log an issue it seems to be resolved relatively quickly.

There is a strong need for documentation as personally I’ve never had any dealing with mobile apps before and this is still a learning curve.

I have released my first android app to my members two days ago so it has taken me a month to get to grips with android (including all the issues) and get it deployed. While it may not be up to commercial standards it does the job well and all seem happy (so far anyway!)

For someone at a retired 60 … something with no formal training and completely self taught I’ve tried Kotlin, dot net and C in its different forms and only managed to get to grips quickly with Xojo. For me at least its been RAD without a doubt. For any commercial developer I cannot speak.

For me its … ‘a fair start , but… can do better!’


I echo some of the thoughts here.

I presently have no interest in Android but I have started experimenting with Xojo’s iOS implementation.

The documentation / guidance for mobile development really needs attention. I’ve been building Xojo apps for console and desktop for 20 years but I’m still struggling with the app lifecycle and other issues with mobile that are fundamentally different from desktop.

1 Like

I run into the same problem.

It’s an empty new project on a Windows VM running Xojo 2023r2 installed today with a fresh install of Android Studio.

This is dead on arrival.

What could I do to get the error message behind the scenes?

I made an issue: #73619

And could you guys automate Android Studio installation somehow? It may be easy to get it wrong.


<< The initial dialog (which only appears if Android Studio is not installed in the default location)…>>

I am confused. ‘installing_android_studio.html’ does not say that Android Studio needs to be installed in the “default” location. So I chose to install it in a non-default location.
But the dialog box demanding ‘Select Folder’ kept popping up.

So what specific folder is expected by the Xojo Android program???

Applications ?

If you’re on macOS then yes, but it would definitely be nice to get a definitive answer from Xojo about the requirements for Linux for instance.

I suspect that just using the Windows installer and letting it install in the default location would be enough, however I bet they could get the actual location from the registry with a little digging.

I am running Xojo on Windows 10.
No matter what dummy apps I write, the default behavior of Xojo when attempting to run the app is the same: it opens up a dialog box for me to ‘Select Folder’.
It does not say what folder it needs.

No matter what dummy apps I write, the default behavior of Xojo when attempting to run the app is the same: it opens up a dialog box for me to ‘Select Folder’.
It does not say what folder it needs.

I think I mentioned above that you need to select the Android Studio folder location. The next version will have a prompt.

On Windows, the default location is where the Android Installer defaults to, which is C:\Program Files as I recall. If you change the install location, then Xojo prompts for its location the first time you run.

On Linux, there is no default install location since there is no recommended installer. Xojo checks the Desktop folder by default and if it is not there, it displays a folder selector.

Check the system log with DebugView.

Not at this point. We may be able to manually download and install just the necessary components at some point. Installing Android Studio is just a few clicks.

But I suspect there is something else going on here. Looking at the code, the “outputs” error appears to indicate the template file did not extract. I’ve never run into this myself, but we’ve gotten a few reports of this since r2 has shipped. Perhaps it could be localization? If you’re able to run the commands noted in the log manually, perhaps it could shed some light on the problem.

But these sort of things are why Android is a beta, so that we can continue to fine-tune issues such as this.

1 Like

If you haven’t already, please do create Issues for additional doc topics you think would be helpful.

That is a shame, removig really usefull features instead is not a good move.

Looks like not even the events are working in containers:

Even the errors table have errors… The second line is overlaping

This looks like they aren’t converting endoflines properly.
It’s done this for years during the alpha stage… like a creaky door, I guess Xojo got used to it and never ‘got around to’ sorting it out.
Always been advised to copy it and paste it into some other text tool.