Xojo 2022 R4 Quarantined ?!?

Downloaded and installed thinking I’d give this a spin as it appears to have a couple of useful bugfixes, but on launch I get this:

2020 iMac Core i5 running Ventura 13.0.1.

Oh well, it’s back to 2021R3.1 for me.

Oh they finally added that message? It’s about time :slight_smile:

Just search for how to remove the quarantine flag, there’s a handful of ways.

Try this How to remove com.apple.quarantine from t… - Apple Community

So now Xojo needs an installer to unpack the.DMG, copy everything to the Applications folder, and run the terminal command specifically to remove this, oh, and force a reboot before Xojo can be used.

And likewise the next version of my app will likewise need similar since it is not sold via the app store.

Great. Do I have to pat my head, rub my tummy and genuflect 3 times as well ?

Gatekeeper has been broken this way since the beginning. Feel free to complain to Apple.

Your app doesn’t have to do anything with how Xojo behaves.

Well, when you copy the Xojo app from the mounted disk image, the Finder should remove quarantine.
If it doesn’t, first thing would be to do it again.

Second option would be to run terminal command to remove it.

xattr -cr /Applications/Xojo/Xojo.app

Usually happens when people try to run an app straight out of the DMG.
I added a similar message to my apps years ago, and havent had any problems from customers since.
Before I added the message, anyone who tried running from the DMG could run into odd problems and slow operation.
Just dragging the App to applications sorts it, 99 times out of 100. When it does not, dragging to desktop, and from there to Applications, did the trick


A behaviour I’ve never understood. Many of these users then complain they can’t find the app anymore, when they want to launch it a second time.

The real question is “Why someone want to do that ?”. A test answer can be… just to check something.

I can do that sometimes (I do it with GIMPin the last week or so. WHen I saw what I wanted to know, I quit it and eject that DMG.

I never do that to work with the application.

Similar but “old” behavior in Windows:
Long time ago, I copied to the desktop an application (to test something), then fired it. That operation was rejected. I moved the application in Downloading (I think it was that) and fired it successfully. I never do that again.

Pretty simple: copy the Xojo folder to Applications before launching it.

1 Like

It was added in 2022r2.

There are plenty of good tips here for how to avoid and/or fix this issue if it occurs for you. Unfortunately this is an Apple GateKeeper thing and not related to Xojo itself.

I’m under Mojave and I don’t have all this Apple protection problems (protection of my computer or protection for Apple income is another debate).
I distribute my applications (made with Xojo) in ZIP, do my users who download them will have less trouble if I distribute them in DMG? I don’t pay Apple to be listed as a developer.

Then you’re not signing (let alone notarizing) your applications. This means that on first launch, your users must right-click on the icon and select “Open” from the contextual menu. After the nag screen is dismissed, the application will then run and the user won’t get nagged on subsequent launches.

I recall reading (haven’t tried it) that this method won’t work on Apple Silicon, and signing is mandatory. Someone who knows for sure can chime in here. :slight_smile: In any case, signing/notarization is the issue, not zip versus .dmg.

1 Like

Did you perhaps Cancel the step when it was verifying the DMG? I believe in the past, if you canceled the veririfcation step, the DMG would still mount, but then the app would be Quarantined after copy. I had this happen to me once.

Ok, thank you. That was my question. I make 2 builds of each of my applications (not one universal) and when someone contact me from my application, it write in subject “About MyApplicationName v.1.7.5 Mac INTEL 64-bit (2022r3.2)” or Mac ARM or Windows depending of the build. And I’m nearly sure I receive some email from ARM but I will have to search.

I just tried on my Mini M1 a few days ago with an application that is not signed, and it opened nicely.

The apps do open. But now and then a signature is screwed up on some app and then the app needs to be downloaded again.

After two more trials (delete it, download again, mount the DMG and drag the folder to Applications) it repeatable for me, 3 times out of three.

As for
xattr -cr /Applications/Xojo/Xojo.app

This fails with a bazillion lines of…

xattr: [Errno 1] Operation not permitted: ‘/Applications/Xojo2022R4/Xojo.app/Contents/_CodeSignature/CodeResources’… ending eventually with
xattr: [Errno 1] Operation not permitted: ‘/Applications/Xojo2022R4/Xojo.app’

And it’s still quarantined.

Which likely means you would likely have to use:

sudo xattr -cr /Applications/Xojo/Xojo.app

and have an Admin account.

Aha. This will catch a few people.

In Ventura, there is something new under System SettingsPrivacy & Security - and open App Management.

Guess what’s hiding in there: a setting to allow or block applications from updating or deleting other apps.

And Terminal is included, and the default is OFF (ie blocked). Turning this on, the xattr command will execute with no errors, and all is sweet (Xojo 2022 R4 no longer quarantined).



What I do is copy the Xojo folder into Applications. Then I select the Xojo app in Applications, copy it (cmd-C), paste it into the Desktop, and then move that copy back into the folder in Applications, replacing the original. Done.

Oh, I also rename Xojo.app to Xojo 2022r4.app so that I can see what version it is when I have several lurking about in the dock.