Xojo 2018 R1 Bugs


we experience some bugs in the current Xojo version, which make it unusable for us today.

  1. After compliling it is not possible to run our apps on some of our machines.
    We have identical applications, one made with 2017 R3, one made with 2018 R1, only the 2017 apps are able to run. Ldd-command shows nothing new. I have a very experienced server/linux guy in the company and he’s not able to start the 2018 application either.

  2. Xojo tend to ignore breakpoints which we have set in our applications. The code simply runs through with out stoping at a breakpoint. With this, it is very hard to test and debug things.

  3. If I accidentially delete an object, for example a containercontrol or a webdialog, in the objects list and press CMD+Z (for reverting the changes), then the object becomes a complete mess. Controls are mixed in the layout, events becomes methods, methods get lost and so on.
    I had this twice in the last days and I was forced to revert to my last git commit, because otherwise I had lost a lot of code.

Today we decided to not use the latest Xojo version anymore until the problems are fixed.

And: we cannot file a feedback-case, because the feedback-app doesn’t work in our environment.

As I read the last day, we are not the only ones having trouble with the latest version, so maybe someone can help or tell us when the problems are solved?

Thank you all guys

Have you tried 2108 Release 1.1?

  1. There is another open topic from a guy who has a webapp that doesn’t start in 2018. We ARE talking about webapps, correct?

  2. Should be fixed in 2018r1.1.

  3. Don’t know about this.

As usual it’s your job to say if the problems are fixed or not. Except the breakpoint issue your descriptions are way too generic.

My intent was more to see if this happens at other guys here in the forum as well.
It is no problem for us to stay at an older release.

I know that my explanations are not viable for a good bug hunt. :wink:

As far as I can say is, this happens also in R1.1 - I’ll double check this later

If you would use feedback on windows platform behind a firewall, you can’t use it. After the first start you can’t set parameter for proxy using. I have created a bug report, but the solution was "feedback is designed to work and open a normal http request on port 80.
Old projects on windows platform can’t not be used without a check and change of all controls that are placed on a stack witch images and transparent values on a canvas or placed into a container. If you open a new window control and do some database queries or read data from an array, some controls (Textfield, Pop-Up-Menu, etc) or the contents of the control are not visible. If you resize the window, they are visible. If I build these apps with 2017R3 the problems does not exists.

You are not the only one, but realize that big changes can take a few releases to get stable again.
Like the chicken and the egg: if it never drops one, it will won’t know what should be improved to make it better.

If my product is an enterprise solution for companies, which could be much bigger than I am and which use your product to develop their own products with maybe hundrets or thousands of customers, then no, then I can’t release an update which is not stable and well tested.

I don’t blame xojo for this, but as I mentioned, their product is the base of others business model. And if they want to keep their customers, they need to keep the product trustworthy. Otherwise the customers are looking for alternatives in the future.



here’s a tiny editor bug:

Sorry… I have to put my 2cents out there… The more I read, the more I am seeing that 2018r1 is more a QA release than anything else… Seriously 90% of the issues I am hearing about should never have seen the light of day. I was totally prepared to dip into my 401K to upgrade to 2018, but the more I read the more I am planning on delaying that decision

Bold, Isn’t it ?

Did you try that code without the umlaut n the u (Schuler instead of Shüler) ?

In the REAL / Real days, I never used anythin <> ASCII characters outside of strings, and sincce all troubles I have with Xojo, I enforce that: no variable, class, method, window, etc. with a name that holds a non ASCII character (even in the project path (and name)).

Just try it…

[quote=390130:@Emile Schwarz]@Lars:
Just try it…[/quote]

No it has nothing todo with the umlauts. We usually do not use german words in variables and we can observe the same behaviour.

And as you can see, we convert every runtime-string to utf8.

I suppose that a feedback request was logged for that interesting little as as as as… bug?

As I meantioned. Feedback doesn’t run on our systems/our environment. :confused:

And at home ? At another location ?

Edit: are-you using the last version ?

We all use our company macbooks at work as well as in private. And we decided to force the use of a VPN. So no, I cannot use feedback since some months (after some changes here). :slight_smile:

Do what I was told when I brought up this exact issue … “File a feedback request” (I kid you not)


seems to be a joke, but unfortunately I know that this could be a xojo answer. :smiley:

Try going here https://portal.macincloud.com/select/#/plans ,spend a $1 and install feedback on a cloud mac or go here https://aws.amazon.com/ec2/?hp=tile&so-exp=below and sign up for a free windows EC2 install and put feedback on it.

you mean spend $30.00 as that is the minimum credit (and it is not refundable)

Or install a windows vm and tether it to you phone