XML in IOS 2020 R2

Is anyone using XMLDocument in a shipping IOS app created in Xojo 2021?

As soon as I include an instance of the class in code, the app stops working.
This isn’t running code, it relates to whether a device allows the app to install.

There is no shipping version of Xojo 2021

Using 2020r2.1 I just checked adding following line in App.Open and the app installs and opens just fine on device:

Var x as new XMLDocument

My apologies, I am talking about Xojo 2020 R2.1
(The opposite of writing last years date on cheques)

Thanks for looking.
Me too.
But until I have code that uses it, the compiler optimises it away… its not actually in your compiled app.
Have you any code following to actually parse a document?

Is anyone shipping an app which uses it?

This morning, I tried switching to XMLReader.
Same issue. If I have a class of that type in my code, it won’t install. Presumably it uses the same libraries.

Is it possible that the XML libraries are in the simulator, but somehow not on my iOS 14.3 iPad Pro?

a) Have you sent your project to someone else to see if something is wonky on your computer?
b) Have you tried to use another computer for development?
c) It’s time to talk to Xojo directly and not via the Forum.

I’m still trying to tie things down to something repeatable.
Thats all Xojo will be interested in.

I think I have it here, but since XML support is so new, I have the strong impression I may be the only person trying to use it.

Have you sent your project to someone else to see if something is wonky on your computer?

Arrange provisions , compile something, and try to install is a big ask of anyone, but I have code that can be shared with anyone who would like to look.

The entire difference between ‘can install / cant install’ this morning is the simple presence of an XMLReader class with some system.debug logs in the event handler.

‘Have you got a working app that uses XML?’ is a quick and easy yes/no question.

If the answer from anyone is ‘yes’, then I can widen the search or give it up as a bad job.

But if you search the forum in IOS for XML, the only posts are from last year or older where people are asking ‘why doesnt IOS have XML support’, or from me saying ‘I think its broken’

That would be strange. But for now you can’t rule it out.

Tried with a XmlDocument (not xmlReader) and it works both on simulator and device

Used, not just ‘mentioned’?

I’m currently building my own XML parser to work around this.
Scared I will run into something else later on.

( its been like playing ‘Buckaroo’.
Add a line of code, see if it still deploys, add another, and so on.
So frustrating)

Could you show us some code? I just added several lines to manipulate the xml document and it still doesn’t crash.

it still doesn’t crash.

The project doesn’t crash.
It doesnt install.
I never get to ‘running it’ stage.

I have created a feedback case and attached a project to it.
Attached to it are 2 projects in a zip file, and they differ only by the inclusion of an XMLReader object with some debug lines in the events.
One works, the other does not.

I have created this project (or some variant of it) from scratch, about 12 times now, in case it was project corruption of some kind.
(I have 37 copies of it at various stages of complexity on my machine.)

In a way, I’m genuinely pleased to hear that this works for other people.
There must be some subtle ‘combination of things’ going on in a large project.

See… the devil is in the details. I was testing XMLDocument.

XMLDocument has the same issue. (See first post here)
If I include either of them, and have code that uses them (so that the compiler doesnt strip them out) , then it wont validate the install.

I switched to trying XMLReader today in the hope that it would be better.

ok, so while I’m not having trouble with XMLDocument, adding a subclass of XMLReader and instantiating it in code does crash the app on launch. That said, I am able to install it on my phone.

Just curious… do you have a Team selected in the iOS target? That would certainly cause you to not be able to install an app on a device.


Could you post a screenshot of the iOS Capabilities section of the inspector in the iOS Build Target’s advanced tab?

Yes I do.
Can install without the class, cant install with it.

Under ‘entitlements’ ?
None set to true at the moment.

I just added a request to your feedback case for the walle.OXS file that is referenced in the project.