Apple has rejected my .ipa built with Xojo 2017.r3 under Xcode 8.3.3. It has to be built with Xcode 9.0 or later. Downloaded Xcode 9.1 and now Xojo cant’t find the simulator and the build errors are numerous. Tried restarts, command line tools etc. and now I’m in the process of restoring Xcode 8.3.3 to see if I can get things working again using the command line tools for Xcode 8.3.3 under Xcode 9.0.

While I wait for the download, will the build be done under Xcode 9 using command line tolls for Xcode 8.3.3 ?

BTW I had everything working fine under Xcode 9.1 some months ago until I got an automatic update to MacOS after which I had to use Time Machine to restore my old OS. This caused Xojo to quit working with Xcode 9.0 so I put Xcode 8.3.3 back on my machine and have been working under that configuration. The App is ready for Test Flight and now I’m stuck in this Catch 22.

I’ve had success building and submitting to the App Store with Xojo 2018r1.1 and Xcode 9. I don’t think you’ll get Xojo 2017r3 to build with Xcode 9.


Thanks Paul. That’s what I was afraid of.


I just did a quick Hello World App and it successfully built an .ipa with Xcode 9. Tried my App again and no joy. Why would a new App link and not my old App? Strange. Don’t have a spare 300 bucks laying around for an upgrade.

It could be anything. A simple app might not use a control or library that causes the problem.

Thanks Paul.

What errors are you seeing? Many of us have experienced a myriad of Xcode issues with Xojo so maybe post a log and someone will have ideas? What libraries are you using in your app if any? Give us more info and we might be able to help


I’m currently reloading everything including my certificates. My App is finally ready for Test Flight and the .ipa failed since it was built under Xcode 8.3.3. I downloaded Xcode 9.1 but my xojo 2017r3 will not play with Xcode now including a Debug build with the warning that the simulator is not found. I’ve done all the standard fix attempts, setting command line tools to Xcode 9., reloading certificates etc. It all shows up in xojo as before but won’t run or build. Going back to Xcode 8.3.3 command line tools everything works again but then the .ipa will still be built under 8.3.3. Now according the documentation for 2017r3 states that “Xcode 9 is now supported for building and debugging iOS applications.” How to get 2017 to play with Xcode 9 when it’s been playing with 8.3.3 is where the solution lies but as they say in Maine "you can’t get thea from heah. I’ve been developing this App for over a year and now it seems I’m forced into a $300.00 renewal in the hopes that it will work. I built my first App with Realbasic in 2010 and you could build and test without a license. You bought the license when you were ready to publish. I’ll be glad to renew once the App is out there but I need to get it out there first.

It sounds like running Xcode-select could fix this. This thread will help:


Thanks Jason, I’m working on that. It asks for a password in console that I have no idea what it would be. My mini has no password requirement and the Apple ID password doesn’t work.


It’s a clue. Xcode 8.3.3 is running was running from my desktop extracted from a zip file. Xcode 9.0 is in my App folder. I’m extracting Xcode 9 to the desktop now in the hope that works. My location is:

sudo xcode-select -s /Applications/Xcode.app/Contents/Developer

so maybe xojo is looking for Xcode on my desktop where 8.3.3 no longer resides since I removed it in the hopes xojo would stop using it.

SUDO requires the login password for the account before it will execute the command with elevated privileges. Moving Xcode won’t stop Xojo from using it. You need to use xcode-select to tell every aspect of Xcode to use a different version and this includes apps like Xojo which look things up based on the bundle id, not by path.

Thanks Jason. Thing is… I have nothing protected by passwords. I need to create an account password apparently

It’s the password that is associated with your user account on your computer. SUDO requires it so you have to type it in.

Got that done Jason, had to create a password for the computer. Didn’t work. Xojo is still not finding the simulator. I’ll try a build for App Store and see if it uploads to Apple.


No problem in building a Debug but here is the result of an attempt to build a release.

The operation couldn’t be completed. 2018-07-19 15:57:35.546 xcodebuild[1738:863220] [MT] IDEDistribution: -[IDEDistributionLogging _createLoggingBundleAtPath:]: Created bundle at path ‘/var/folders/5v/x_2sr9cd2nzfdmc9nkjcmdg80000gn/T/Boat Minder_2018-07-19_15-57-35.541.xcdistributionlogs’.
2018-07-19 15:57:41.699 xcodebuild[1738:863220] [MT] IDEDistribution: Step failed: <IDEDistributionSigningAssetsStep: 0x7f95696e5c70>: Error Domain=IDEDistributionSigningAssetStepErrorDomain Code=0 “Locating signing assets failed.” UserInfo={NSLocalizedDescription=Locating signing assets failed., IDEDistributionSigningAssetStepUnderlyingErrors=(
“Error Domain=IDEProvisioningErrorDomain Code=9 ““Boat Minder.app” requires a provisioning profile.” UserInfo={NSLocalizedDescription=“Boat Minder.app” requires a provisioning profile., NSLocalizedRecoverySuggestion=Add a profile to the “provisioningProfiles” dictionary in your Export Options property list.}”
error: exportArchive: “Boat Minder.app” requires a provisioning profile.

So it’s just not connecting to Xcode 9.

Xojo 2017r3 will not compile an iOS app with Xcode 9. Although Xojo might have stated it was compatible when releasing 2017r3, it is not.
It is a bug that was talked about on the forums last year.

mon dieu. Now What!

Werner, I found this from Xojo store:
All Xojo licenses purchased from the Xojo store are covered by a 90-day money back guarantee.

Anyway even if 2017r3 could compile with Xcode 9 it still isn’t compatible with iPhone X. The only solution is to use Xojo 2018r1