Why are these textfields blocked?

I can’t figure out what is happening here. In a window I placed 4 text fields. They have no code, neither does the window. Still it is not possible to click in them as if they are read-only. They only unlock when I click for a moment to the main window and then back to this window again. What is happening? I created a new project with only this window and the fields are still blocked.

They are not here (Ventura, Xojo 2022.r3)

The third and fourth Fields are inverted when Tab to go to the next field…

I don’t understand what you mean with “They are not here”, Emily.

Also, I am running Xojo 2022 r2 on Ventura, but that should not make a difference.

Your question was:

Why are these textfields blocked?

and, no, they are not here: (they are not blocked, so I cannot comment) I was able to type text in them, and using Tab go to the next TextField.

Emile (no y) is a guy.

What is the problem?

Thank you Beatrix.

I do not understand too (what is the problem?)

Sorry for the name misspelling, Emile.
I checked and indeed using tab isn’t a problem, the text fields do work normally. I tried only accessing them by mouse click, and that doesn’t work most of the time, only after switching between the main window and this window.

The first click (in the top EditField) worked fine too.

I don’t understand what you mean with “They are not here”

He means ‘when I open your project, they work correctly for me’
and Beatrix too.

(Looks like Xojo has changed the file format so much I can’t open it on the machine I’m typing on /sigh/ , so I can’t offer an opinion myself)

Try clicking in every field.

Done, same good result (no trouble).

BTW: I printed the project to pdf and I do not saw any code in it beside the button that display that window.

Quit all your running application,
have a drink (orange juice for example),
reboot and fire / execute Xojo onlt.

I ran the project in Xojo IDE. I do not compile it.

Jeff: these are DesktopTextFields, so 22r2.1 is unable to open the project (I wrongly double-clicked on it…).

What Xojo version are you using?
What OS are you using?
I can replicate your problem using Xojo2022r3.1 and macOS Mojave 10.14.6, but I think is related to dark mode, see:
ezgif.com-gif-maker (18)

Edit: Anyone know what background color should we select so dark/light mode works?

You’ve set the background color to #FDFEEA which is slightly off-white, so the text area is not behaving correctly for dark mode. Set the background color to #FFFFFF and it behaves correctly for dark mode. Alternatively, set the text color to slightly off-black.

Credit to Alberto for sleuthing about dark mode, wouldn’t have looked without his screenshot.


Pure white for the background #FFFFFF and pure black for the text #000000


I am using Xojo 2022 r2 on Ventura. Still cannot get passed this problem.

I am not using Dark Mode btw.

If you’re not talking about how the text is showing up white on white in dark mode, could you show us the problem? If you don’t have a screen recording software of choice, QuickTime Player can.

1 Like

Here is a video that shows what I am experiencing. First I try to click the text fields in my app which only is possible when switching between the main window and the “pillars” window. Then I do the same in a project that only contains this window. I can only enter the text fields with the Tab key, but not with a mouse click, except when switching between the main window every time. There is no code on these fields or the window. It really feels as if they are set to Read-Only.


OK, now I see something else happening. Even though I cannot click in a field which normally would show the flashing mouse cursor, I do can start typing and text appears in the field. So the problem is more that the cursor sometimes shows and sometimes it doesn’t when clicking in a field. This is still confusing for a user who doesn’t use the Tab key. Any idea why the cursor isn’t always showing up?

Looks like a problem in/with Ventura. Testing your project (build with 22R3.1) under Monterey, the input cursor is visible when you click in a textarea. Under Ventura (macOS 13.1 Beta) it is not (or only in the first textarea which got the focus after opening the window).
But even if the input cursor is not visiblle, everything else works as expected - except focus ring.

Don’ t know if this is a bug in Ventura or if Xojo has to do/could do something…

But, who will wait to get the insert cursor before typing text ?

In the last years, I got a multitude of different cursors <> than the one it must be, and I continued to work ignoring the bug (in those case, it was a bug; I think at Gimp, but maybe this appeared in other applications…)

When I want to edit a text, I click in the Text zone and start my edit (add or delete text…).

NB: I totally do not know what a newbie think at this stage. This may depend on how (s)he learned to use a computer. Some teachers have strange sayings (“Do not use the keyboard” is the latest thing I heard in this area… “but I wanted to go to the other entering control…” was the answer…)