Ventura 13.2 (a) (22D7750270d) crashes Xojo

Xojo stopped working on my Mac today. I think it auto-updated to macOS 13.2 (a). I’m getting an unhandled OutOfBoundsException when launching Xojo.

  • This is happening with 2022r4, 2022r3.2, and 2022r3.1.
  • 2022r2 just quietly crashes.
  • 2022r1.1 and older appears to work.

Is anybody else seeing this?

macOS 13.2 is beta… wait for stable version. and go back to 13.1 that was stable :wink:

1 Like

Very probably the same as this:

Unfortunately it isn’t entirely beta related. I believe it is related to the fast security update which will be rolling out to general releases in the future.

@Roger_Meier are you able to un-install the fast security update ?

@Jeremie_L How do I do that?

A hard crash is not an unhandled OutOfBoundsException. Could Xojo do a check for the macOS version on start up?

@Roger_Meier : do you see any information in the Console before the exception?

1 Like

I don’t even know if it is possible.
It seems on iOS that rapid (supplemental) security updates can be removed, you might have the same kind of option in macOS system settings.

Did you open an issue for this?

Almost 100% guaranteed. First reason, Xojo caches this info, so the inexpensive way is just getting that info once at init time, and using it for the entire runtime lifetime. Second reason, Xojo probably takes different routes to solve some problems depending on the OS version at runtime, that will demand a System.Version inspection.

So, I installed MacOS 13.2 Beta (22D5027d).
Xojo 2022r4 launches without plugins and can build an app.

Now I added 51 MBS Plugins.
Xojo launches without crash :slight_smile:

My Xcode Test project crashes only around 10% of tries (2 or 20 runs). So Apple may have fixed some of those bugs, but maybe not all.

1 Like

Did you also try with this update?

1 Like

I can install that. I thought this update is just a training to see if security response updates work.

After a restart, I run into the same OutOfBoundsException error as others:

Stack Trace:

Xojo 2022r4 fixes this for iOS but not macOS as I feared :pensive:

So we need an urgent patch release (2022r4.1) to fix this critical issue. But I’m also curious about what’s going on with


After the security update, and the fix done.


Well, let’s not just assume that he’s running the beta on his production machine. This is actually very good information. I’ve just reproduced this on my own 13.2 VM. And, by the way, this has also seemed to break all of my projects.

This one seems to cover it:

That might be “fun”, especially if it has to ultimately be fixed at Apple’s end. I mean, they broke it. :slight_smile:

It could also be something that Apple does in an unexpected way that’s still correct but Xojo’s checks have not considered this possibility. Then it would be a programming error on Xojo’s end, e.g. because the Apple docs were not fully understood or even read. Has happened to the best of us.

1 Like

Yes, the “it’s your fault because you were the last one to touch it” approach has its limitations. :slight_smile:

Almost the same problem occurred in the Xojo iOS framework weeks ago. Xojo fixed it, Xojo end, not considered an Apple fail. I do expect the macOS case being almost, if not the exact same problem; as Apple is integrating many mobile APIs into desktop and sharing code between platforms.