Unable to install (but only on some device)

I see a bunch of other posts about this, but this might be a bit different.

I have been able to build and install on my iPhone. I’m not using a wildcard.
However while I have been able to do so in the past, I cannot install onto my iPad. My iPad is defined in my apple developer account as well.

Before I rip up the carpets and repaint the house, and do a bunch of other futile activities to try to solve this… anyone have any direction?

Since I have this problem and it has completely blocked my project after months of work: what happens when YOU try, are we seeing the same issue?

I drag the app into the devices window for the iPad, and it pops up a message “Unable to install (my app name here)”

Works fine with my iPhone. So strange. Nothing else really to describe.

Are you sure the iPad’s Identifier was added to https://developer.apple.com/account/resources/devices/list

And the same identifier was added to your app’s development profile: https://developer.apple.com/account/resources/profiles/list

On a mundane level , I assume yes but:
have you checked the iOS version on the iPad, do you have an iPad screen in the project?

It was added for sure.

iPad is up to date, and the build works great in the debugger.
I may just rebuild all my profiles (again);

I am experiencing the opposite. Unable to install message on my iPhone but installed OK on my iPad. Checked that the profile includes iPhone. Using software versions:
Xojo 2021r3 running on MacOS Catalina (10.15.7) to build app
Xcode 13.1 running on MacOS Monterey (12.0.1 to install app on devices
iOS 15.0.2 in iPhone
iPadOS is 14.8.1 on iPad

Makes me suspicious that the “15” version of iOS is the issue. Don’t want to upgrade the iPad and lose testing capability at this time.

I am having a problem also with trying to install on my iphone12. It was working fine before I updated to IOS15 so I believe the problem is there. I was hoping when I updated to 2021R3 it would fix the problem with a new compile but I see the same problem.
I was installing on Catalina ok before ios15 so I upgraded my laptop to Monterey hoping the latest Xcode would fix it but still no go.
I can install to my iPad running IOS14.7.1???

Are there any new plist requirements?

can you check the console.app (you can connect by cable phone/tablet and select them) to see the logs ?

I’ve had to kill my provisioning profiles and ensure that they were made with the device id. Have you updated your hardware?

I have not been testing yet, maybe later today. Did you add all Plist NS…UsageDescription values?

No Hardware updates. The message that comes up on the iPhone 12 when you try and run the App that worked before updating to ios15 is “The developer of this app needs to update it to work with this version of IOS”

This is my plist

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>NSPhotoLibraryUsageDescription</key>
	<string>Allow the selection of photos from the photo library.</string>
	<key>NSCameraUsageDescription</key>
	<string>Allow access to camera.</string>
	<key>NSPhotoLibraryAddUsageDescription</key>
	<string>Allow photo additions to library.</string>
</dict>
</plist>

Try to add NSMicrophoneUsageDescriptio. Just to be sure ?

https://developer.apple.com/documentation/bundleresources/information_property_list/nsmicrophoneusagedescription

Interestingly I can download the version in the App Store and run it but can’t drag that same version that I uploaded to the Store from my Dev Computer

Maybe someone more familiar with the IOS changes can say if there is something that the new IOS is demanding be done that the older IOS didn’t. Another thought, does the App Store make changes to the plist when you upload that would see the App Store version different to my upload version?

The biggest change is that we upgraded the SDK from iOS 14 to iOS 15, which is required to allow you to use declares against things that were introduced in iOS 15. This change sometimes has ramifications for older OSs.

The App Store itself does not change your plist, but building for the App Store does. If you want to be able to just drag a build to a device, you’ll need to do a developer build, without the App Store button checked. The App Store build does not allow for side loading.

Now what you could do is put TestFlight on your devices and when you upload, just make them available to your testers through that.

1 Like

I thought that might have been the issue but it is still the same if I change to Developer build. Just to add all these Apps have been previously installed on the device.

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.