Sonoma just broke my app

I tried to install my app on Sonoma - al lest that works,
however, I can’t access any file locations like I did previously (such as application support) - it doesn’t read or write to file directories… is this bypassable with sudo? The IDE doesn’t run on Sonoma (is doesn’t recognize AVFoundation… my software is music based… midi, etc…).
I am using xojo 2019r1 - before the graphic class went tits up and meant I had to address that and changedim to var etc…(lots of graphics). I got a lot of use from MBS products and everything works just great on Windows, but for my apple users, this latest update hurts my customer base.
any recommendations?

Sigh… you don’t have to change dim to var. Sonoma isn’t exactly new. Why haven’t you tested your app with Sonoma like starting last June?

Is your app signed and notarized? How do you read or write to files? There is nothing new permissions wise on Sonoma.

So the app is not notarized. And it crashes on start when I deny the connections with Little Snitch:

So I wanted to have a look at the software to see where the file problems are. But your app isn’t even HiDPI which makes my eyes hurt.

It’s tough to know exactly what’s going wrong in your app, but if what @Beatrix_Willius is saying is true, you likely need to put in quite a bit of work to modernize it. On 2019r1 you won’t be able to build for Apple Silicon either.

I can definitely confirm that AVFoundation and r/w access to Application Support still works on Sonoma, so there must be something else going wrong.

You will need to fire up Xojo on a Mac running Sonoma and work through it step by step (alternatively you can use the Remote Debugger). I would highly recommend updating to a newer Xojo version as well so you can compile a Universal Binary (2023 R4 also added some pretty serious speed improvements for Windows too). The platform licenses are on discount for $99 right now so maybe the stars are aligning.

Edit: Apparently there are some issues running Xojo 2019 R1.1 on Big Sur or later as well, as is being discussed in this thread. So it may just be time to bite the bullet and upgrade.

yep already discussed in this board. you can’t use xojo 2019 on recent macos
even ventura does not work with xojo 2019. I tried it in february last year and had to move to xojo 2023.
main rule: if you update your OS, then you update your dev tools at the same time …

Does this affect apps running the Xojo framework as well? Could it be that all OP needs to do is recompile in a new version of Xojo (probably needs new MBS license as well)?

from memory, you could debug but not compile, or the other way but something was missing.

Xojo has 2023 Lite for $99 right now.
Buy that, tick the ‘supports hiDPI’ option, and compile.
It should ‘just work’.

You don’t need to switch dim to var.
You don’t need to do anything API2, but the Xojo IDE will try to steer you there.

When it runs on your machine, turn off the internet, and see what breaks because it has no data connection.
If it doesnt work on your machine, what folders are you trying to access?
Specialfolder.applicationdata should be OK.
Most other places you need to be notarised to be able to access.
Do you have a Dev account at Apple?

I agree he should buy it, but it’s not going to just work, because he mentioned that he’s using the old drawing options in the old Graphics class. The IDE will throw an avalanche of exceptions when he compiles, and he’ll have to completely refactor the app to get things working again.

Not to overstate the obvious here, but this is why you should always keep your license current, and update your apps incrementally to work with language feature- and OS-changes as they happen. Once you miss years like this, you’ll probably end up having to rewrite your apps. The good news is, you get to figure out how to make it better than it was before.

1 Like

Hmm. I thought he meant the gubbins that was due to losing GDI plus.
It’s been many years since I had code that tried to do

Once that was out of the way, anything after 2015 was still ropey on Windows, but this is Mac, you are almost certainly correct.

Where to start:

  • The app is not native ARM (Apple Silicon). Users expect this nowadays.
  • It is not Notarised.
  • Some Entitlements are missing (for example to save files).
  • It is not HiDPI ready (any macOS app should be HiDPI from well before 2019).
  • Crashes when no internet connection is available. If it needs internet connection, make sure you ask the user before going forward.
  • Overall GUI is … well … not modern. It needs an overhaul for sure, I guess.

Back to the drawing board. :wink: