Some code changes are not saving in High Sierra

I’ve never seen this before, but today I lost almost two hours of work and I still don’t know why. Not all of my changes are being saved. Xojo isn’t crashing and I’m a fairly compulsive Cmd+S tapper — Xojo thinks everything is saved but it isn’t.

When I watch the view (it’s an iOS project) xojo_code file in the Finder, and I Save in Xojo, I can see the project update but the date/time on the xojo_code file does not change. When I quit Xojo — and Xojo doesn’t prompt to save because it thinks it has saved — and re-load the project, the changes in that particular view have not been saved.

This is in 2017r1.1 as I haven’t moved to 2017r2.1 for my iOS project yet. Tearing out what small amount of hair I have left…

Dropbox? iCloud?

I use Github for source and it doesn’t see a change either.

I still had a copy of yesterday’s project on my other computer (also running High Sierra) so I duplicated it as a backup and copied the offending view’s xojo_code file from that project into the current version.

But the same thing happens. I can save the view once and any changes made in that session (ie before saving) are saved to disk but thereafter no other changes can be saved. Two separate computers, both running High Sierra (with the patch that came out a few days ago).


If I open the copied project — before about 5 hours work today — then I can work with it and save incremental changes without any problems. So could something have become corrupted in my project? If so, how can I work out what that might be?

I wonder if I’ve got a similar problem to the one in this thread:? @scott boss did you manage to solve this?

I may have fixed it, or at least it looks promising. I can now:

Make a change -> Save and Quit Xojo -> Run Xojo and make another change -> Save and Quit Xojo -> Run Xojo and the second change has saved.

To get it to this point I deleted the project folder and Cloned the project again from Github (though this is the same version of the project which is not working on my other computer). I also switched to the all new version of the Github Desktop client.

I’m going to have to watch this sucker closely for a few days…

This is a macOS fault that reaches Xojo now as well.
Thanks for the warning.

Crikey. :frowning:

Maybe as a workaround, start your Git Client and see if the Changes have been Saved, befor you Close the Project?

Yes I think that is a good idea and I’ve been using it in this way, but it’s a helluva way to live! :wink:

I via iTerm created a new directory, copied the xojo code (not the .git repo) over to the new directory. rebooted (on a Mac I am not sure why I did that). and tried it on the new directory and it worked.

once it worked, I deleted the old directory. renamed the new directory to the old name. rebooted (again not sure why but I did anyways). and it still works. go figure.

Thank you Scott. That’s essentially what I did, though I just deleted the project folder and re-cloned from Git. The odd part is that the problem existed on two separate Macs after Github Desktop synced the code so I have been thinking that the problem must exist within the folder somehow, eg to one or more of the project items. Anyway I’ll try this at work today, keep an eye on it and report back again.

Just reporting back to say that the problem has not re-occured since I deleted the folder.

Different problem / Software, same kind of “feature”: saved image is incomplete on Sierra (not High Sierra):

In Preview: copy an image, pasted it into another (in another window), save and only the other is saved (png). Click outside the pasted one (to unselect it), save, worked once, but not all the time. Strange too.

BTW: for once, I do not installed the newly released (High Sierra) OS; I will download it sometimes in the future… (next month ?)

I wish I’d been more patient with High Sierra too. The file system change was a big one and, in retrospect, I should have waited a little longer.

Yes, but also the way how Apple imposed such a big change and basically assumed that us developers would do their beta testing for them in the 3~4 beta period is really not very responsible of Apple.

Apple should have NOT release APFS with High Sierra, but instead encouraged (or even rewarded) developers and consumers for helping to beta test it and then included it in their next OS update. They should have also made available a tool that can revert the disk back to HFS+. Apple knows exactly how few people back up, and that once the disk is APFS, the user is screwed if they need to revert to Sierra.

IMHO they simply don’t care anymore.

IMHO they act like everyone else on the Market now. I think we just have to live with this behaviour…

Don’t want to start a Win vs. Mac Thing here again. But at my Main Workplace i have to work on Windows 7 + 10 with 32 + 64bits and they have teir issues too. I am still very happy when i’m at my MacBook again… :slight_smile:

Don’t need too, in the last few years the Mac community is already divided, between those frustrated with Apple’s current direction and those who either haven’t been stung yet or refuse to admit that there’s trouble brewing for Apple.

APFS replaced a filesystem that was ancient and inappropriate for 2017. HFS+ has been around since the 80s.

Apple is doomed!! (Since 1976)

[quote=353781:@Gavin Smith]APFS replaced a filesystem that was ancient and inappropriate for 2017. HFS+ has been around since the 80s.

Apple is doomed!! (Since 1976)[/quote]
Don’t make the mistake of believing what I say is doomsday speak. So Apple replaced a 27 year old filing system, effectively overnight. You know and I know that there WILL be problems and Apple knows better than anyone the rate of consumers who backup before applying Apple’s updates. Yet they didn’t provide a mechanism for people to revert back to HFS, you know and I know they can. So what happened, a whole bunch of people clicked on update, it fucked up and now they can’t start their Mac, nor can they revert back to Sierra or whatever version of the macOS they were running before. The only advise from Apple is to wipe the drive and use internet recovery to restore the OS that came with the machine, thus losing all the customers data.

I’m sure that if you were one of these unlucky people, you’d not be making jokes.