Remote Debugging issue on R Pi

OK, so I followed the instructions to do remote debugging on RP (2007r1), the remote debugger is running, the IDE (MacOS) sees it, the code is transmitted across to the RP, but the IDE just hangs at the “Launching Application…” stage and nothing happens on the RP end. Any suggestions?

what kind of app ?

It’s a GUI app (not a console app). A window with a single “Quit” button on it. Nothing else.

make sure the stub is set to launch after receiving
that it has a writable location for apps sent to it

those are the only reasons I’ve seen this not work

if you start the stub from terminal you can see the messages sent to it and that may give a clue

Yes, the “launch after receiving” checkbox is set. The location for the received files is the desktop. The App file and folder of library items is being written just fine. Just doesn’t launch.

if you start the stub from terminal you can see the messages sent to it and that may give a clue

I’ve spent too much time on this. I need to spend my energy on something that works.

I and others have been using the Pi Remote Debugger for some time. I’ve not run into a GUI app not launching.

As Norman says, launching the Remote Debugger from the terminal will output debug info which might help pinpoint the problem.

You might also try launching the debug app manually from the terminal to see if that gives an error.

Did you place it in your home directory ?

file a bug report with the project attached ?

I cant help without any information like the log etc
The log might even show if there are missing dependencies for the app being launched

Right now I have nothing but wild guesses whats wrong as I have no other information to go on

I can confirm what Paul have said. I’ve used a lot Pi Remote Debugger and never run into a GUI app not launching.
Since you see the app on the PI try to launch it with the terminal within the Pi. Maybe there is something in the app.

Yeah, I’m not doing anything special on my Pi either. I have the Remote Debugger stop on the default users Desktop (probably not the greatest place for it) but for me, it just works.

All working fine for me too, except it cannot find the RPi with auto discovery. I needed to add the RPi manually, but at least it accepted the dns name for me.

The auto discovery thing isn’t new and I think there’s even a bug report about it

for me it worked first time, never had any trouble using it.

Raspberry Pi 3:

  • Wifi DHCP
  • network name setup (eg raspberrypiname.local)
  • debugger stub in /home/pi/xojo/

After starting up the remote debugger stub, and keep it running (GUI) it works without problems.

Any additional files are transfered from my mac using mountain duck and SFTP.

FWIW - Up until today, I wasn’t having any issues with the GUI and running debug on a Raspberry Pi. This morning I began using the new GPIO module. The app would not start in debug on the Raspberry. I would receive the status on my main system stating, “waiting for application to launch”. I removed the GPIO module and replaced it with the older one (without the classes) and I can get the debug to start. But now the app freezes while in debug. Oh well.

When I start the stub I receive the following:

StubLocator Error: 105
StubLocator Error: 105
StubLocator Error: 106
StubLocator Error: 105
StubLocator Error: 106

After the file copy
un-tarring / decompressing
launching the MyApplication for debug
Connection Closed

Then my keyboard, app and the stub are unresponsive - the app running on the main machine will not stop either.


is this a console app ?

Generally, if your app uses GPIO it needs to be launched using sudo (for Console apps) or gksudo (desktop app). That likely means you’ll want to uncheck “Launch app” in the Remote Debugger Stub and manually launch it yourself with the appropriate command.

Norman - no, GUI
Paul - tried again and it’s up and running.

I am starting to think like my users, “Isn’t there a button that just makes it all work?”
Where is the fun in that?

Thanks guys.