Problem while sending email from Xojo Cloud


I have deployed my application on XOJO cloud. I was having problem of email sending previously. I had solved that problem using MBS plugin. But from last month it was not sending email from XOJO cloud. It is working fine on local machine. I have tried many solution but not helped. I have also opened firewall port but does not helped. Please suggest me the solution for this problem.


i hope this helps

I tried 2 step verification process and added XOJO cloud in my gmail account, and it worked, The email is sent successfully from xojo cloud, but in my application the gmail account can change. So for every different account should i have to create an app-specific password? If yes then is there any other alternative for this?

I think that’s the only option with gmail accounts.

If you can use other accounts, you can check other smtp mail services.

What does log show for sending?

Firewall may block? password could be changed?

In the debug data for entering the password for Gmail account is :

[quote]535-5.7.8 Username and Password not accepted. Learn more at
535 5.7.8 a17sm17026230qth.17 - gsmtp

Yes, maybe you check the smtp password?

For gmail it works properly with app specific password.