Problem compiling a project on ChromeBook in the Linux Environment

When I try to compile, the Xojo IDE crashes.

Here the log when I run Xojo from the command line:

Xojo: /var/lib/go-agent/pipelines/LLVM/source/include/llvm/Support/Casting.h:255: typename cast_retty<X, Y *>::ret_type llvm::cast(Y *) [X = llvm::FunctionType, Y = llvm::Type]: Assertion `isa<X>(Val) && "cast<Ty>() argument of incompatible type!"' failed.
Aborted (core dumped)

Any ideas how I could fix that? I’m using the lastest v2022-4.1

My OS is a Debian. It’s actually on a ChromeBook, using the Linux environment which is a virtual machine of the Debian family.


Hi @Antoine_Beaubien -

Can you run 22r3.2 on that system?

Is it that particular project or any project?

If you can, try with the same project.

2021r3.1 does the same.

Every projects, even the examples.

Make sure that VM has all of the Debian prerequisites for Xojo installed.

Yep there’s a missing dependency as 2021r3.1 runs OK.

Just to make sure I was understood correctly: v2021-3.1 does NOT work.

And when I mean not work, it can’t compile, and it can’t even « Analyse this project ».

I have followed these instructions:

sudo apt-get install libc6
sudo apt-get install libncurses5
sudo apt-get install libstdc++6
sudo apt-get install libglib2.0-dev
sudo apt-get install libglib2.0-0
sudo apt-get install libsoup2.4-1
sudo apt-get install libgtk2.0-0
sudo apt-get install weston
sudo apt-get install rpm

How can I find what dependancies are missing?


I have installed a lot of programs, and they all work well.

Xojo runs until I ask to « Analyse this project ».

How can I find the Debian prerequisites for Xojo that are missing?


I have also installed llvm, even if I didn’t think it was the direct problem.

Please note that both versions I tried (v2022-4.1 and v2021-3.1) work to edit the code.


Start here:

About half way down the page, it talks about Linux and shows commands for the different platforms to get all the necessary parts.

Thanks. I hadn’t seen that part of the page.

So, I’ve also installed this, but didn’t help.

sudo dpkg --add-architecture i386
sudo apt update

ldd doesn’t seems to give missing librairies…

antoine$ ldd Xojo (0x00007ffc601cd000) => /opt/xojo/xojo2022r4.1/./Xojo Libs/ (0x00007e19a9191000) => /lib/x86_64-linux-gnu/ (0x00007e19a8fac000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a87fa000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a86f5000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a86e4000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a8692000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a8666000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a865a000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a8535000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a850f000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a8331000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a82d7000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a81a6000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a8063000) => /lib/x86_64-linux-gnu/ (0x00007e19a7f1f000) => /lib/x86_64-linux-gnu/ (0x00007e19a7f15000) => /lib/x86_64-linux-gnu/ (0x00007e19a7f0f000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a7f0a000) => /lib/x86_64-linux-gnu/ (0x00007e19a7ee6000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a7ecb000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a7eae000) => /opt/xojo/xojo2022r4.1/./Xojo Libs/ (0x00007e19a7afd000) => /lib/x86_64-linux-gnu/ (0x00007e19a7ae3000)
	/lib64/ (0x00007e19aba2f000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a7adb000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a7ac9000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a7ac1000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a7a8a000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a795b000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a793f000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a7926000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a783c000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a77f6000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a7733000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a772e000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a7523000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a7514000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a750f000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a750a000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a74c7000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a74be000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a74b9000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a74a8000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a7491000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a7486000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a73db000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a73a1000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a739c000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a736f000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a7360000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a7156000) => /lib/x86_64-linux-gnu/ (0x00007e19a7139000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a70dc000) => /lib/x86_64-linux-gnu/ (0x00007e19a70b0000) => /lib/x86_64-linux-gnu/ (0x00007e19a7094000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a7088000) => /lib/x86_64-linux-gnu/ (0x00007e19a7015000) => /lib/x86_64-linux-gnu/ (0x00007e19a6fed000) => /lib/x86_64-linux-gnu/ (0x00007e19a6f98000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a6f5f000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a6f33000) => /lib/x86_64-linux-gnu/ (0x00007e19a6f04000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a6efb000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a6eed000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a6ee1000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a6edc000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a6cd6000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a6c85000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a6bed000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a6b36000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a6b13000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a6afc000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a6a21000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a69fe000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a68dc000) => /usr/lib/x86_64-linux-gnu/ (0x00007e19a68cf000) => /lib/x86_64-linux-gnu/ (0x00007e19a68a9000)

This is my machine info. I seem to fill in the criterias.

antoine$ uname -a
Linux penguin 5.10.153-20432-gaa06ea936644 #1 SMP PREEMPT Tue Jan 10 19:07:58 PST 2023 x86_64 GNU/Linux
antoine$ hostnamectl
   Static hostname: penguin
         Icon name: computer-container
           Chassis: container
        Machine ID: 22c77650e7daeb44b74872c75febe8c3
           Boot ID: ec562481493948d79789614f904dbc78
    Virtualization: lxc
  Operating System: Debian GNU/Linux 11 (bullseye)
            Kernel: Linux 5.10.153-20432-gaa06ea936644
      Architecture: x86-64
antoine$ lsb_release -a 
No LSB modules are available.
Distributor ID:	Debian
Description:	Debian GNU/Linux 11 (bullseye)
Release:	11
Codename:	bullseye

Did you also do the line below that that says:

sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386 libglib2.0-0:i386 libsoup2.4-1:i386 libgtk-3-0:i386 libwebkitgtk-3.0-0:i386

1 Like

Yes, this line is not clear. But I did install them. I had a problem with:

sudo apt install libwebkitgtk-3.0-0:i386

So I added a source, and then, I could install it.

nano /etc/apt/source.list
deb stretch main

But, I still get the same error message from Xojo.

Any suggestions?


Contact @Jason_Parsley, I’m out of ideas.

I’ve created a Debian 11 VM

Downloaded the DEB install

Started the install and …

For my part, I install from the command line:

dpkg -i xojo2022r41.deb

With all the other installation as stated in previous comments.

My problem was VM too small. Need to build another one.

I don’t do Chromebook, can you tell me what software is used to virtualize Linux?