Older versions of Xojo on M1 Mac?

My new M1 MacBook Air arrived today. The first thing I did was install Xojo 2019r1.1 (I need this version for reasons I won’t get into here) and it refuses to launch.

In looking at the system logs, it appears that Xojo checks for a system version of 10.10 or newer, and fails so it quits. I’m guessing that when 2019 was written there was no expectation that OS X 11 would ever get released… so the logic just looks at the minor version, which fails in Big Sur because it is 11.0.

Is there any way to get 2019r1.1 to run on OS X 11 (Big Sur) - on either M1 or older intel chips?

I’ve read that Big Sur will report itself as 10.16 if you ask it nicely. Xojo may not be doing it correctly.

I think this version is the minimum.

Get Xojo 2019r3.2 for Big Sur.
For everything older use an older macOS version.

Even 2019r3.1 won’t work correctly on Big Sur. For desktop apps at least, 2019r3.2 is a hard minimum when running Big Sur.

1 Like

Well, that’s… unfortunate. :frowning:

Has anyone tried Xojo 2019r3.2 on a new Mac M1? Everything works fine? Is it fast?

It launches, it runs, it builds. What else could it do?

Congratulations. Did you also order a space heater for the cold winters, your MMacBook isn’t going to keep you warm.

4 Likes

Sorry, I haven’t followed the news recently, so Xojo 2019r3.2 is compatible with the new Mac M1? It works with Rosetta or natively?

Your plugins too?

Since Xojo 2019R3.2 arrived a loooong time before even the Developer Transition Kit became available my guess would be it uses Rosetta … :roll_eyes:

Xojo 2019r3.2 work fine in Rosetta on the M1. Plugins load, too.

1 Like

Ok, thanks Christian and Markus!

And thanks to the Xojo team for this compatibility!

It SHOULD just work with Rosetta. That it does not is a HUGE deal IMO for those who need to maintain backward compatibility!

While Geoff might be happy about 2019r1.1 not working on the M1, if Xojo inc wants to show they care about long term customers they should either

  1. allow the new release to save projects in a format (even if it requires a license fro the version) that can be opened in 2019r1.1 and also have a switch for API autocomplete to chose which API to show
    or
  2. If the issue with 2019r.1 is ONLY a system version check, Xojo Inc should at least fix 2019R1.1 so it can run on the M1 under Rosetta.
  • Karen
1 Like

Wow, look at this list of things that won’t happen.

They for Big Sur very rapidly. That’s 19r3.2. It was something like a week after the first beta shipped, if I remember correctly.

But you can’t expect them to issue new versions of every older version. How far back would they need to go? Won’t there always be somebody unsatisfied? It’s just an unfortunate fact of life. 19r3.1 and earlier just won’t work on Big Sur. I’m not 100% sure why, but they produce an compile error, in UIFramework if I recall correctly. Probably using something that was deprecated and Apple finally removed. It doesn’t really matter though. It’s not failing due to a simple check. You can launch it just fine. Console apps run fine even. But there is actually a problem.

This is why I always urge people to fix their deprecations sooner rather than later. You never know when it’ll matter. If it was a deprecation and they fixed it earlier, more Xojo versions would be working on Big Sur. But that’s not the case. It’s unfortunate. Find a way to deal with it.

2 Likes

Nope, as much as Photoshop doesn’t work properly and they have a few more developers than Xojo. And on Big Sur in general (ARM and Intel) they haven’t even achieved to change the black Creative Cloud Icon to fit to the new design … :frowning:

For whom? :roll_eyes:

:innocent:

Fixing why 2019r1.1 won’t work on the M1 system was the number 2 option… I would rather #1

But I don’t really expect them to do either because of how they did the API 1->2 transition and won’t let the the post 2019r1.1 IDEs save in a backward compatible format.

They pretty much showed that backwards compatibility was no longer important to them, even though it is/was to more than a few of the long time users (a number of which are now no longer customers because of it)

-Karen

A little update: Trying Xojo was literally the first thing I did as soon as I got the new user account created etc on the new M1 MacBook Air. The first 3 times I tried to launch Xojo it just completely failed to run, and in checking the console I saw error messages there which lead me to believe what I quoted above. Some time later (after writing the original post in this thread) I came back to that mac and had some messages about needing to install Rosetta so that Xojo would run.

It is a bit odd that it took several minutes for these prompts to appear, but it’s likely due to literally taking the computer out of the box, setting up a user account, downloading Xojo and trying it. The mac was probably still doing a bunch of first run junk in the background, and I simply beat it to the punch.

Once Rosetta was installed, Xojo 2019R1.1 will launch, but it will not compile anything, and I don’t expect Xojo to bring any official support to older versions - which puts me in a tough position. For now, I’m simply going to have to keep a Catalina mac available to compile this specific project until it can be fixed to build in the most recent versions of Xojo.

For anyone curious: my issues are not related to API2 (yet), but rather with UI/drawing issues both on Windows and on OS X. This project currently compiles correctly for Windows only in Xojo 2017R3, and for Mac only in Xojo 2019R1.1. To fix it, I’m looking at a pretty major re-write, and this is a massive project with a codebase nearly 15 years in the making. We’ve already begun a complete ground-up re-write using a completely different platform, but that won’t be ready for more than a year. In the mean time, I have to keep the Xojo version maintained. So I either bite the bullet and spend however long it takes to refactor my UI to work with more recent Xojo versions, or I keep a Catalina mac around just for this project. Since this is the main project I work on, that means I likely won’t be updating my daily driver mac from Catalina for some time. Sigh.

1 Like