Nothing Runs From IDE

Hi folks,

I’m a new user who has previously developed in VBA for Access and Excel.

I’ve downloaded Xojo, love what I see but can’t make anything run from the IDE. Nothing. None of the examples for desktop or Web. I’ve disabled Bitdefender and Malwarebytes and still nothing. I’ve uninstalled and reinstalled and still nothing. I get the debug window but no app.

I’m running on a HP Zbook, i9 with 16GB, Win 10 Pro and I’d love to start rewriting some of my Office-based applications, but I’m getting absolutely nowhere. Several of my colleagues at the university have also downloaded copies and they’re experiencing exactly the same situation.

I’d be very grateful for any thoughts / support you could give me?

Is this an app you have created yourself or one of the samples?

I guess the examples.

They did not run from inside the IDE? Without a license no executable is created, you just can run and experiment things as you may know.

Thanks Rick. I assume you should be able to run within the IDE, just not build an app? I really want to buy a license, but I’d like to try Xojo first.

Both. I built a little “Hello World” launching a message box from a push button, but that didn’t work (however, it compiled with no errors). None of the samples I’ve tried have launched either. They build but nothing appears.

Did you check Windows as the target ? When you say nothing run, do you get any error message ?

Correct, you can run but not build without a license. Have you tried running a default Desktop project? Check the Task manager to see if there are any debug processes around. Restarting the computer sometimes helps in clearing up stuff.

No. No errors and no app. Yes, Windows (or Web, depending on the example app) is checked in each case. Very strange.

Thanks, I’ll check the processes. I’ve restarted my machine many times during my attempts to get it running.

I think this case is so weird it may deserve a remote section from Xojo engineers to check by themselves as you said more people are affected.

I’ll check the processes and see what’s running. It is odd. As we all have the same laptop in our university team, it may be a HP issue.

Agreed, even a screen recording would be helpful.

1 Like

Make sure you have selected a target under ‘Build Settings’

1 Like

Central IT are looking at the machines tomorrow and I’ll check back then if they find the issue.

1 Like

Could it be 32- vs 64-bit build problems?

More than likely it’ll be a group policy that is stopping something like the execution of an exe from a temp folder. Try saving the project somewhere that you have write access, like your desktop or documents folder then try running it.


Good idea, you can also try Run Paused to verify that the app is being built. A folder with the debug app should pop up, then you can double click the debug app to verify that it actually runs.

Hi. We remain completely baffled. All antivirus and antimalware has been removed, all group policies have been suspended and Windows Defender has been disabled.

When we “run paused” the file appears but when it’s double-clicked, nothing happens. Can Xojo provide any support to get us up and running? We would grateful - and become customers - if we can get it running.

Instead of double clicking the debug version to launch it have you tried via a command line shell to see if any messages appear?

Sadly not. It just returns to the command prompt.