New Phone: Not showing up as Run On target; can’t install in Xcode


After upgrading to the iPhone 14 Pro (iOS 16), I can’t install the iOS app I’ve been developing, either through the debugger (“Run On”) or by dragging the built app to the device in Xcode (“Unable to install ‘My App’”) Everything worked fine with my iPhone 13 Pro and iOS 15.

My other Xcode iOS projects run and install without issue (e.g., the new device is registered, and the provisioning profiles are installed.

Running on the iOS 16 simulators works as expected.

Has anyone else experienced this issue with iOS 16 or new phones?


I built an app a while ago for diagnosing these things a little easier:


Run the app, select your device in the list and then drag the app (not the ipa) to your device. The text area at the bottom should have some details about what went wrong.

Don’t forget to build for the App Store.


Did you update your device list and development profile to include the UUID of the new device? I’ve got exactly the same problem – new iPhone 14 Pro on iOS 16 and I can’t copy it to the device or run it from Xojo on the device – and this is after updating my development profile.

1 Like

Had the same problem yesterday after installing iOS16. Had to activate developer mode on the device to make it work.


{Rant, but who else will listen?}
Been informed by some customers that my existing iPhone app suddenly doesn’t work properly on iOS16 and what will I do about it?

So once again, the almost yearly rigmarole of a new Xcode , new Xojo, certificates and provisions begins, then getting everything to talk to each other.
I’m {this close} to ditching iOS as a target.

Thanks, Greg, the error is 253:

Error: 253

To answer the other questions, yes, the device is registered, and developer mode is on: (The screenshot show my other Xcode installed apps in the background list.)

You have my sympathy, but I’ve been in the same boat with Xcode/iOS for 12 years—it doesn’t sound like a xojo-specific issue. Apple’s iOS updates can break functional apps, even ones made with native tools.

I tend to let Xcode manage provisioning profiles/devices/certificates now, so there’s less issues than a decade ago.

Oh yeah… not saying this is Xojo’s fault by any means
I just wish Apple would LEAVE IT ALONE for a while. :frowning:

1 Like

you need to add your device to and then add that device to your bundle identifier’s provisioning profile, then add that to your (iOS 16 developer mode enabled) device.

Then xojo can run your app (once you’ve selected Development build type) on device.

Thank you, that’s correct: The device UDID is registered on and attached to the provisioning profile. I’ve run other Xcode Obj-C/Swift apps on the same device, and it has Developer Mode turned on.

To test this bundle ID, I created a new iOS app in Xcode with the same bundle ID as the XOJO app and ran it on the device without issue. Then tried again to install the XOJO app on the device but received the same error (253)

Also: The iPhone 14 device doesn’t show up in the Run On menu; If something were off with the profile/cert, I believe that it would at least show up as disabled (grayed):

This trouble started after installing Xcode 14.0

Doing further testing, I can’t run the app on any of my other test devices (iPad 11", iPhone 6 Plus) which are still running iOS 15. I get the following error from XOJO: (Yes, the device is always awake and unlocked when trying to install.)

Yep, UDID is registered and attached to the development profile. Sounds like we are in the same boat.

don’t expect or believe anything, w’ve seen it all.

Anyway if you device is not on your current account, and provisioning profile (may require updated cert even) it won’t show up in the list. The bundle id must be online and have a provisioing profile installed on your machine.

Xcode 14 sdk cannot build for iPad os 15 as well, you must use Xcode 13.x sdk to compile for you ipados 15.x.

  • Try restarting your machine, that helps alot of times
  • Try loading all profiles trough xcode (this fixes issues sometimes).
  • Make sure you select the correct team in the xojo build settings
  • Make sure your build settings is set to Develop (xojo doesn’t do that automaticly when debug run on device… which one may expect.)

From Xcode14 and beyond, bitcode generation was removed by default, possible clash between Xojo way and current Xcode way?

There has been some progress, and some errors have gone away.

The main issue now is that XOJO cannot see the iPhone 14 Pro in the “Run On” menu.

Here’s where it stands:

:white_check_mark: XOJO can build and deploy on iOS 15.7 devices with Xcode 13.4.1 installed.
:white_check_mark: XOJO can build and deploy on iOS 15.7 devices with Xcode 14.0 installed.
:white_check_mark: Xcode 14.0 can build/deploy Obj-C/Swift apps on the iPhone 14 Pro
:white_check_mark: XOJO build apps can be copied to the iPhone 14 Pro through Xcode 14.0 or an app installer
:x: XOJO can’t see the iPhone 14 Pro in the Run On menu

in xcode preferences you’ve selected sdk 14 or before?

Sorry, do you mean have I selected the iPhone 14 Pro in Xcode before? If so, yes, I can build and run on iPhone 14 Pro.

Or the Xcode 14 Command line tools?

Same as here, and i don’t have any issues… Just checking.

Some steps i had to take:
Refreshed the menu?
Restarted your mac?
Checked your certificates?
Installed all xcode additional tools?
Turned the phone on developer mode?
Plugged the phone in with cable and checked the Provisioning profiles actually on the device?

  • Trough xcode go to view → devices and simulators check if your device has any profiles.

i’m not sure how xojo detects this but i do remeber once i double clicked my updated provisioning profile of my device (with udid added) it started to work again.

Please forward this on the forum, so we can seen the “state” of your side.

1 Like

Does your phone appear in Xcode’s Devices and Simulators dialog?

Thanks, Greg. Yes, as described earlier, I’m developing and deploying other Xcode native apps on it. My main development environment is Xcode → iOS, so I’m certain it’s working properly.