Monterey 12.2

macOS Monterey 12.2 is out today. Anyone tried it yet? On one of my M1 mac mini test machines, 12.2 somehow managed to break USB - my Apple extended wired keyboard no longer works. I’m a little hesitant to do the 12.2 upgrade on my main work MacBook. Anyone else having positive or negative experiences?

No issues here. USB on a 14" M1Max works fine (both through the USBC ports and through a CalDigit T3 dock connected to one of them).


that is good to hear as I use the same dock

Well for me it was a bad idea, i wish i could go back and revert this update. So far after update on my M1 Mac mini after update , double click is messy, after a while it does not work anymore, apps don’t open anymore , projects don’t load anymore as they should be , sadly those people break more the os instead of fixing it, but what to do. i guess we have to wait for a new version.

I wait then :grin:

And 12.3 beta isn’t any safer too.

I did 12.2 on my main macbook and everything is fine here, guess I got lucky?

Also, the problem with the USB keyboard not working on the M1 mini went away - I guess the solution was “power it off for 36 hours” and that somehow fixed the USB system??!


You’re not alone in having successfully installing 12.2 on a M1; it went fine here, too.

1 Like

We have it now on all Macs. Works just fine.

But please remember the rules:

  1. Make a backup. Time Machine and/or a clone via Carbon Copy Cloner and/or Online Backup.
  2. Check beforehand that you are not running out of disk space (20 GB or so needed!) or battery while updating.
  3. Don’t install first week after release. If there are heavy bugs, someone will find them.
  4. There is always someone on the internet, where it fails. Often due to point 2.

Enjoy your Mac!

1 Like

To the people with lucky M1:
what is the M1 model ?
(first flood or second flood holding colored iMac, 14 and 16"…)

14" M1 Max, 32/1TB (built to be the same as the base config 16" M1Max).

M1 Mac mini, 16 GB, 1 TB. No problems with macOS 12.2

Dropbox has send me an e-mail they will come with a solution/fix asap.

Had one weird thing happen since upgrading to 12.2: using BBEdit to edit a bash script file, after saving it, when trying to execute it in Terminal it wouldn’t run. Turns out it had the quarrantine flag, which I could clear using the xattr command. But why? And even weirder, it was sporadic - I could Edit and save and execute the file 10 times using BBEdit, and only 2 or 3 times did it get quarantined. Bizarre.

I stopped using BBEdit when switching to Apple Silicon. The first versions did crash a lot. Maybe that’s solved now but I’m now using TextMate. Pretty good alternative.

Well; I assume the crash got fixed by Bare Bones or Apple since BBEdit runs fine here.

Please update to 12.2.1.
Looks like Apple fixed a zero-day bug for WebKit and you may not want to have someone take over your computer with some malicious code delivered via an ad-network on your favorite website.

1 Like

here 2 customers (different) imacs intel with no activable bluetooth anymore since 12.2
tricks for reseting bluetooth or smc or pram did nothing
reverting to 12.1 did not make bluetooth back
reverting to 11.6 did make bluetooth come back…
not trying finger-crossed upgrading to 12.2.1…

1 Like

By default App Sandboxed applications add the Quarantine flag to files. You have to add an additional key to disable this functionality. If you use App Wrapper, the option is on the Capabilities pane.