Migrating an App from Real Studio 4.3 to Xojo 2019

Hi There,

I have developed a desktop app using REAL STUDIO 4.3 back in 2011. Now when Mac OS X Catalina will stop running 32 bit apps I am trying to use the Xojo 2019 r1.

I am dealing with a Syntax error on the app name what seems very strange because is just a single word to describe the app.

There I have:


Super Application
Interfaces Choose


Default Window SENAMAX
Menubar Menubar1

When I press RUN I get LNSENA.name with an Issue Syntax Error LNSENA

I have tried to change the app name without any changes getting the same Syntax Error Message

Do you have an idea of what is happening?


If you have a syntax error in an impossible place, the project is corrupt in some way. File a feedback case and attach the project so that Xojo can fix the issue for everyone. It might be best to include the original un-Xojo’d project as well.

Definitely provide the original RealStudio project.

Thank you Tim and Robin

may be ? : https://forum.xojo.com/conversation/post/413056

Thank you Jean,

Very tricky indeed. I couldn’t find the cause. Seems my case doesn’t matched the issues already addressed by you guys.

if the problem is in application name, you must try to change some field in the shared (or mac or win) properties, then compile, then revert back and most of the times it works. it may not be the field I moved that will be the same as yours.

Is the project saved as Text, binary or XML ?

TEXT or XML I might be able to read the project & tell you whats wrong

Binary is hunt and peck
Arbed might give you a clue

Dear All,

Following a basic advice from Jason starting from Real Studio 2011 4.3 I have tried Xojo 2013 r1, 2014 r1 and 2015 r1.

Both 2014 and 2013 Versions worked flawlessly but 2015 r1 has showed the following issues:

slow processing times,
progress bars, not working,
all the refresh actions ceased only final results display
Any thoughts? Cocoa implications?

Thank you

very possibly related to moving to the cocoa framework

Hi Norman,

I do think so, any shortcuts to improve that suffering?

Thank you

Dear All,

Just to let you know I have replaced all the refresh actions to invalidate… still no improvements


really depends on what you did way back then
drawing to the graphics of a controls is no longer allowed from outside its paint event

Hi Norman,

Thanks, of course it does depend but, on that specific app, there are no graphics drawing.


The only fast way to get a whole project updated is to hire a professional who can. If you’d rather do it yourself, the community will help you through the process by answering specific questions. But a general “how to” is very specific to how your old stuff was implemented.

Beware of shortcuts. Shortcuts are how you make more suffering for yourself. Every time I see someone take a shortcut when presented the correct way to do something, they are back with problems very quickly.

Thank you Tim

Hi everybody…

I have proceeded and here is the take away:

RS 4.3 2011 is the starting point
Xojo 2013 r1 has worked flawlessly
Xojo 2014 r1 as well

Xojo 2015 r1 cocoa 64 Bit here almost everything works, list boxes refresh and progress bar don’t…
Xojo 2016 r1
Xojo 2017 r1
Xojo 2018 r1

Xojo 2018 r4 the app doesn’t work at all and I get the Syntax error on the App.name as in the 2019 r1


RS 4.3 and Xojo 2013 / 2014 is the 1st block

Xojo 2015, 16, 17 and 18 r1 are the 2nd

Xojo 2018 r4 and 19 r1 are the 3rd where the app doesn’t work at all

Again, thank you

If you find a way to overcome what I am facing here please share.

I’m sure that, when you share some code that doesn’t work, people will help.

Post - some - code please? :slight_smile:

Hello J. L.,

You will discover that a lot of things that just “worked” in Carbon-based apps become very painful to deal with when you just hop over to Cocoa and 64 bit. Your app’s UI responsiveness gets tanked when you have long running background loops. If you used threads, you’ll run into the inevitable issues presented by “ThreadAccessUI” exceptions, even if just reading a UI control’s property.

One option that I would recommend is looking at 2016r3.3 as the “mediator” for moving your code from the old world to the modern Xojo environments. That is where I found the best balance between being able to at least debug/test my old projects so that they worked in the newer Xojo world.