MAS Application Loader XojoFramework ERROR ITMS-90334: Bundle identifier mismatch

Attempting to upload an app compiled with Xojo 2015r2, Application Loader 3.0 gives the following error:

ERROR ITMS-90334: "Bundle identifier mismatch. The executable at XojoFramework in has been signed with identifier ‘com.xojo.framework’ which does not match the bundle identifier 'com.xojo.XojoFramework’.”

Anyone else seeing this? I just filed a Feedback report and then realized I should have asked about this here first.

well, don’t you want to sign it yourself to have all the dylibs have same code signer?

If you use AppWrapper3 then uncheck “Use same identifier for all components” in the Code Signature settings on the general tab. Use one of the other checkboxes there.

Thanks, Torben - I use my own Applescript to prepare the app for MAS.

You’re right, Christian, I was able to force-replace the code signature, and this solves the problem:

codesign --force -s '3rd Party Mac Developer Application: My Name' *.framework"

I just found this line was missing from my MAS prep script :wink:


Since today I got the same error:

[2018-08-10 01:05:30 MESZ] DBG-X: parameter Success = false
[2018-08-10 01:05:30 MESZ] ERROR: ERROR ITMS-90334: “Invalid Code Signature Identifier. The identifier “com.xojo.framework” in your code signature for “XojoFramework” must match its Bundle Identifier “com.xojo.XojoFramework””
[2018-08-10 01:05:30 MESZ] DBG-X: The error code is: 1102
[2018-08-10 01:05:30 MESZ] INFO: Done performing authentication.
[2018-08-10 01:05:30 MESZ] INFO: JSON:{“msg”:{“phase”:“Upload”,“count”:3,“description”:“Operation failed”,“index”:3},“messageType”:“VerifyProgress”}
[2018-08-10 01:05:30 MESZ] DBG-X: Returning 1

In the current AppWrapper release 3.8.7 /256) the switch for “Use same identifier for all components” is unchecked and not enabled.

I don’t know what apple is checking this values. After 10 times to try upload to MAS it was now accepted.

Yesterday I got the same error while transfering my app to MAS.

[2018-08-10 01:05:30 MESZ] ERROR: ERROR ITMS-90334: “Invalid Code Signature Identifier. The identifier “com.xojo.framework” in your code signature for “XojoFramework” must match its Bundle Identifier “com.xojo.XojoFramework””
[2018-08-10 01:05:30 MESZ] DBG-X: The error code is: 1102

I must try 20-30 times to transfer my app to MAS. Has anobody the same problem?

did you sign the Xojo framework yourself?

I use AppWrapper release 3.8.7 (256).

Please make sure you do not have “Use same identifier for all components” checked in the Code signature Settings. :wink:

This setting is currently OFF and disabled in AppWrapper

Do the two items really differ in upper/lowercase?

Same result in 2018R1, 2018R1.1 and 2018R2

After AppWrapper:
Into folder “AppName/Contents/Frameworks”
codesign -vvv -d XojoFramework.framework

Format=bundle with Mach-O thin (x86_64)
CodeDirectory v=20200 size=46966 flags=0x0(none) hashes=1460+5 location=embedded
Hash type=sha256 size=32
CandidateCDHash sha1=eb4b09f1f763847593a85bf00351ef39098f3572
CandidateCDHash sha256=0524e92dadfeaa74483a7ed45263ebf06ac6a49c
Hash choices=sha1,sha256
Signature size=4812
Authority=3rd Party Mac Developer Application: H#### J#### (########)
Authority=Apple Worldwide Developer Relations Certification Authority
Authority=Apple Root CA
Signed Time=15.08.2018, 23:02:28
Info.plist entries=19
Sealed Resources version=2 rules=13 files=45
Internal requirements count=1 size=204

Before AppWrapper:
Format=bundle with Mach-O universal (i386 x86_64)
CodeDirectory v=20200 size=46898 flags=0x0(none) hashes=1460+3 location=embedded
Hash type=sha256 size=32
CandidateCDHash sha1=6c554ca060b6d8797b6a1e080b60b472f31c177e
CandidateCDHash sha256=590fa7fbbd375710727026b0541fdfeb7ef24a80
Hash choices=sha1,sha256
Signature size=8923
Authority=Developer ID Application: Xojo, Incorporated (########)
Authority=Developer ID Certification Authority
Authority=Apple Root CA
Timestamp=03.08.2018, 00:52:43
Info.plist entries=19
Sealed Resources version=2 rules=13 files=67
Internal requirements count=1 size=180

AppWrapper settings:

And also special parameter for packaging are not set.

My next application has the same problem. I think it is a problem from AppWrapper.

ERROR ITMS-90334: “Invalid Code Signature Identifier. The identifier “com.xojo.framework” in your code signature for “XojoFramework” must match its Bundle Identifier “com.xojo.XojoFramework””

I mean, I have zero problems with AppWrapper and listing apps in the app store. You should reach out to Sam by email if you really think it’s AppWrapper. Try to provide as much as you can to show why you think it’s AppWrapper, because if it is indeed, it benefits us all to get it fixed :slight_smile:

I am not at home for the next few days, so my ability to answer e-mails is somewhat hampered (am in Singapore for a friends wedding).

This problem has come and gone over the years, I don’t fully understand why either. Often when people have this problem, simply trying to resubmit at a later time, it goes through.

However I am assuming that somethings changed at Apple’s end and now they want it done differently; there is nothing I can do for the next few days and I’m sorry about that. I’ll be back home on Monday (at stupid o’clock) and probably be alive at some point on Tuesday afternoon. I’ll get right on to it then.

Okay, I am back and I’m looking into this. Are you still getting it?

Message Edited:

So I’ve checked the latest documentation, had to search to find it as they’ve not updated the documentation I was using and don’t link you to the newer docs. They have changed the procedure, I need to do a code audit before I can redesign how it signs Frameworks (they’re quite complicated and Apple’s docs over simplify).

From your e-mail I can see that you’re using High Sierra 10.13.6, but could you please tell me, which version of Xcode and which version of Xojo. I want to double check some things, to see if I can reproduce the incorrect bundle identifer and design my solution to make sure that it doesn’t occur any more.

I have tested it with App Wrapper 3.8.7, on macOS 10.11.6 with Xcode 8.2.1 and the bundle identifier is matching. I’m going to add some code to the diagnostics that will make it easy to see the code signed bundle identifier from within App Wrapper, also for it to check them.

Lastly, I vaguely recall that there is the ability to store a bundle identifier directly within an executable file, so I will check this too. Incase there is, and it’s different.

Xojo 2018R1.1 and 2018R2
xCode: 9.4.1 (9F2000)
Application Loader 3.7.1 (1047)
macOS 10.13.6