Listbox empty

I Have a project that when I run it in debug, everything is fine but when I compile and run it as a service, the listboxes are empty (they get populated from a sqlite db which I have in the same folder as the .exe on the final release. I am using port 8095 and made sure I allow communication on that port in Norton. Any ideas?

Do you also use the same SQLite file while debugging? Is the final build being run in the same machine you’re debugging?

Using Session.JavaScriptError, Session.UnhandledException and App.UnhandledException events to log any issue that could be preventing your listbox to be shown.

Check also the browser error logs, using the Developer Tools (each browser comes with some dev tools).

Thanks Ricardo, I used a different machine to run the final product using apache (which I didn’t mentioned since I can get to the app with reverse proxy). What I found strange is that I copied a fresh DB file to the folder and it started working which worries me. I will try the tools you suggested to see if I see something strange provided it does it again.

1 Like

It’s there a way you can debug it using the remote debugger?

I just did and is running normal on that windows 10 machine. Couldn’t duplicate the problem of not loading the listboxes.

Do you have any build step present only for debugging that isn’t present for final builds maybe?, that’s strange.

Ok, it just did it again out of nowhere. This time I tried to open two apps I made which involves the weblistbox and they are empty. Any ideas?

If I restart the windows service, it works

Is this happening also with Xojo 2022r4 or with previous versions?

I will recompile with 2022r4 and see what happens. It was built with 2022r3.2

1 Like

It did it again with 2022R4. I kind of did a bandage by adding a task schedule and restarting the service every hour to get it going but I don’t understand why is hanging like that intermittently.

Does your app cease to function in any other way when this occurs? It looks like the Listbox isn’t able to fetch data from the server, and if a restart is fixing this phenomena I would expect that other parts of the app are failing to communicate as well.

Are you comfortable with browser debug tools? It would be interesting to know what happens with the data requests. There may be info about the type of failure hidden in what happens to them.

@Tim_Parnell The app functions normal everywhere else. I can even add a new record to the database and everything. I can look into the browser debug to see as I have not done that yet.

Has anyone have had this issue? I recompiled with the latest version hoping it was fixed but still getting the listbox with no data. I then have to stop the service and restart in order for it to populate the list

Can you create a sample project that reproduce the problem?

Here is a sample. I have it on port 8083!AtMYYfHMLzClgbp7u2ikowwBtJ9KeA?e=9CfqlE

The database supplied in this project has no data just empty tables.

I’m so sorry. Please use user: temp888 Password: temp888 to “create a new user”. Then you can login and create a few records for the DB. Right now I have it running (without being a service" and so far so good.

I’m sorry, I can’t test running the web app as a service on Windows.

Does the SQLite database exist in a folder that requires credentials? Have you tried setting up the service with a username and password certain to have access to the database? Try setting up the service to use the same username and password that you use when running in the debugger.

If the server is on a domain make sure you set the user as domainname\username and if it is a local user then use: .\username