Linux IDE editor very slow

Hello all,

I’ve just installed Xojo in Linux (Fedora 14 & 18) and the editor is very slooooow. So slow that i must wait several second to see appear what i wrote. Other Linux distros shown this behaviour to anybody?

This never happened in previous versions (I mean RealStudio & Real Basic, not Xojo betas).

Anyone knows if there is some solution to this? or must open a case?

Best,

Please open a case, I’m sure we can do better, but it might depend as well. I know on Ubuntu 6.10 the editor is snappy, on Ubuntu 12.04 it’s not bad. On some other distros though I have seen some lag so we’ll have to do some profiling and see what we can do about it.

Done: feedback://showreport?report_id=27022

Thanks

Note, as i wrote in the case, that compiled apps works fine when typing (ie. in a TextArea)

Last night, while using Xojo in Mac OS X, I was able to get the editor in a state where it started behaving very slowly : about 1/2 second delay per keystroke. If I see that again, I’ll try sampling the process and report what I find. This may, or may not, be related to the behavior on Linux…

I have seen this before, but only when another tab has an editor open or you’ve recently been in the structure editor. It’s definitely not ideal and a bug report should be filed if you can narrow it down.

In my case, I had 2 projects open at once. I don’t think I’ve seen it (yet) with just a single project open. These projects are VCP and have a number of shared external XML items, if that matters. I definitely had not used the structure editor, though.

I don’t think multiple projects affect it, just multiple tabs/editors/windows for the same project.

I have the same problem, Im using Ubuntu 12.04. Xojo is extremely slow.
and an strange problem that i had even using Real Studio 2012r2.1 and is present in Xojo Studio is that Right-Click Menus (IDE usually, not compiled apps) take a long time to appear, and Menu appears from where you clicked, so if a button at the bottom of the page has an menu (just like setting button of Library in IDE) the menu is not use-able at all. but in windows if menu has not enough space at bottom, it will be shown up to top

(Sorry for my bad english)

So it’s not a Fedora / Gnome3 issue. If i get some time i’ll try OpenSuSE and perhaps Mint.

A Video of runing Xojo Studio on Ubuntu 12.04 LTS: http://bayanbox.ir/id/4912389652583419225

System Info:

[quote]CPU: Intel® Core™ i3 CPU M 370 @ 2.40GHz
Memory : 3 GB
Ubuntu:
Release 12.04 (precise) 32-bit
Kernel Linux 3.2.0-45-generic-pae
GNOME 3.4.2[/quote]

Xojo is very slow (including the editor) for me on Ubuntu 12.10 32 bit.

Trying it on Debian 6. Painfully slow

Tried OpenSuSE 12.2 x86_64 also slow.

Running CestOS x86 6.4 as a vm configuration and:

  • Take long time to launch Xojo
  • Working in the IDE is quite fast
  • Take long time to compile solutions

Dennis, CentOS 6 (x86_64) is the first platform i tried and is very slow when writing in code editor (not GUI designer). Is it fast for you?

Very slow on Mageia 3 as well… i can edit some lines (delete, down arrow, delete, etc) and I can get so far ahead it takes about 2-3 minutes for Xojo to catch up and display the changes.

Jos,
It’s doing OK for me.

Such a shame that RS had this makeover to Xojo… it basically sucks… I’m interested in coding not a fancy looking GUI

Code editor is very very slow with Xojo 2013R2 with Ubuntu 13.04 and i7 processor. The size of my Xojo Binary Project is 5,7 Mo.

The editor is so slow that I can not edit the code correctly !!!