libgstreamer and libxine

Looking for help from my linux guru friends. I’m trying to play some video on ubuntu 16. All 64 bits, both ubuntu and the built app.

For testing, I just built a simple app with one window and a movieplayer. I started the app from the terminal so I could see the console output. When trying to play a movie file, I have 2 messages:

Incompatible version of libgstreamer
Cannot find libxine

followed by a nice Segmentation fault when I quit the app. I guess there are some libraries I should install, and I have used the apt-get command to install stuff, but I don’t know what the package names are.

Anyone knows what I should install?

this is what I have in Ubuntu 16.4 (32 bit)
no xine

MoviePlayer opens a new Window playing a video, does not play in the Xojo MoviePlayer Window.

Same on my side. The movie plays fine in the Movie app installed by default, but not in Xojo.

I have long given up using the MoviePlayer in Xojo - Linux.
It has never worked, not with music, not with video.

Try installing libgstreamer0.10-0
Video plays in an app window here on Ubuntu 14.04 64bit
No play/stop etc controls though… but it’s a start

No updates in this subject? Movieplayer in Linux/Raspberry not usable?

Have you tried installing gstreamer? Some steps are described here:

Yes, I did that, but still the same problem. I am using debian wheezy for raspberry pi.

No, I’m afraid it’s just Linux that’s not usable :wink:

Linux as a server is fine

On the desktop there’s too many distros, too many choices & too damned hard for the average person.
It’s still primarily an environment for geeks by geeks.
Even then what works well on one may / may not work on another.

But what if you did it, and it does not help?

I would have no problem if in the description would be indicated:
‘Do not use this in Linux’

Edit: I’ve decided to rescind my comments. My attitude toward select issues is best left to other outlets.

looking into whats up with Raspberry Pi is on the TO DO list
I have no idea what, if anything, has been found

I agree with @Axel Schneider

[quote]I would have no problem if in the description would be indicated:
‘Do not use this in Linux’[/quote]

But MediaPlayer does not seem to me a nonimportant part of Xojo. Or an unused feature…

But thats not generally true
Its only on Raspberry this seems to be an issue as far as I know

Linux ? Linux ? Linux and thats the fun part

It is not a huge problem that the MoviePlayer does not work, I can play videos and audio in the HTMLViewer.

I am trying to create a video player/looper, I don’t believe that HTMLViewer and HTML5 allows me to get the end of the movie and start another one… does it?

It does, Vine did.

@Alexandre Amato

here is an example for playing videos from a ListBox in HTMLViewer.