Language Reference broken in Xojo 2013r2 ?

Hi, today I’ve made a update to 2013R2.

I had Trouble with my License Keys. I’ve removed 2013R1 & 2013R2.

After a new installation (tryed 2 times) of 2013R2, the Language Reference does not work properly (I use the local reference).

A search for 'Listbox" give the right result for the Listbox, a click on the CellAction Event is a link to an folder in my temp Directory, but this Folder dos’nt exist there. All links in the local reference point to this not existing Folder…WHY???

When I use the Online reference, all works fine. But i’m not allways ONLINE…

What OS ?
This is the first report I’ve heard of this type about the new LR in R2

I use Windows7 64-Bit

Odd as I’m pretty sure that Robin also uses Windows 7 - 64 bit and I don’t know that he has issues.

Please file a bug report with all the relevant details about OS, language you’re running, memory etc and we’ll have a look into this.


I just tried 2013r2 on Windows 7x64 with the local LR and I do not see this. The local pages are coming up as I expect.


I’ve tried a complete install again with:

a) delete the temp Folder files
b) removing all XOJO apps (Feedback, 2013R2)
c) delete all temporary Internet files
d) a new download 2013R2 (English only)
e) a reboot of the System
f) a new Installation of 2013R2

the same behavior… tomorrow I tried this again with deactivating Virus scanner etc…

I’ve done a complete new install of 2013R2, but the Problem still exist.

I’ve found out, 2013R2 create all needed Files in the temp Folder, but there is a “index.html” file with the size of 0 Bytes.

I’ve updated the case above.

It Looks like LR fails by creating the "index.html’… But WHY???

The size of the Installer File XOJO2013R1ENsetup.exe ist 181 MB
The size of the Installer File XOJO2013R2ENSetup.exe is only 131MB

Now I’ve installed 2013R1 again, LR works fine by using 2013R1. A search for ‘Listbox’ is mutch faster in R1, in R2 it is verry slow, but the broken links by using LR in R2 are still present.

Index.html just has to exist
It actually has no content

And yes 2013r2 SHOULD be that much smaller - the LR IS in fact quite a bit smaller

AH I suspect that having this installed on D:\ IS the issue


[quote]Index.html just has to exist
It actually has no content[/quote]

OK, I’m not familiar how LR generate the Output.

I’ve this Problem on 2 Computers, both have the same enviroment, OS on C: UserFiles on D:\Benutzer\UserID

But I do not want to change, because that would be a lot of work.

I understand
It’s on my list to investigate

I have an odd question but where is Feedback installed on your machine ?
Is it in C:\Program Files\Xojo\Feedback ?
And does clicking the tool bar button that starts feedback in the IDE work for you ?

Feedback is in: C:\Program Files (x86)\Xojo\Feedback
Xojo is in: C:\Program Files (x86)\Xojo\Xojo 2013r2

Clicking on the tool bar starts Feedback, this works.

For more understanding:

Win64 is installed on C:
Userprofiles are located in D:\Benutzer
The System uses a Temp Folder in D:\SysTemp (set via System-Enviroment Variable TMP & TEMP)
EveryUser has an temorary Folder in D:\Temp\UserID (set via User-Enviroment Variable TMP & TEMP)

Did you find a solution to this problem? I have been on 2014r1.1 for a day and all of a sudden the LR stopped working for me just showing the Save as button
this is on Windows 7 SP1 64-bit.
Have tried to reinstall Xojo 2014r1.1 but no improvements.

solution is to visit the docs in a browser :slight_smile:

Windows 7/8 and have never seen this issue. …well once in 2012, but it was a webkit issue.

I actually received the following from a gentleman this morning regarding software that has works, and suddenly stopped (this I believe is a webkit problem that arose from an update? Possibly?)

Every time when I run the program now I get the following messages:

Could not load libWebKit

Could not load libGtkHTML

Segmentation fault

Note: I have libWebKit and libGtkHTML installed.

I’m using Ubuntu 12.04 64bit

…xojo software not using htmlviewer/webkit loads fine for the

This is Linux, but usually updates to webkit ate distributed cross-platform… And suddenly for this to reappear makes me wonder. …

Yeah, as long as you have a working Internet connection this is fine. The off-line version of the LR is also broken with the same problem. Well… well…

Do you have more than one version of xojo on your system? The older references still apply :slight_smile: for instance I have 2008 to current on my dev system…a different reference may work

Well, in theory… I tried to find the Window property GrowIcon that went missing somewhere between 2012r2.1 and 2014r1.1 :wink:

GrowIcon was removed in 2013r3. And was deprecated years before that. Use Window.Maximize instead.