Installing Big Sur as guest on Parallels

I finally figured this out last week and posted it to the Parallels forum. I figured I’d cross post it here as well as many of us use VMs for testing new systems, etc.:

For those who have been trying to run Big Sur as a guest OS in Parallels, this solution is clean and works:

First, I did this in Parallels 15 for Mac “home edition”. I’m running on a 2017 iMac w/ 32 GB RAM with Mojave as my system OS

Also, I saw almost every different error that people have been reporting and this method avoided all of them (so far, at least)

1. Make an installer DMG from the downloaded “Install macOS Beta” app. The technique to make one is available via Google but I used the one described here: It’s a series of 6-7 command line strings but not too tough

2. Get the correct board_id and hw_model information about your particular Mac:

  • In Terminal, on the Mac that’s running Parallels type (or copy/paste)
    ioreg -l | grep board-id
    ( that’s a dash and lower case L, then the pipe character, FYI )
  • copy the Mac-xxxxxxx text for use below
  • then type:
    sysctl hw.model
  • copy the hardware model string for use below

3. Create a New VM in Parallels. Don’t try upgrading a previous macOS version VM. Also, unless I state otherwise, leave settings @ their default

  • click the + button or select File->new in Parallels control center
  • select “Install Windows or another OS from…”, click Continue
  • select the DMG you created in step #1, click Continue
  • name the VM and check “Customize settings before installation” & click Continue
  • Parallels will open its familiar Configuration dialog:
  • click the Hardware tab:
  1. I set the RAM to 8GB and processors to 4 - but I was being a bit paranoid. I think processors @ 2 is probably OK
  2. for Graphics, I set Memory to 512MB with “Scaled” graphics - again, being a bit paranoid, not certain 512MB is required
  3. for the Hard Disk, open Advanced Settings, click Properties and increase the size to 128GB. Click Apply, then Close
  4. in Boot Order, open Advanced Settings and copy-paste the following lines: (note, Parallels failed to save these lines a couple of times until I copy-pasted them one at a time and hit return after each line - go figure. If your install fails, double-check this setting)

(replace inside the quotes with your mac model from step #2 )


(replace inside the quotes with your mac board_id from step #2)

  • close the Configuration dialog and click Continue
  • follow the instructions for normal installation going forward
  • while it’s installing, call your parents and check in. they worry
    *** Note - do NOT install Parallels Tools at any point. This is what results in the “stuck at black screen”, the “won’t let me log in, just kicks me out” problem and probably other issues. It’s also one of the reasons why upgrading a previous macOS VM fails as it probably already has Parallels Tools installed. Like me, at this point you probably just want to get Big Sur running and can live without PT until Parallels updates it.

Many of the above steps and information was gleaned from other intrepid users posting to various forums and others and I thank you all.

regards and good luck
Steve in Seattle
(not nearly as crazy here as some have reported)

Instead of step 2 getting your machine’s specific model and board IDs, this simpler method also worked for me:


as the only entry needed in the Advanced Options of the Boot Order for the VM. The above is what Parallels support team suggested in a thread on their forums – found after I had failed to get the other method you install.

That said, the VM was VERY slow when trying to load up XCode 12 and iOS 14 Simulator. It was better when I assigned 8GB to the VM, but the simulator was still slow enough that trying to run a sample demo app from WWDC 2020 using the Vision framework never detected what it should with the sample video also supplied by Apple.

I suspect the combination of Big Sur, XCode 12, and iOS 14 Simulator really needs over 8GB to be productive.

One other thing: though I didn’t have the problem, several forum posts had people not able to get lowercase t or y, or digits 1 and 2 to work without setting up keyboard maps in Parallels. The suggestion is when installing Big Sur do NOT use t, y, 1, or 2 as part of a password until you have the VM up and running and those keys tested or remapped as needed. For me, all those keys still worked.

Some also reported they could get 1 and 2 to work if they used the Fn key.

Great step-by-step instructions, thank you!

2 days ago, I tried to upgrade a 10.15 VM anyway (removing Parallels Tools prior the move), it got stuck at the login screen (no input doable). I tried the steps from Steve and am stuck with a very-similar issue.

So, creating the DMG and using Parallels’ assistant went smooth. Then, the VM started and I saw the progress bar. Now, I have the “Choose language” window shown, waiting for my answer, but, like with the upgrade try, I can’t input anything. If I click on the VM window, the focus is brought to the VM (I have to press option and control to exit out of the VM), but my arrow pointer stays at the top-left corner and the keyboard does nothing either. So, the VM waits there…

Parallels Desktop 15, too.

Any idea?

I didn’t have any trouble with my trackpad or keyboard, but I read where some had trouble with all or some of these keys: t, y , 1, 2

But for some it worked to hold down the Fn key while doing it; not for others. So try the Fn key if you have one. You could also try the settings icon for the VM and try each of the popup options for the Mouse & Keyboard in Settings > Hardware > Mouse & Keyboard though I don’t really see how it will help. But from that tab you can also define shortcut preferences for that VM, and those with the problems with t, y, 1, 2 said they could make a shortcut of those keys mapped to the same value and then they worked. So you could try to define a shortcut for the return key or other keys you need (maybe your password characters?).

Unrelated to Parallels, but I had a similar BT keyboard issue installing Big Sur on a mac mini. The BT keyboard that was paired while it was Catalina worked fine all the way through the install of Big Sur. But then the final boot into BS got to the login screen and the keyboard did nothing. Tried all the various things like removing all USB devices and having the keyboard in pairing mode during power on or restarts and never got the detect BT keyboard pane. Eventually had to scrounge up a wired USB keyboard to get past the login panel. Then the BT settings page didn’t list my keyboard but would offer to pair it and I could unplug the wired keyboard.

But try defining a shortcut for the return key in the VM > Settings > Hardware > Mouse & Keyboard > Open Shortcuts Preferences and see if you can get past the login.

Yes, I also saw several posts about this. My issue isn’t only with some keys, it’s the whole keyboard/mouse that won’t work (the same result as if you kill the hidd process on a working Mac, actually (don’t do that, you’d need to force-shut down the computer then; hidd is what handles all input devices; I also think it includes remote desktop software (not sure))). The Fn key and other workarounds won’t probably work since it’s not a “translation” problem.

I’ve started to try changing various settings in this VM (5 at a time, then reverting when I see nothing changes). I’ll have to persevere, since I gave up too early, having something else to do.

Smart idea, indeed. At least the arrow keys, the tab and return keys (so the setup assistant would hopefully be useable if this trick works at all).

Was this on a clean install or an upgrade from Catalina?
If the former, I’d bet for a driver problem; if the latter, a preference setting may possibly have been corrupted…

I’ll and post the result here; thank you!

It was an upgrade from Catalina, but after a clean install of Catalina. The BT keyboard was paired and working in Catalina, and worked through the whole BS install until the login screen. To get past that I had to find and use a wired keyboard. Guess I should keep one of those around. (For those with a Magic Keyboard 2, you can also plug a lightning cable in and it acts like a wired keyboard. I only had an original magic keyboard and third party BT keyboards readily available.)

Granted, wired keyboards are just required from time to time; they are just using less drivers and no pairing, and are therefore more reliable.
My guess is the first start to the login screen had reset the pairing (perhaps as the initial setup process?).

I was able to upgrade an existing 10.15 VM by following similar steps to above. Make sure you remove/uninstall Tools from the VM before downloading the upgrade from Apple. Make sure you create an new Administrator level account not attached to your icloud account and have a blank password on it as well as all existing accounts. Once you have successfully upgraded you can add back passwords.

Thanks for your advices.
Yes, I removed the Parallels tools when I tried the upgrade path; the other path (a fresh install) produced the same symptoms, so it’s definitively not a Parallels Tools issue (or perhaps a “lack” of the tools, but why would it work for the other users, then?).
As for the password tricks, I don’t even get a chance to enter anything after BS is installed, since the inputs are unresponsive.

Sadly, it was still the same issue. I defined these shortcuts: Option-Shift-S for Down, Option-Shift-D for Right (and so on) and Option-Shift-Q for Tab and Option-Shift-E for Enter (not sure they aren’t over-complicated shortcuts, but simple ones are already used by the OS/app/etc.). Sill nothing happened.

Then I tried another way: one can configure the “Keyboard” sub-menu from Parallels’ preferences (where you can send keystrokes using a menu item, instead). I defined a “down” menu item, but it failed too.

What I find strange is, under the “General” tab of the VM’s settings, Parallels reports around 1.5 GB of used space, only used by drivers (for the VM where I’m stuck at the language chooser, fresh install that has not yet began). In my previous attempt, it even showed only “18 MB” of hard disk used space (no driver space at all).

It’s perhaps just a “bad install”, but the other VM, where I upgraded from an existing Catalina VM shows the exact same symptoms (no input handled). So it’s not a unique issue…

sorry, out of suggestions - I had no keyboard or trackpad issues with the VM for Big Sur

And yet it happens to me 2 of 2 times…
I’m aware my configuration isn’t officially supported (Mojave running on a 2008 Mac Pro), but I fail to understand how this could be related. That’s the only thing I expect to be “rare” enough on my setup resulting in no one experiencing the same issue. I don’t have a supported Mac at hand anyway.

I’ll try again, re-downloading the installer, perhaps…

Thank you, Douglas, for all your suggestions and help.

I did forget to mention that you need lots of disk space available in your VM and have expanding disk turned off. I would have all the above settings in place in your VM before you request the profile and download the installer. That is what I did and it worked without issue.

Oh yeah – forgot I had to do that too. I allocated a fixed 100GB to the VM during the install, but had read that 90GB is sufficient. After the VM was installed and running, I went back to settings and enabled expanding disk again. Don’t recall if I needed to also do the option to reclaim disk space or if I immediately had my boot OS get the extra space back. But it was a temporary thing to need 90+GB for the install.

Interesting. I’ve got expanding disk enabled and my VM is working just fine.

I only needed to disable it during the install. According to the forums, you should have 90GB or more non-expanding during the install. But it seems when it comes to installing the beta BS in the current Parallels VM, the idiom YMMV applies.

has anyone tried installing PT after the initial set up or does that also ruin the VM ?

All the forum posts I have seen say currently installing PT hangs.

There’s clearly some sort of bug in the installer: I tried to install Big Sur on real hardware, and even though I had X GB of free disk space, the installer kept failing saying I needed Y, and Y was less than X! I eventually just installed it on an external 512GB SSD.