Installing Big Sur as guest on Parallels

Parallels Tools are working here.

Just for clarity, I used createinstallmedia to create a bootable USB stick. Yes it took about 3hrs total, but it did work for me. I then created a new VM and used the USB stick as the source with Customize VM turned on so I could add the boot options. I also turned off the option for parallels tools to be automatically updated and expanded the HD to 128GB. Once it installed, I set the password to “aaaaa” so i would have an easy way to get in if there was a problem. I later changed that after validating that everything was running fine. I also suggest setting the video memory to at least 512MB. it was a lot less jumpy for me once I did that.

I also suggest making VM snapshots along the way.

Tried with a fixed disk and got the same issue.
Then, I tried with Virtual Box. There, it started in verbose mode automatically (like always with Virtual Box, go figure), eventually showed the welcome screen (“Choose your language”) and was stuck like with Parallels Desktop (mouse integrated in the VM, but wouldn’t react, like the keyboard).
Now I know it’s not specific to Parallels.
I downloaded the Beta installer twice, so it’s not because of a corrupted installer. Hard to find what remains possible…

My next attempt will be to try on another computer (a 2013 MacBook Air) using Virtual Box. Parallels Desktop is hardly an option on multiple computers.

I was able to get Big Sur installed on VMWare and I haven’t had any issues with it even with VMWare tools installed. Compiled apps have been stable so far. I haven’t gotten an IDE compile to work yet because of some post build path issues in our project.

My experience gets more weird…
I discovered another difference between installations on my main computer (where I can’t input anything in the 11.0 VM) and the one where it worked.
When the installation starts, the Apple logo is normally shown over a grey background with a progress bar (that’s what I saw on the computer where I could install BS). On my main computer, the background of that step is black (clearly 2 different colours, not a ColorSync difference).
Looks obvious both issue would be related, but how? What can I conclude to find the underlying problem?

Finally solved my problem (I hope for a long time).
I could start in safe mode (adding arguments to the VM) for installing, but once a window asked me to choose the language, the same problem would happen: no mouse, keyboard or other input would work.
On the Web, I stumbled across forums regarding another problem with BS on virtual machines, where the solution was to use this:
open -a “Parallels Desktop”

I didn’t expected this would work, as my problem was another one (and seems unique [in the world]). Eventually, I tested anyway and… it’s currently being set up!
It’s still started in safe mode, thought. Not sure at this point whether starting with SYSTEM_VERSION_COMPAT=1 only (no safe mode) will work.

I’ll finally be able to try BS… :slightly_smiling_face:

There is a new version of Parallels, v, which fixes most known issues with Big Sur. Their knowledge base article is here .

Has anyone tried to install BS on VMWare? After my recent fun I’m not too keen on updating a physical machine.