I thought others may find the following useful as these are the steps I took to get both Xojo and LiveCode working on my Ubuntu 13.10 64-Bit machine (I am evaluating both of them). I’m not sure which steps apply to which product but it won’t hurt to run them all…
- Install Synaptic Package Manager by running -> sudo apt-get install synaptic
- Open Synaptic Package Manager, select Settings->Repositories, click the Other Software tab, click Add button and put
deb http://archive.ubuntu.com/ubuntu/ raring main restricted universe multiverse in the text field then click OK, allow it to update then exit.
- sudo apt-get update
- sudo apt-get install ttf-mscorefonts-installer
- sudo apt-get install gksu
- sudo apt-get install libgtk2.0-0:i386
- sudo apt-get install libpangox-1.0-0:i386
- sudo apt-get install libpangoxft-1.0-0:i386
- sudo apt-get install libidn11:i386
- sudo apt-get install libglu1-mesa:i386
- sudo apt-get install gstreamer0.10-pulseaudio:i386
- sudo apt-get install ia32-libs
This installed a ton of i386 libraries (particularly the install of libgtk2.0-0:i386) and I expect a lot of them are not needed but what the heck, I have lots of free disk space.
This is some excellent research and would actually apply for many of the other Debian-based distros. But, change that Synaptic repo line to a code section so it’s not URL-ized by EsoTalk -
deb http://archive.ubuntu.com/ubuntu/ raring main restricted universe multiverse
This should be made sticky.
I’ve tweaked the original post to fix the URL problem and made it sticky. I’m also reviewing it to see if I can get this into the docs somewhere.
Xojo still has a problem installing the feedback application (i.e. it doesn’t install) and the documentation doesn’t work. Not sure how to fix that.
If Feedback and the Language Reference window do not work then that would imply that libwebkit is not installed…
Thanks Paul. I’ll check into that and post an update.
Paul, there seems to be a conflict with GnuCash. It appears that Xojo and Gnucash want different versions and they cannot coexist.
Very odd as the versions have very different names, so you should be able to have both on the system. It seems that the webkit DPKG author took the shortcut.
I guess the $64 questions is - do you actually use Gnucash?
In that case, we need to know what version Guncash requires -
Run an 'ldd" on the gnu cash binary and see what it reports. We may be able to simply rename the require .so files so that both can coincide.
Here is what the Ubuntu Software Center reports when I try to install libwebkitgtk-1.0-0:i386
The following packages have unmet dependencies:
Depends: libatk1.0-0 (>= 1.12.4) but 2.10.0-2 is to be installed
Depends: libc6 (>= 2.11) but 2.17-93ubuntu4 is to be installed
Depends: libfontconfig1 (>= 2.9.0) but 2.10.93-0ubuntu1 is to be installed
Depends: libfreetype6 (>= 2.2.1) but 2.4.12-0ubuntu1 is to be installed
Depends: libgail18 (>= 1.18.0) but 2.24.20-1ubuntu1 is to be installed
Depends: libgcc1 (>= 1:4.1.1) but 1:4.8.1-10ubuntu9 is to be installed
Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but 2.28.1-1ubuntu2 is to be installed
Depends: libglib2.0-0 (>= 2.37.3) but 2.38.1-0ubuntu1 is to be installed
Depends: libgtk2.0-0 (>= 2.24.3) but 2.24.20-1ubuntu1 is to be installed
Depends: libicu48 (>= 4.8-1) but 18.104.22.168-12ubuntu2 is to be installed
Depends: libjpeg8 (>= 8c) but 8c-2ubuntu8 is to be installed
Depends: libpango-1.0-0 (>= 1.22.0) but 1.32.5-5ubuntu1 is to be installed
Depends: libpangocairo-1.0-0 (>= 1.16) but 1.32.5-5ubuntu1 is to be installed
Depends: libpangoft2-1.0-0 (>= 1.16) but 1.32.5-5ubuntu1 is to be installed
Depends: libsoup2.4-1 (>= 2.39.3) but 2.42.2-6 is to be installed
Depends: libsqlite3-0 (>= 3.5.9) but 3.7.17-1ubuntu1 is to be installed
Depends: libstdc++6 (>= 4.6) but 4.8.1-10ubuntu9 is to be installed
Depends: libxcomposite1 (>= 1:0.3-1) but 1:0.4.4-1 is to be installed
Depends: libxdamage1 (>= 1:1.1) but 1:1.1.4-1ubuntu1 is to be installed
Depends: libxml2 (>= 2.7.4) but 2.9.1+dfsg1-3ubuntu2 is to be installed
Depends: zlib1g (>= 1:1.2.0) but 1:1.2.8.dfsg-1ubuntu1 is to be installed
Tim, ldd output is too long to post.
Yes - but what does Gnucash say it needs? I’m specifically interested in the version of libwebkitgtk that’s listed.
I do a lot of symlink hacks in these situations since quite often the newer lib is fully compatible with the older lib and all that you need to do is create a symlink from the current version’s .so to the name that the other software is expecting.
I personally don’t have gnu cash installed anywhere, so I can’t pull this myself.
Tim, here is what it reports…
libwebkitgtk-1.0.so.0 => /usr/lib/libwebkitgtk-1.0.so.0 (0x00007febb0e22000)
That’s very curious since the only diff would be the i386 part which should not conflict.
I have some time over lunch and I’ll update my Ubuntu VM and install gnucash to see where it takes me.
OK, my testing indicates that the above steps are no better than simply doing:
sudo apt-get install ia32-libs-multiarch
The multi arch install gives you everything you need to run Xojo except libwebkit 1.0, which so far I’ve had no luck getting to install.
Attempting to manually install it using this:
sudo apt-get install libwebkitgtk-1.0-0:i386
results in a bunch of dependency errors and an eventual “will not install” message.
These are the errors I get trying to install libwebkitgtk:
So I then manually downloaded these packages individually. Attempting to install them manually displays scary messages like this:
For Ubuntu 13.10 64-Bit, by default there is no ia32-libs-multiarch available for installation so you would have had to do something to get apt-get to see the package.
Anyway, I get the same errors as you and have given up getting it to work.
My previous post was not clear. I have given up trying to get help and the feedback program to work. Other than those two things, Xojo seems to be working fine.
Sorry, I was using 12.04 x64. I’ll give it a try with 13.10 x64 as well.
So many Linux distros…