Fonts Different Sizes Different Mac's

I have an app where I consistently have my fonts being System and the point size 11. All my customers have a similar interface experience AFAIK.

However, I recently did an experiment where for a ListBox I set the Font to “Arial Bold” and the size to 10. I liked the look of it, as it was small but clear. (I also set it on some Labels on my splash screen.)

I didn’t send it out to anyone except one tester I was working with, and sure enough he complained that the font was too big and looked funny. I had him send a screenshot and his font size was more like 12 or 14 on the areas I put the different font on. I asked him if he set his Mac up any differently and he said no. I asked him if he had the Arial Bold font on his machine and he said yes.

Why could this be happening?

I’ve run into funky font problems on the mac before where some software installs new fonts named the same as existing fonts (Office for OS X, I’m looking at you!) that cause conflicts.

You can use the FontBook application to look for and eliminate conflicts in the fonts on your mac.

OK, perhaps part of this is because I never use our Mac’s for layout or printing or anything else. Using Font Book, I don’t have a font specifically called “Arial Bold”, but I have Arial and it has a Bold attribute. I guess that’s an attribute, it says Bold when the Arial font is expanded in Font Book.

So, on my Mac, why is it that Arial Bold looks like Arial Bold, when i don’t have it listed (specifically) on my Mac? Shouldn’t it default to System? But, if I enter Arial in REAL, and check Bold, I get a Arial that looks bold, but it’s not as bold as “Arial Bold”.

Please continue to help! I don’t know what I’m doing but I’d like to know what is happening.

In FontBook, go find your Arial font, then the bold variant. Right click on it, and say “show in finder”. For me, this opens /MainDrive/Library/Fonts, and highlights “Arial Bold.ttf” in that folder. There is a .ttf for all the other variants of Arial (i.e., there is an “Arial Narrow Bold Italic.ttf”)

What do you get? The same thing?

If that all looks good (i.e., you have a bunch of .ttf files for the arial family that matches the list in FontBook for the variants, etc) then go back to FontBook, and select the whole Arial family, then hit the File->Validate Font menu. That may reveal some issues.

Now, if everything looks as it should on your mac, then repeat the same procedure on the other mac that is doing the testing that has the font size issues.

Not saying this will definitely reveal the issue you are seeing, but it is a good diagnostic step: make sure the fonts match on both machines.

If FontBook finds issues with the Arial family on either mac, correct them and try your testing again.

Oh, also, you can specify “Arial Bold” as the font name in Xojo, without checking the “bold” attribute. I’m not sure, but I bet that checking the bold attribute does not actually select the sub-family font, but rather just fattens up the rendering of the original font you choose.

It could also be that it just looks wrong. When you change the font on something, our brains tend to take notice.

Is there a specific reason you’re not using System or SmallSystem?

Thanks, good point - I think it’s the other way around, mostly.

I put this change in two areas of my program (again, just for an experiment). I set TextFont to ‘Arial Bold’. I did this because there was an app that had this font and I really liked the clarity. I found the font name was ‘Arial Bold’ by some weird circumstance (I think looking at their log files). At least I THOUGHT the name was explicitly ‘Arial Bold’. And in my computer it looked fine - in REAL, in the IDE, and in the compiled app.

My tester noticed it immediately and made a complaint, saying it was too big. So, in my busyness, I changed it in one of the spots to ‘Arial’ and then checked the Bold attribute. The other area it’s still TextFont=‘Arial Bold’.

I asked my tester last night what Font Book said on his system. My tester replied this morning and said firstly the one area where I changed it to ‘Arial’ now looks okay. The other obviously still doesn’t. Additionally, he noted that when he validates the Arial font in Font Book, it notes that he has Duplicate Fonts.

So now my working assumption is that dictating ‘Arial Bold’ works to indicate ‘Arial’ with the Bold attribute, but it’s not a bullet-proof thing to do. Apparently the Mac will fail to substitute properly if there’s enough of a conflict. It looks like that’s what is happening to my tester. It looks like being as specific as possible with the font name for the TextFont (and not relaying on it to pass attributes, unless it’s actually part of the name) and using the attributes is the best way to go.

Thanks Kimball for the direction.

Because the System font sucks. =) No, just kidding. I made a Point of Know Return decision a while ago to use 11pt fonts in part because I wanted a sleeker look; that is a smaller proportion of screen size to font size. It just looked better. But recently, the lack of clarity of the System font with 11pt bugs me a bit. There’s an app that recently came out that has that and it looks awful. Thus, now I think my app looks awful. =)

I don’t want to go to System, TextSize=0 because it gives me 12pt. So I think Arial TextSize=10,11,12 may be the way I want to go, it looks much clearer.

Hey, I KNOW that setting it to System has the blessing of HIG and that allows the user control, but I don’t WANT to give the user control. I want the app to look like I want it to look. Plus, this is in the music biz, where non-businesslike interfaces are normal, usual, and common.

BTW, I am using REAL 2011r3 and Carbon. I did notice that when doing Cocoa builds (on other apps), the System font for MsgBox and other things I think is Arial, not Carbonite =) or whatever the System font is in Carbon.

I’ve had to do this as well as I do have 2 versions of Arial both with bold variants & they are quite different in overall weight
One has a much thicker stroke than the other.

That said font handling under Carbon was mostly invisible to people and even if fonts didn’t have bold or italic variations installed Carbon’s engine would synthesize one. So you could set those attributes on any font & get a result

Cocoa’s text and font engine won’t synthesize a variant. So if you select Arial and try to set Bold it may not come out bold unless there is a bold variant installed. But, there are tools, like Kimball mentioned, that install fonts with the entire font name as “Arial Bold” instead of font “Arial” with bold, regular, italic and other variants.

In general this problem occurs because Arial <> Arial. For most of the common fonts (Times, Helvetica, younameit …) a lot of different font definition exist: By different foundries, from different OS versions, with different readability in mind (screen vs. print) … Just have a search for Arial at And there’s no real definition for a font size, meaning 12 pt Arial may look a lot bigger or smaller compared to a 12 pt Times.

If you want to keep a consistent screen design, it’s probably best to deliver a font with your installation, and preferably one that is not usually installed by the system to avoid font conflicts. On the other hand, there’s the licensing problem – and I’m not sure if Google fonts for example are not subject to change through the years.

There are other problems with delivering fonts with your software: Xojo has a hard time keeping things like the baseline consistent, reporting correct line heights, and generally getting things wrong when you do much custom work with fonts.

For example, I really wanted to use the OpenSans font from Google in a recent project, but found all sorts of wonkiness with how Xojo decided where to place the baseline of the font. This issue is not unique to OpenSans, and is common on many of my fonts.

See here:

[quote=72335:@Garth Hjelte]I don’t want to go to System, TextSize=0 because it gives me 12pt. So I think Arial TextSize=10,11,12 may be the way I want to go, it looks much clearer.
If you get frustrated with that, try SmallSystem with a size of 0.

Thanks for all your replies; Norman, Kimball, Greg, Ulrich, all others. Problem solved, looks like I’m equipped to go further!