Finally built app, but now can't install

Hey all,

I finally was able to get my app built. I created a Parallels Virtual Machine and installed Catalina and Xcode 11 on that. After doing some more messing with certificates and all, I was finally able to build the app with Xojo! YAY!

OK, but now when I try to install the app on my iPad, I am being told that Xcode can’t install it. I’ve tried using the Conifugrator2 as well. It appears to install it but when I go to the app icon, it tells me that it couldn’t be installed and to try later.

So everything should be fine - what am I doing wrong? It’s an iPad Pro (12.9"). Running iOS 13.6. I just upgraded to 13.6 hoping that would fix it (was on 13.3). But nope. Still won’t install.


Make sure that your iPad is one of the authorized devices in your development profile, and use Xcode to make sure that profile is uploaded to your iPad.

Yes and yes. So it’s not that.

Anyone got any ideas on this? I’ve managed to build a simple “Hello World” app and have installed that to my iPad just fine. But this app I have developed just won’t install on the iPad. I have tried creating several different App IDs with different entitlements selected thinking maybe I am missing something. I’m not sure. Is there some place that Apple tells you what is wrong? I’m just getting messages the app can’t be installed and to try later. So I’m very confused and frustrated. I’m behind on my work for my client and can’t get the dang app installed so I can do some final tests! I know it’s not Xojo related specifically but it is a Xojo created app. So looking for any help possible.

Do you actually have a Default iPadScreen inside the IDE setup ?
If it’s empty then you could get issues like this.

Just to be sure.

If I recall I had similar problems…

What if you create a new User on your Mac and build the app under that User?.. If that works then it is probably a Keychain/Certificate issue…

Also you may want to try this:

Before you try this make sure you have all your Keychains backed up! I cannot be sure that this will not make things worse for you as I do not fully understand what these files do… don’t blame me if things go haywire.

  1. Delete all your Certificates and Provisioning files from your account
  2. Open Keychain under “login”, “Certificates” find:
    Apple Application Integration Certification Authority
    Apple Worldwide Developer Relations Certification Authority
    Developer ID Certification Authority
    (also make sure there is only 1 copy of each… I had multiple copies in other Keychains which I deleted)
  3. Export all 3
  4. Delete them from your Keychain (right click)
  5. Reimport them by double clicking on the exported files.
  6. Recreate your Certificates and Provisioning files.

A screenshot of the actual error you’re getting when you try to install the app on your ipad would be helpful. There are lots of errors that could occur.


This is all I get!

try to open console and see if there is some kind of info about it
while installing it

Hi Jim,

I had thought about doing that, but I literally just created all these certificates and everything as this is a brand new install of Catalina in a Parallels Virtual Machine. And since I was able to install the HelloWorld app, I know that my certificates are good. That’s one reason why I tried that.

Apple’s console is such a disaster. I’ve tried searching for my app name. I did find some stuff at one point about Mobile Provisioning, but it was not very informative and it wasn’t updating after I tried further installs of the app. If someone could tell me where to look that might help, but I am not sure where to look…

i normally do “erase” all logs, then do the thing and try to filter it by bundle id for example.

That’s a good idea. I will try that…

did you use a wildcard or fixed bundle id ?


ok then that’s good

Make sure on the Apple developer site that you have a development provisioning profile for this app identifier and have enabled the device within that provisioning profile.

Yep. I’ve done it multiple times. Xojo won’t let you build w/o the profile.

OK. I just erased my logs and then did a search for my bundle identifier after attempting to install the app. Here is what showed up in console:

AMDeviceSecureInstallApplicationBundle (thread 0x70000dd26000): ENTRY, options: {
CFBundleIdentifier = "com.justaddsoftware.switch3";
CloseOnInvalidate = 1;
InvalidateOnDetach = 1;
IsUserInitiated = 1;
PackageType = Developer;
PreferWifi = 1;
ShadowParentKey = "file:///var/folders/56/1ph58gbx1rd0zslqz3pbh5w40000gn/C/";


The error you are getting I usually got when the device is not enabled on the profile as I described. Being able to build has to do with having you as a developer enabled on that same profile.