Feedback on pop!_os from System76.com

I tried to install the Feedback DEB but see the following error:

The following packages have unmet dependencies:
  xojofeedback: Hängt ab von: libwebkit2gtk-4 (>= 1.0.0) but it is not installable or
                               libwebkit2gtk-3 (>= 1.0.0) but it is not installable or
                               libwebkitgtk-3.0-0 (>= 1.0.0) but it is not installable

I am new to Linux. I tried to install libwebkit2gtk-4, libwebkit2gtk-3 and libwebkit2gtk-3.0-0, but none of it could be found using “apt install…”.

BTW: libwebkit2gtk-4.0-37 (2.28.4-0ubuntu0.20.04.1) is already installed.

Had the same thing some week ago with a desktop build on linux.
Did you try this one:

apt install libwebkit2gtk-4.0-37-gtk2

Not sure if this works, i can’t remember how i fixed it …

Yes, but it did not fix the issue. Thank you @DerkJ :slight_smile:

1 Like

Check this topic:

They are talking about libwebkit2gtk

you have libunwind8 right?

Yes :slight_smile:

this is the worst, on linux not finding packages while they are already installed… :sweat_smile:

I know this thread. The problem is that they have a massive problem in installscript of 2019 versions. Only way to run under Windows is to get the tar.gz and unpack it and run direct from folder. There is no chance to come around cause it leaks 32 Bit Support of the os within this it will never work like it should

is it a 32-bit system?

No the lib is still available for 32 bit that’s making the problems. I have 64 bit and cpu in all my systems 64 gab ram…

It is a 64bit Ubuntu Derivat

Even tried:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386 libglib2.0-0:i386 libsoup2.4-1:i386 libgtk-3-0:i386 libwebkit2gtk-4.0-37-gtk2:i386

But no… :frowning:

Anyway, it’s late and i do not really need it on this machine. I’m giving up for now. :slight_smile:

Take the tar gu file and unpack it to your user folder you can directly run xojo from there

1 Like

Today i made a new attempt. I extracted the tgz with

tar -xzvf Feedback.tgz

It resides now in the /opt/xojo/feedback/ Folder. If i start it as a User, i get a NOE. But if i start it with sudo, it works just fine (but looks ugly on my dark themed pop!_OS…).
I even moved it into /usr/bin/ and my home Folder, but still need sudo to beeing abvle to run it.

Xojo Style :wink:

You have to change the chmods for the files otherwise it tons only as root

You mean chown, correct?

sudo chown -R username /opt/xojo/

Did not change anything. The only error i see in the system logs is:

g_menu_item_set_detailed_action: Detailed action name ‘win.filter_Xojo Feedback’ has invalid format

Hm I’ll try tomorrow cause on Ubuntu focal it runs as user

1 Like

If Xojo Inc. would have only used the System Log… But you know, Feedback is this mysterious beast we shall not know too much about. :wink:

In the meanwhile i’ve created a FR: feedback://showreport?report_id=61925