Feedback 2016r1

For anyone that’s interested, we pushed out a new version of Feedback yesterday. Highlights include:

  • Mac version is now 64-Bit and updated for Retina
  • Linux version is now 64-Bit
  • Uses Xojo.Net.HTTPSocket throughout which means that it should work with more proxies
  • Windows 10 and Windows Server 2016 are now properly recognized

You can download the latest version from our website at: http://www.xojo.com/download/extras.php

Already downloaded !

Thank you !!!

‘About Feedback’ sais it’s still beta, is that correct?

Windows version not 64-bit??

Looks good and feels faster on OS X 10.11.6. :slight_smile:

Along the line of the ongoing discussion about redistribuable, installation of Feedback under Windows 10 Pro 64 is, well, kinda painful…

SmartScreen asked me first permission to install redistribuable 64, then again beep and permission to install redistribuable 86x, and finally re-beep, and permission to install Feedback. That is not very user friendly, to say the least…

Since Xojo works already fine on my system, I know these redistribuables are already installed. Is there no way to check if a redistribuable is already installed, to avoid this cumbersome procedure ?

Also, after entering the password, it takes OVER A MINUTE TO LOG IN ! If that was my app, I would find that unacceptable. Is it not really possible on Windows to use the much faster classic framework, until new framework delivers acceptable performances ?

Please check that you’re using the latest version. I’ve checked all of the downloads and can’t reproduce this.

Feedback isn’t something that benefits much from being 64-bit. It isn’t math intensive, nor does it use more than 3.5GB of RAM. If we do a 64-bit version, we’ll have to distribute two versions for Windows because many of our users are still on 32-bit versions of Windows.

It could be that the Feedback installer has a slightly newer version of the redistributable than we used in the IDE installers.

We’re working on the speed issue, but it’s tough to track down as we don’t have that issue here in the U.S., so we’re thinking it’s related to latency in some way.

OK. My Windows 10 system is US, and I connected through VPN in Miami.

Same issue. Over a minute to connect.

Previous versions connected in a dozen seconds or so. But as you forbid them to continue working, I cannot go back.

Based on (possibly faulty) memory, doesn’t Xcode include (or let you download) a tool that lets you emulate various network conditions?

The Xojo IDE is 32Bit on Linux, isn’t it?
Why should one develop on Linux (32Bit Distribution), but report on another system (a 64Bit Linux Distribution)?

In my opinion, Linux is (currently) the only Target which should have both 32Bit and 64Bit versions.

OS X doesn’t matter if 32/64Bit - both run just fine on current systems.
Windows is fine with 32Bit (for non memory-heavy applications), even on a 64Bit system.
Linux is quite a different beast… 64Bit Apps won’t run on a 32Bit Distribution. And running 32Bit Apps on a 64Bit Distribution is not very user-friendly at all, since the “32Bit compatibility libs” are gone on current systems…

It does, and interestingly enough, this bug ONLY seems to manifest on Windows. I even tried it using the Parallels network conditioner and the results were inconclusive.

How can we help debug that awful delay in Windows ?

[quote=283616:@Jürg Otter]The Xojo IDE is 32Bit on Linux, isn’t it?
Why should one develop on Linux (32Bit Distribution), but report on another system (a 64Bit Linux Distribution)?

In my opinion, Linux is (currently) the only Target which should have both 32Bit and 64Bit versions.[/quote]
As I said earlier, Feedback relies heavily on the HTMLViewer and it’s nearly impossible to the correct libs on 32-Bit versions of Linux.

What we really need is the 64-bit debugger… :slight_smile:

Unfortunately we are gradually making breaking changes which make the older versions obsolete.

Found it, you are right, i used the old version. This was caused by the fact that this version is installed in another directory:
“C:\Program Files (x86)\Xojo, Inc\Xojo Feedback” and it was: “C:\Program Files (x86)\Xojo\Xojo Feedback”

Just tried again to start this new feedback program and i don’t see the slow startup, the total start process including login and showing the My Top Cases list and the My Newest Cases list was within 10 seconds. I think it’s mostly a problem with a not too fast connection to the internet at busy times.

No, it is something else. Here the Mac feedback opens in a dozen seconds, and the Windows one in over a minute, on exactly the same Internet connection. Note that the beta did the same.