EddiesElectronics Web sample broken ?


using 2019 r3, I open Sample Applications/EdiesElectronics/Web/EEWeb.xojo-binary-project and saved it as PDC_V2.xojo_project,

When I click on Run, the IDE freezes on Compiling “WhiteBackgroundStyle” (70 of 70) . I tried saving it as a xojo-binary-project, same result.

If I open the sample and Run without saving as, it compiles properly.

What is the explanation for that ?


I can’t reproduce following your instructions.
Where are you saving PDC_V2.xojo_project ?

Hi Alberto,

Xojo is installed on the C: drive and I saved the project on the D: drive (not under the root). Windows 10 version is 1909.

Oh, I should have added that I used Saved As.

Are you saving it to a directory that is being handled by Dropbox, OneDrive, Google Drive or something like that?

I don’t have a Windows machine at hand but don’t think that should be an issue.

I am saving to a local disk inside the computer.

Tomorrow I will do this test: find the project under samples and copy the file where I wish to work with.


Did the test, just copying the project file doesn’t work. This time I used Save, but the same issue arrises. I browsed the project and found out that:

  • even though the project would compile it would not work for the reason that the SQLite DB is in a different directory in the Examples files and it’s not copied to the new location
  • on top of that this sample app is not ported to the new API, for example still uses a call to GetFolderItem().

Looks like chances to succeed are thin.

Do you know if this app properly ported to 2019r3 is available somewhere ?


Have you tried an older IDE and found it to work? This sounds like a permissions issue.

@Tim Parnell

If I create a new project and open the app, it will compile no problem. It’s only when I Save it elsewhere that it fails. I don’t get how permissions could cause a problem. I run Windows 10 with an administrator account, so permissions should not be an issue IMO ?!?

Gilles, some other questions:

  • is your OS in English?
  • do you use “special” characters like (other)?

I may be able to test on a Windows 10 machine later today.

The location the IDE builds to changes depending on whether or not you’ve saved the project. If the project isn’t saved, Xojo uses the temporary folder. If the project is saved it uses the location next to the project. Windows 10 has a security feature that protects your folders from ransomware attacks by denying running software access to certain folders. This would explain why you’re able to build unsaved projects, but not the projects you’ve saved.

This is only to explain how it could be a permissions problem. I don’t know that it is. Are you able to build for distribution?

If you think it’s related to the IDE version, then it’s a good test to check an older IDE version.

What are you copying? The Eddie’s Electronics project has a Copy File Build Step for copying the database (which is in another folder – go to Build Settings in the Navigator and then expand Windows to see it). It’ll find this file in the default location, but if you copy just the web folder then it won’t be able to find the database file. So either copy the entire EddiesElectronics folder or update the Copy File Build Step manually to point to the database file.

Using Save As from the IDE the Copy File Build Step is changed from:

[quote]/Applications/Xojo\ 2019\ Release\ 3/Example\ Projects/Sample\ Applications/EddiesElectronics/Database/Logs.sqlite
/Applications/Xojo\ 2019\ Release\ 3/Example\ Projects/Sample\ Applications/EddiesElectronics/Database/EddiesElectronics.sqlite[/quote]

[quote]…/…/…/…/Applications/Xojo 2019 Release 3/Example Projects/Sample Applications/EddiesElectronics/Database/EddiesElectronics.sqlite
…/…/…/…/Applications/Xojo 2019 Release 3/Example Projects/Sample Applications/EddiesElectronics/Database/Logs.sqlite[/quote]
depending where you save on your machine.

I don’t have another drive to test or windows, I guess saving on D: instead of C: is not changing/saving the path correctly and it can find the files.

@Paul Lefebvre

I realized that copying the project file would not bring all of the other files. So I used Save to copy on my D: drive. When I try to run that project saved on D:, compiler hangs forever on UI/Mobile/Styles/WhiteBackgroundStyle. I guess that if it would not hang that the copy of the database would work.

I installed 2019r3 on a Mac, and when I copy the project on the Desktop and Run, there is no hang on WhiteBackgroundStyle and the app works fine.

So it seems that the Windows version is allergic to that style, for whatever reason. Is there some way I can try compile to copied app and get a clue as what’s going wrong ?

I do not know. I have copied the entire Eddie’s Electronics folder on Windows 10 from the Examples folder to a new location in Documents and the web project runs just fine from the new location.

I made another test, instead of Running, I built, I should say tried to built, for Windows. Again I have a hang, this time at Build “My Application.exe” for Windows x86-64 . . . Linking .

Did you perhaps change the 64 bit settings to “Aggressive” ? Are you sure it’s not just taking a really long time - because that happens (especially with 64 bit).

@Tim Parnell

What do you mean by

I have let it go for 30 minutes, the progress bar still displays (Not responding).

I wonder if its hung trying to start the app by a firewall / anti virus and thats the last message that was shown ?


Gilles, what do you have in the Copy Files Build Step?