Control Background Color Unstable

Anyone else experiencing controls like textfield and textareas losing its default white color? Sometimes when I Run or compile, some of my controls become black or yellow. When it goes yellow, the color chooser next the the fields in the inspector shows a checkboard background (assuming it is clear). It is so annoying because I have to go and reset all of the fields back to a white background.

In case you are wondering, I have no code to change the background colors of my controls. Everyone of them uses the default.

I just ran in to this problem, It happened after i did a save as to the new xojo format. When looking at the raw project the color did not get saved. Editing any thing on the window then saving seems to have fixed it.

This has happened to me several times. Very annoying.

Yeah, I have reapplied my the background colors at least half a dozen times in my current Xojo test project (Xojo test branch based on an existing commercial app). Given that I have a lot of sheet and normal windows with lots of fields, this is becoming a huge pain in my rear right bumper. I don’t know what is triggering the loss of background colors, but it happens enough to say a few foreign words at Xojo (the product) with my kids around.


You’ve been Xojo’d. :slight_smile:

This just happened to me again. There doesn’t seem to by any rhyme or reason to it and I can’t reproduce intentionally. >:|

This happened again today - 6th time since this posting was created. I can’t reliably reproduce the bug as it seems to happen when it feels like it. Now I will have to go through all of my text-related controls and reset them back to white.

Happens a lot for me. Usually turning black - now every textfield has .backcolor set in open event to avoid this. Very strange but glad it is not just me and coding!!

My project cannot be Xojo’d because it is already dead at the hands of “Real Basic”. In other words, “Frying pan” did the job.

I just experienced a similar issue in an RS2012 project that had been saved as a new xojo_binary_project. After monkeying with some custom listbox row background colors, all the textfields and textareas in ALL other windows had a black background. WTF? My workaround was to just click in the affected window’s background color selector, then cancel it, then save. Huge PITA, since it happened a few times since in the same project.

Out of curiosity, how many of you are using the version control format ( as opposed to the binary format) ?

Version control format here.

We use version control format due to projects being worked on by multiple people through our repository system.

I am using the version control format.

Unfortunately this black background is a recurring problem. I “fixed” it by using the inspector to change back to a white background only to find it coming back to haunt me later after some changes (binary and version control). The only “fix” I have found which is stable is using the “.backcolor” in open (to whatever colour) which seems to have a priority.

Ok. Since you all seem to be using version control, I suggest that you look at the diff of the Window sourcecode. You may find that the backcolor of those fields has been changed. You should be able to revert that one line.

Don’t get me wrong, we’re curious about the cause. We run into this occasionally, but have not been able to reproduce it on demand. If you have repeatable steps, we’d love to know!

When i looked at the diff on my windows, it showed that it deleted the color completely. The line is still there but the value is empty.

My diff shows the entire Background line being deleted (diff), as well as the TextColor line (diff).

I had this problem after importing an old Real Studio project into Xojo and saving the project in the new Xojo format (version controlled).

Even though the main project file was saved with the new Xojo extension, most of the other files still had the old RB extensions. I eventually re-saved each individual file with the new Xojo extensions. By doing this the background color problem was fixed permanently.

I’m just taking guess here, and not sure if the other guys also imported their projects from the old RB format, but I think this issue might somehow be related to a mixture of old RB formats and the new Xojo formats?