Compile freeze

I’m having an issue with the compile freezing on Windows 10.

  • There are no errors, it just freezes and I need to kill Xojo app to stop it
  • This happens when I do a Build or Run for a Windows exe
  • It works with 32bit, but not 64bit.
  • I’ve tried two different projects, with the same results.
  • When I compile on the Mac (for a Windows exe), it compiles with no problem.
  • This problem started happening in the last week or two, before that they compiled on the same machine with no issues.
  • I’m running Xojo 19.1.1 as I don’t have the time to update the application to work with the newer compiler.

Any suggestions on what I can do to get it working?

Thank you…

Are you sure it’s freezing? Did you maybe change the compiler optimization to “Aggressive” by accident?

1 Like

@Greg_O_Lone, Based on an old posting, I tried switching that from Default (both applications were set to default) to Moderate, and then just for fun, to Aggressive. The exact same thing happens. I’ve also left the compiler for approximately 20 minutes, with it remaining frozen. I’ve attached a screenshot of the frozen application.

Interestingly, the compile fails when it reaches the Styles. However, when I remove the style and any reference to it, it fails anyways at what appears to be the next step, so I’m doubting it has anything to do with the styles. This happened on both applications.

When I look at the Event viewer, it says:
The program Xojo.exe version 19.1.1.44753 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.

When I look at the Security and Maintenance control panel it says the following, though I’m not sure that is the crash, or because I forced the Xojo to close:

Source
Xojo.exe

Summary
Stopped responding and was closed

Date
‎2022-‎02-‎15 7:58 AM

Status
Report sent

Description
A problem caused this program to stop interacting with Windows.
Faulting Application Path:	C:\Program Files\Xojo\Xojo 2019r1.1\Xojo.exe

Problem signature
Problem Event Name:	AppHangB1
Application Name:	Xojo.exe
Application Version:	19.1.1.44753
Application Timestamp:	00000000
Hang Signature:	d8b2
Hang Type:	134217728
OS Version:	10.0.19044.2.0.0.256.4
Locale ID:	4105
Additional Hang Signature 1:	d8b277240e191d6d55ca9d300c548faf
Additional Hang Signature 2:	ad49
Additional Hang Signature 3:	ad49c2bb74ee2e322f28ccadb0b4f9a5
Additional Hang Signature 4:	d8b2
Additional Hang Signature 5:	d8b277240e191d6d55ca9d300c548faf
Additional Hang Signature 6:	ad49
Additional Hang Signature 7:	ad49c2bb74ee2e322f28ccadb0b4f9a5

Extra information about the problem
Bucket ID:	8593dbc03de9b81454f6ac3b0a400465 (1510584094604395621)

What I do notice, is that the “compile directory” is not created, so I’m wondering if it is failing there. I’ve checked permissions and that is all ok. I’ve run Xojo as Administrator with the same results

@Greg_O_Lone , do you have any suggestions on what I can try?

Thank you…

First, try going back to Default for the compiler optimization level. Moderate and Aggressive can take a long time (the IDE Takes 40 minutes per target on aggressive)

I have returned it to default with the same results, but I’ve never let it attempt to compile for that long. I’ll do that (at default) to see if it eventually compiles.

If you have an antivirus program running, make sure it’s not preventing houdiniassistant from running.

I’ve found no evidence that something called houdiniassistant is running on my computer while I’m compiling (saw in another thread that houdiniassistant is the compiler). Interesting, when I look at what is running, it shows that Xojo is using zero CPU…so nothing is happening. The memory stays consistent, no growth or decrease.

image

As well, it freezes at the “link” step, and even if I leave it for almost 90 minutes, there is no change.
image

FWIW I tried to compile “Aggressive” on am M1 mac. It never got past the first object. It was clearly doing something as the fans came on Full blast after about 5 minutes.

2 Likes

Have you covered the basics?
-Clear the building caches (Edit - Options - Building)
-Close Xojo (make sure to kill all the processes) and reopen it
-Delete the target folder where the compiled app will be
-Restart the PC
-Uninstall Xojo and reinstall it

@Ivan_Tellez, thank you for your response.

  • I have cleared the caches, same locking compile
  • I’ve closed Xojo (need to do that each time as it freezes) and opened it again.
  • The target folder for the compile/run never gets created. I assume it is freezing before this step
  • I’ve restarted the PC a few times since starting to debug this problem.
  • I have completely uninstalled Xojo, then went to the site to download it again, and install the application.

Throughout this whole process, it continues to crash when set to 64bit, but works fine when set to 32bit Windows.

You have 2019r1.1 try to update your xojo and retry?

Right, so to me no existence of HoudiniAssistant means that the compile process is being prevented from starting altogether. As I mentioned before, check to make sure your AntiVirus software isn’t causing problems.

Kind of a dumb question, but are you running a 64bit version of windows?

@DerkJ, I do not have the time to deal with the changes to the code that are required to do an upgrade, so I need to stay at this version for now.

1 Like

@Jason_Cullins, yes I am. :slight_smile:

We’ve had this effect, too.
It only occured on our company provided machines, not on private ones.
So it must have been some combination of Windows 10 configuration.

This is the Feedback Case about this issue: feedback://showreport?report_id=61314
Windows 10: Building hangs for all BuildTargets that use the LLVM Compiler

Xojo tried hard to figure out what prevented their build process to work. As a result they have fixed this with Xojo 2020r2.

Since you’re (having to) use 2019r1.1 - we got something from Xojo support that helped and even worked with 2019r1.1 for us.
Your best chance is to contact their support and ask about that Feedback case mentioned.

1 Like

This is a good lead, thank you @Jürg_Otter.

@Greg_O_Lone, do you think that our issue is similar enough to Jürg’s to try the same fix?

1 Like

Looks like this was the situation…it is now working. :smile:

Thank you Xojo Support for helping me out.

3 Likes

Is it something you can share in the forum, or would someone else experiencing this bug need to contact support!

2 Likes