Compilation of "App" Failed

I get the message seen many times before: "A file system error occurred (#2) for " “xyz.png” “. If the application already exists… etc”

I have removed the app.debug files, deleted and re-added the xyz.png file, restarted my Mac, none of these get me past this message. Any clues out there to save me wasting more hours on this?

Are you building in a Dropbox, iCloud, OneDrive, or other similarly shared folder?

No, just regular hard disk.

Does Xojo have permission to write to the build path?

The folder it is in has read & write permissions. I can open and save ok.

Hrm. Interesting. That’s the two most common causes I can think of. Which operating system and version? What version of Xojo?

MacOS 11.1, 2020r2.1.
It was working fine last week then - dunno what happened.

Do you use Time Machine? I wonder if that might have some part in this…

Have you tried moving your project to another directory and debugging to see if it works there?

What about running First Aid on the drive?

I’m really out of ideas beyond those.

I do use Time Machine and Carbonite, but they don’t seem to have caused this issue before. I just resaved the project as a binary on desktop - tried running from there - same issue.

Going to run Disk Utility… no problems found - same problem.

You might try this, modifying the command to match your version of Xojo, in case you recently updated and it somehow became quarantined, but I’m not sure that’s the cause:

Humm, other projects run just fine, it seems to be just this project (the critical one of course). So not sure that it would be a quarantine issue as that would impact all no?

Ran the sudo xattr -cr anyway… no change, same problem.

I have now used SourceTree to go back to an earlier version which works fine. Will just have to re-do the work over again.

Strange. I wonder if it is a corrupt launch services database which has been known to cause weird file i/o issues? Some things to try:

  • Put the project in a new folder and see if the problem persists
  • Run in a different user account and see if the problem persists
  • Rebuild launch services databases (steps vary by macOS version)

It sounds like something has a hold of the app or possibly something inside its package which is preventing the deletion.

We get this problem with iDrive when we have the Continuous Data Protection feature enabled.

What happens is that iDrive starts backing up the executable when it appears on the hard disk. Unfortunately, due to my slow upload speed this takes some time to complete so if I try to perform multiple debug builds before it has finished, Xojo cannot delete the old executable.

It occurs even when the previous .debug file has been manually deleted.

Do you happen to have another instance of the same application name or bundle id running?

No, Xojo is the only app running (and safari & source tree)

1 Like
  1. New folder - problem persists
  2. Testing but run into problem with external graphics (now where are they - this is a whole other issue - but how do you determine which graphics are internal and which are external? - and where the heck are they all?)
  3. I wouldn’t know where to start…

macOS 11.2 was released recently (last Saturday):

I may be a good idea to upgrade (these days) ?

(that is the guy who still runs El Capitan that wrote that !)

All images are external. You can right-click on an item in an Image Set and pick “Show on Disk” to see where it is.

Looks like Onyx can do it. But use caution with such tools. I’d try the separate user account first.