Can you help me get an application approved

This is a little embarrassing, but I need help in getting my application approved on the Mac App Store.

The reviewer seems to be able to make it generate an error, after following his steps we’re not able to re-produce it and neither can our current beta testers. Unfortunately the reviewer does not seem to want to send me the complete error report either, so I’m shooting black rabbits in the dark and without a flashlight/torch.

I was wondering if you guys could help me by testing the application and following the reviewers “Reproduction steps”, maybe one of your guys can reproduce it and then help me figure it out and fix it and then finally get this application released. It’s been with Apple since the 2nd of June.

You can download it from my site.

The reviewers ‘reproduction’ steps are as follows.

[quote]The following are steps to reproduce the alert we are receiving:

  1. Insert external Hard Drive
  2. Launch the app
  3. Click on the ‘+’ button
  4. Choose the USB drive, and click Open

An error alert appears. Please see the attached screenshot.[/quote]

I had previously altered the code in the hopes to better deal with this error, it just seemed to then take longer for the reviewer to still be able to make it happen.

Thanks in advance for any assistance anyone can provide.

Worked perfect for me. No Errors

Model Name: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB

It worked fine for me with a USB flash drive. The only way I could get it to give me an error was to point it at a DMG I had open at the time (which of course was read only). Can you at least say what the error message says?

Edit - I also get an error if I point it at a folder inside the flash drive. But both of these cases SHOULD give errors, so…

Have you tried all the various drive formatting options, e.g. case sensitive, etc.? I had a huge problem with GarageBand on a case sensitive formatted drive this year.

so I tried it with a USB flash drive with 2 partitions. 1 NTFS and 1MacOSX Journaled/Case Sensitive. and the app worked fine with them. no bitching. no errors. (I got yellow triangles since I didnt have anything to backup to them).

I have no usb disks with me right now, only that one usb flash drive. I will check later to see if I have a drive I can test with.

sorry I didnt find the error for you.

I got it.

Report sent to Sam via his in application error reporting.


Thanks guys I really appreciate it.

Hi Brad, I have indeed, I have a bunch of different USB sticks from different manufactures and then I have a bunch of the same model with various different formats. I also have a couple of USB external Hard Disks, with spare partitions on them…

Thanks Jim, I wish the Apple reviewer would click on the “Send Report” button like you did… but he won’t, he just sends me a screenshot of the simplified error dialog.

I’ve updated the application, fixed Jim’s issue and added a new error reporter. If you’d like to try, then please download this version.

Download new version and installed. The app ran the backup already set up, did get a message that it would continue (or something like that). While reading it the message went away and the copy started ( I did not respond to message).

I let it run for an hour or so then cancel it (was going to take six more hours).

Deleted script(?) and set up a new backup with a smaller source. Completed ok.

Question. Sandbox. MAS.
I guess you can get ‘right’ to access entire Volume or Folder of Files? For both reading and writing. I did not think this was possible.

This message is to allow you to cancel the auto-backup when inserting a disk, incase you don’t want it to backup at that time. It has a 10 second timer on it.

I’ve tried to make it as quick as possible, but when backing up a whole disk, it may take a long time. I know apps like Carbon Copy Cloner don’t take that long, so I’ll continue to optimize the routine over time.


[quote=102510:@Jim Smith]Question. Sandbox. MAS.
I guess you can get ‘right’ to access entire Volume or Folder of Files? For both reading and writing. I did not think this was possible[/quote]
It’s only possible via Drag & Drop or a NSOpenDialog, your application doesn’t automatically have access to any volumes unless the user grants permission. You then need to create and store a Security-Scoped Bookmark (Evil things), my third generation code seems to be working well, so I’ll be releasing it later once I have more evidence to prove it’s the most reliable code I’ve written.

In a sandbox you have write access to the complete hierarchy below a given folder this way? Could you have write access to the containing folder for a dropped file?

This is still the single reason I can’t issue a MAS version of my app.

If you mean that folder’s contents then yes.


I could not get the app to error like Apple did. I do get an error that it cant eject the media (USB Flash Drive - vendor branded 2gig USB2 drive) whenever it actually backs something up to it. (ie there is a new file(s) to copy to it). If the backup has nothing to do (ie no file(s) to copy to it) then it ejects it without an issue.

good luck with tracking down the issue.

Bummer. This is something my app requires to do frequently :frowning:

It is up and available…

[quote=105327:@Sam Rowlands]It is up and available…[/quote]

Congratulations :slight_smile:

[quote=105327:@Sam Rowlands]It is up and available…[/quote]

Charge for your work!

[quote=105341:@Gavin Smith]Free?

Charge for your work![/quote]
I do sometimes. This app is only part of the procedure, there’s a very long game involved (which is one of our top secret take over the world type plans).

Then this project was a learning experience?

Glad to hear it. I sometimes feel bad that I don’t give you money for App Wrapper each year. But hey, don’t let me give you ideas :wink:

I’m actually concerned about the race to the bottom, in terms of pricing, on the Mac App Store. I think it’s a couple of years behind the iOS App Store, but I’m fearful that it’s heading that way, where everything is free and supported with ads and nasty in-app purchases. (Sam’s app clearly does not fall into this category at all; there are a few awesome free apps on the MAS).