Big Sur and Xojo 2019 to 2021

I just upgraded to Big Sur on my development machine, and ran into this problem: Error for Big Sur: "Linking Executable ld: file not found"

I’ve been using the latest (2021 R 2.1) for my web apps, but have been reluctant to move from 2019R1 for my Desktop apps, but it sounds like now may be the time?

Are there any big gotchas in going from 2019 to 2021 for macOS and Windows Desktop apps? Would you recommend I hang back on a slightly older version (for example, I believe 2019R3.2 would work on Big Sur, but 2019R2 and later had the big API 2 introduction and partial withdrawal…)

I didn’t see what computer you have but for our M1 Macs I converted a program with many, 50+ at least, windows, containers, menu, connecting to a postres database with at least 75 million records and everything worked the first time I built for the M1.

In two months of hard production work every thing has worked flawlessly.

I started out making no changes to my 2018 r3 code. For the last 2 weeks I’ve been sloooowly changing some code to api 2. Even mixing them on the same line of code with no problems. For example, me.cellvalueat(me.listindex, 0), works. My hats off to the Xojo team for doing a great job.

I’m also currently moving a desktop app from 2018R3 to 2021R2.1 and no significant issues so far. My next challenge will be the companion web app.

Just in case you intend to stay with 2019r1 for Desktop Apps a little while longer…
Have a look at this:
MBS Blog: Big Sur and Xojo 2019r1.1

2 Likes

Jürg, thank you for that tip. Using that hack, I’m able to run 2019R1.1 under Big Sur, which enables me to do the normal Edit/Run/Debug/Edit… cycle. I may not stick with 2019R1.1, but now I’m able to make an informed decision about which IDE to use. Very helpful!

In Big Sur you can no longer debug in 32bit which was the default in older versions of Xojo. Have you changed to 64bit? I had to do it manually in all my projects.

Oh yes, I went to 64 bits a while ago – or, thought I had! I had a number of issues in my makefiles/build scripts that had to be fixed:

  • build tools must be 64 bits (I had a few Xojo command-line tools still in 32 bit builds). This was easy to fix.
  • the ‘defaults’ command to manage plists seems broken in Big Sur. I had to update to the ‘plutil’ command in a few areas in my Xojo build scripts
  • Xojo Plugins must be code-signed: when launching Xojo 2019 in Big Sur, I got some errors about old plugins that were not code-signed. Turns out I wasn’t using these anyway, so I just removed them from the plugins folder and relaunched.
Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.