Application build upload for remote debugging has 0 size

I’m a new user , testing Xojo for Raspberry. It is a Raspi4 , 8G
I followed documentation and solved few problems using already posted common issues.
The app never runs when I launch the remote build .
What I have done

Uploaded the Desktop remote debugger for raspi to the Raspi, unpacked it
launched the exec, my windows machine where I have Xojo automatically detected the raspberry and displayed me the window
Added in debugging this host


I opened the sample note application, for desktop
change the build to Linux, selected ARM
selected project, run remotely , select the host available
Xojo run and tells me " starting application", then stops
checking the file on Raspberry, it is a 0bytes file size

→ tried to change build directory to Desktop - no change
→ tried to change rights of the folder to 777, - no change

any insights ? Thanks in advance and apologize if it is obvious but haven’t found such issue in the forum


Could be firewall setting on either side?

Maybe this article from Xojo can help:

Hi @brian_franco , Thanks for you answer.
The link was my reference to start, yes Thanks you

As the file is created, I don’t think it is the firewall. But I double checked and everything is "open "


for he Xojo windows host

Finally ,
This is what I get on the RASPI when I run the remote debugging


so, everything “seems ok” ?

up ?


It looks like the remote debugger and the IDE start to talk ok. Can we see some more of the output from this screenshot? Without seeing that, just some guesses… is the remote debugger running with permissions to write files to the destination?

HI @Chay_Wesley ,
Thanks for answering.
This is the full info ( you can see the exec shell run as first line )

I set , just in case ALL folder to 777 and I’m generating the file on the desktop :

so all permissions shoudl be goog ?

I’m out of ideas, so I guess it’s time for me to step aside and let someone with more experience remote debugging on rPi tag in.

No. What’s missing here is the data, your compiled app. Normaly you see some lines that report the received status in percent. Seems the problem is on the Windows side because no data was sent.
Are you using the latest Xojo version?

Hi @Carsten_Belling , I’m using v 2022r1.1, so yes it is the latest version apparently
When I run the remote debugging, I have these 2 windows :

Looks all fine on the screen. The IDE creates a YourAppName.tar.gz file that will be transmitted to the remote debugger stub. Can you check if this file has a size?

on the windows system, the file exist and has a size

on the raspi, it exist but has 0 size

Still out of my lane here (I mostly remote debug on Windows from MacOS). But still… Looks like the connection goes wonky during some expected challenge / response exchange between the two systems. I also notice the PC screenshots suggest a non-US locale. Not sure about the RPi locale settings. Theoretically should not make any difference at all, but in the real world that sort of thing has been known to trip things up. Just a thought.

1 Like

@Chay_Wesley @Carsten_Belling
Thanks a lot for the suggestions .
What I have tried : copy manually the generatede gz file to the PI
unpack it.
then start the remote debugger
Then run mannually the exec extracted from the gz ( not sure if it make sense or not )
I get :

Does it make sense or it is abnormal ?


Are you sure on the PI that you are allowing 44553 IN/OUT and TCP/UDP?

I could only reproduce what you have shown if I the firewall rule for that port is not set correctly

@brian_franco You mean Xojo uses UDP for communication and TCP for sending the data/packed app? That would explain what we see in the console screenshot. Someone of the Xojo team should be able to clear this up.

Not 100% sure but I know if I allow UDP/TCP then it works
Maybe I’m doing it wrong or missing something in my config but that is what works for me

@Carsten_Belling @brian_franco
I double checked :

root@raspberrypi:/home/pi# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

Maybe more info on my system :

root@raspberrypi:/home/pi# uname -a
Linux raspberrypi 5.10.27-v7l+ #1409 SMP Tue Apr 6 18:26:02 BST 2021 armv7l GNU/Linux

config .txt ( with a small screen in HDMI ) :

root@raspberrypi:/home/pi# cat /boot/config.txt
# For more options and information see
# Some settings may impact device functionality. See link above for details

hdmi_cvt 800 480 60 6 0 0 0


root@raspberrypi:/home/pi# netstat -a |grep 44553
tcp        0      0 *               LISTEN
udp        0      0 *

Is there any log on Xojo side to see what happens ?