App Wrapper logging lot of errors about files "" not existing


I’m trying to notarise an app, using App Wrapper. In the check phase, I’m getting those entries under “Executable files”:

Unable to check “” as it doesn’t exist; - Mach-O 64-bit dynamically linked shared library x86_64] [arm64
Unable to read “”; Is a directory errorCode: 21

Those two errors appear several times in a single attempt, with no obvious pattern, for a total of 68 entries.

I tried rebuilding the app with Xojo. Also (and, “of course”), the notarisation doesn’t work (“invalid package”). Also tried moving the app somewhere else (as it’s on a NAS in the first place), with the same result.

Latest AW version used; same for Xojo. Compiled as universal binary and launches fine locally.

What may I check for?

You don’t mention your OS version, but 12.3 broke AppWrapper. There is another thread here on the subject, in which Sam gives a link to a beta which is working for me.

1 Like

That’s it. I’ve installed 12.3 yesterday, my bad.
I also have others weird symptoms on my computer since I did it. Looks like connecting to my NAS shares won’t complete, but I’m not sure it’s also related to the update, nor what else will cease to function.

Ok, thank you!

A lot of people are not seeing the connection either.

Please download the latest App Wrapper beta, the link is in the following thread

Granted. And since the other thread was created before I updated myself to 12.3, I didn’t considered reading it (and later forgot it existed).

Thanks. I’ve already searched and found it (using Jerry’s hint). The beta has just completed the process while I write this, so I can confirm you it works.
Thank you!

1 Like