App won't run in simulator

Get this message: An error occurred when attempting to launch the application. You may need to delete the application from the simulator if it already exists or check the Minimum iOS version.

Except at this point no apps are showing in the simulator.

What next?

Hi @Bob_Gordon

More pieces of info are needed.

  • Does that happens if you re-run the project in the Simulator? (sometimes is a matter of timing).
  • If that app is already installed in the Simulator, have you tried to follow the suggestion? (delete it from the Simulator and re-Run from the IDE)
  • Do you have some “Team” selected in the iOS > Code Signing > Team section or it is set to “None”?
  • Have you done some recent change in your setup?
  • Xojo Release
  • macOS Version
  • macOS Architecture (ARM / Intel)
  • Xcode Version
  • Xcode SDK version
  • Xcode SKD / Simulators installed

Thank you so much!

A few more details:
This worked fine yesterday.
This morning I installed the new version of Xojo (2023.4).
Loaded the program in question into the new version, attempted to run. Got message.
Went back to previous version (that worked yesterday). Same message,

More info (and progress).
Restarted computer.
Tried app in 2023.3. It worked,

Further info.
Tried app in 2023.4. It worked.

The answer is to restart the computer.

hnmmm… that shouldn’t be the answer except some change/update has been made in the setup without noticing.

1 Like

Lol i dit that 100 times and still doesn’t work.

I beleive maybe xcode command line call is broken or such. It must be something simple, i can’t find any major changes in the xcode release nodes on signing other than the notary tool.

Ditto for me, I downloaded 2023.4 yesterday, and opened Xojo app project today. Got this message. There were no changes to my project or system at all.

I tried updating Xcode to latest and simulator to 17.2. Tried restarting. Checked Apple developer account. Created new Profile. Deleted the app from the simulator. Changed the app version number. Changed the simulator version.

My Development Team is correct. I can’t see anything else to try.

Nothing worked so I went back to 2023.3

Me too. I’ve created an issue: https://tracker.xojo.com/xojoinc/xojo/-/issues/75231#note_569071

Restarting doesn’t help.
I can build and run my Xcode projects without problem.

None of the iOS example projects run for me with Xojo 2023.4

In Xojo I am building for Development using my Deployment team as it isn’t giving me an option to use my Development profile. I don’t have a full license yet as I’m just trialling Xojo. Perhaps that is why?

Michelle,

Back up to Xojo 2023.3.1. There seems to be an issue with 2023.4.

Also, try running an empty project. (That is, start a new iOS project and then run it without adding anything. If that works, build from there.)

-Bob

1 Like

Thanks Bob!

Running an empty IOS project autoselected the correct (my personal) Development profile for Code signing.
I was then able to select it for both an example IOS project and my actual project. Both run correctly now.

1 Like

Actually this happened again yesterday and I had to go through all the steps again, ie. downloading my developer certificate, starting a new empty iOS project and saving it, restarting the computer. Then my developer profile was available again to select and run the Xojo project in the simulator.

I had requested an APN key 2 days ago from my Apple developer account, for push notifications in my Xojo projects, and now Xcode says I can’t use the personal Developer profile any longer for an iOS project because of APN. I’m not sure what the implications are for this in Xojo, but my project is running in 2023r4 with my developer profile for now.

Although the issue I created is still listed as Open, 2024R1 has fixed the problem for me. Yay!

1 Like