Xojo 2023r4 – still having problems running in iOS Simulator

I have been unable to run my Xojo iOS app or, for that matter, even a simple test app (by creating a new, “empty” iOS app and attempting to run it right away), in the Simulator since upgrading to 2023r4. The error message is:

Error signing application:Apple Development: {My Company Name}: no identity found

Using 2023r4 I am able to:

  • Build for Development :white_check_mark:
  • Build for App Store :white_check_mark:
  • Run on device :white_check_mark:

But I am not able to:

  • Run in Simulator :x:

Using 2023r3.1 I am able to do all those things, including running in the Simulator.

I see others have had similar problems, eg App won't run in simulator - #12 by Michelle_Parker and Problem running in simulator - #14 by Art_Gorski. Unfortunately none of the solutions in those threads has solved the problem for me.

I have tried @Greg_O 's awesome Apple Profile Triage utility and followed the steps to connect to my Apple Developer account and refreshed/re-downloaded certificates. None had expired but, going further, I deleted and regenerated my development certificate and profile. This hasn’t helped the issue with 2023r4 running in the Simulator, unfortunately.

Given 2023r3.1 can do everything (ie build for debug, App Store, run on device and run in the Simulator) and given 2023r4 can do everything except run in the Simulator, it seems like it might not be related to my particular certificates but perhaps something else that was changed with building for the Simulator between 2023r3.1 and 2023r4. I was hoping you might have an idea @Javier_Menendez ?

Does anyone have any other suggestions?

1 Like

Have you the last Xcode, download the last simulator from it ? (Xcode → Settings… → Platforms)

Thanks @Valdemar_De_SOUSA . I am running Xcode 15.2 and iOS 17.2 simulators.

Upgrading Xcode and simulators has no effect on this problem.

1 Like

I have this problem as well if I have Build For in the iOS Build Settings set to “App Store”. If I set it to “Development”, no issue. I added this information to the current “Works on device but not on simulator” issue. Just have to switch it depending on what I’m working on.

Unfortunately setting the build to Development does not help me run in the Simulator - I still get the error as stated earlier. I can build for Development (and App Store) and run on device, but just not run in the Simulator.

It seems a number of us are having various versions of the same issue: https://tracker.xojo.com/xojoinc/xojo/-/issues/75022

1 Like