App.Name Syntax Error in 2022r1

App compiled and has this error:
App.Name Syntax Error

The name is correct. Build Settings checked also.
There are a couple of threads in the past, but none helped.

i not see a property Name in docu.
use a button, make a break and look in the debugger at globals.

Sub Pressed() Handles Pressed
  System.DebugLog App.ExecutableFile.NativePath
  System.DebugLog App.MyName 'a public Property MyName in the App i renamed as MyApp
End Sub

1 Like

Hi MarkusR,

Thank you for your reply. I meant the error occurs at the end of the compilation process.

You tried calling it something other than App ?

1 Like

Yes, I did, “App1,” “Hello”, etc.

Is this a new app or an old one you’re just now openeing in 2022r1? Perhaps it should be a DesktopApplication.

1 Like

This problem is a pain to track down. I think the last time I ran in to it, I had to open a Feedback Case and attach the project so an engineer could take a look.


It’s an old one, now porting to new systems.

Thanks. I’ve just submitted a Feedback report.

It is a misleading error as the number of times, I’ve experienced it, it has not been related to whatever it’s complaining about at all.

I’ve learned to make only a small amount of changes between runs. This not only helps me focus on just one thing, but it also means when I encounter this error, it’s easy for me to recall what I’ve changed and revert each change back until I can isolate the actual cause. IIRC, it’s nearly always a syntax error.


Make a copy of the project and start deleting project items, compiling at each step, until that particular error doesn’t appear (of course you will be getting a lot of other errors…). The last item you deleted prolly contains the culprit.

1 Like

Hello Paul,
Thank you for your reply. I tried deleting things, one by one, until there is only one thing left, the application, named “App.” And yet, it still shows the syntax error with App.Name, which has nothing in it.

Try to change the super to DesktopApplication

1 Like

Sounds like the project is corrupted; it happened to me, already.
Have you tried saving the project in the text format and runnning/examining that way?

1 Like

You didn’t attach your project to the Feedback Case. They can’t investigate without that.

1 Like

That little project with just the App class that fails fouls be a good start. They should be able to tell what’s wrong from that.


Hello Arnaud,

Thanks for your reply. I will try it.

Thanks, Anthony.

Hello Derk,
Thank you for your note. I just tried it, and it’s still the same error.

Mostly these errors are not about the thing you think.

Something is calling the App class or setting a property … ? check those to be sure.

1 Like