64-bit Windows build with Xojo 2016r4.3

I’m trying to do 64-bit builds of my project. I’m running Xojo 2016r4.1 on Mac El Capitan.

No problem building a 64-bit app for Mac, but when I try to build for Windows I get an error as follows:
Type: An orange exclamation mark icon
Location: OptimumVP.Name
Issue: Syntax error

Another strange thing. There is a Builds folder containing folders “OS X 64 bit” and “Windows 64 bit” but both are empty. It puts the OS X app in the parent folder which contains the source file.

I tried to attach a snapshot of the build settings, but I couldn’t figure out how to do that.

I would use a much newer version than 2016r4.3 for this

I would be happy to use a newer version if I could afford the cost of the upgrade. But in the mean time, can you tell me what is causing the syntax error?

not without code or an image
at this point I have no way to tell

  1. What code? Isn’t this related to the Build Settings?

  2. As I said, I can’t figure out how to attach an image.

What does Location OptimumVP.Name mean?

To “attach” an image:

  • go to imgbb.com
  • upload your image there
  • select Embed Codes - BBCode full linked and copy the code directly here
  1. What image should I send? The build settings?

  2. What code should I copy? There’s 3.9 MB of source code. Do you want the entire source file?

What does Location “OptimumVP.Name” refer to? The name of the project is Optimum Video Poker (OptimumVP), but there is no module or other component called “OptimumVP”.

Also, there’s no syntax error when building for OS X.

It will also build a 32-bit Windows app with no error, so it seems that the “syntax error” can not be anything in the source code. It must have something to do with the build settings, but I can’t see anything different between the settings for 32-bit and 64-bit other than that selection.

IIRC in 2016r4 i think the target for building 64 bit Windows apps was not available by then, but forgive me if i am wrong.

That’s not necessarily true. If you have any code that is enclosed in #if Target32bit or #if Target64Bit you could literally be sending different code to the compiler.

And I wouldn’t risk a Windows 64 bit code before Xojo 2019r1.1, I’ve tried, and had crazy issues.

There is one #if TargetMacOS in my code, but there is no other #if target of any kind.

I have carefully checked all the Build Settings many times for invalid characters or duplicate names.

I haven’t changed anything, but now I’m getting a different error. Instead of a syntax error, I get an alert “Project Cannot Be Compiled, Duplicate project item (i.e. same name): OptimumVP”, but “OptimumVP” is nowhere in the Build Settings or in the Builds folder.

Can you run your project with Xojo 2019r1.1 ?

Just run, not build.

This recalls me something: search the “build” folder and delete what is inside, then try another build (do that at each compile).
I recall that some files were not deleted between builds (is this the error ?).

Can you share a screen shot of the error window ?

As Emile says - download the 19r1.1 package and install it onto a Windows system (this is free and a VM is fine), load your project there, and run it with the Windows settings set to x86 64-bit.

Also, open the Search pane and search for OptimumVP. What’s returned there?

I forgot to ask - why are you moving the code to 64bit? Sine the WOW layer supports 32bit Windows apps, if you can’t compile it 64bit, and there is no specific memory or code reason to move it to 64bit, leave it at 32bit.

This is correct - on Windows, 32 bit apps are “Universal” and will run on both 32 and 64 bit flavors of the OS. Unless you are doing something very RAM heavy, there’s no need for 64 bit. 64 bit apps also have some build lmitations regarding the location of DLLs.