2021R1.1 Apple M1 native iOS compilation failed

Once again we get the “Compilation of “myIOSApp” has failed -1” message.
It seems that yet again we got stuck with rosetta and non-native xojo ide.
Also it’s kinda strange that nobody seems to have catched this before and this issue came trough the testing ? We have xCode 12.4, simulators iOS 14.4 everything works on Intel macOS.

Only when using Apple M1 (Macbook Pro) then we get Compilation failed … on iOS debugrun (simulator) and build. Not when running the Xojo IDE under rosetta

Are you using MBS plugins? I think I read you need newer plugins to be able to work with iOS and silicon.

1 Like

yes, see:
https://forum.xojo.com/t/mbs-plugins-and-apple-silicon-for-ios-simulator/

We have MBS 21.1 PR4 … is that an issue?

Any other plugins that may need update?

I mean, if MBS had to update the plugins for this new native linker maybe other plugins need updating too?

We have the latest of all used plugin as far as i know (Einhugur, MBS, Chillkat are currently used on the M1).

Maybe it’s good for all plugin developers to provide a listing which versions are required for which xojo ide version ? Even better would be if Xojo provided such validation, since it’s causing the IDE to malfunction without notifying what’s the actual cause. I can find a log in console.app or anywhere giving a clue what’s happening…

1 Like

I would start with a blank or simple Xojo example project without plugins to see if you still have compilation issues. If not, then slowly start adding to the project the plugins used in the project that is failing. Add them one at a time until you find the plugin(s) causing the issue. Then check with the plugin author.

I take you that Rosetta is not installed and you want to keep it that way?

1 Like

If you read the first post you’d seen that Rosetta does work. But xojo posted that it has become “native”, eh that actually won’t work with (some?) plugins so it’s not feature complete.

You can’t say it is Xojo’s fault for plugins needing Rosetta in order to compile. And if Rosetta is needed to compile but not actually execute a program using some third party plugin, I personally don’t see the real harm in that either. But then I have Rosetta installed.

What I really don’t get is how Xojo is not “feature complete” if the fault is for a third party control?

And that post is talking about your project which does use plugins.

Try a Xojo install with no third party plugins and a Xojo example project and see it that works. If so, then it is not Xojo’s problem here. You may need to remove the third party plugins from the Plugins folder, not just try a project that does not reference any plugins.

That’s all I meant when asking about Rosetta or lack of it.

With Xojo 2021r1.1, the iOS compilation needs both arm64 + x86 for iOS Simulator.
So all plugins have to be updated.

Having the latest doesn’t mean that they are already updated to handle the iOS requirements to not use Rosetta with Xojo2021r1.1

Well since plugins are part of Xojo, they extend xojo and it’s an ability of xojo …

Anyway i just expect the Xojo ide to give a message “this plugin … is incompatible with the current target” or something… ?

So you would expect the ide to just fail without notice? And you expect that to be part of xojo’s feature set?

Thanks, that makes alot more clear. But since Xojo doesn’t provide a message for plugins that are missing these parts? And we arn’t even using other plugins than MBS in our iOS apps… so what is happening here?

Only a few plugins (provided with Xojo) are part of Xojo. The rest are third party.

Well, I have no experience with plugin development or how plugins interact with the IDE. But if the plugin architecture does not have the ability to specify if a given plugin requires Rosetta at IDE/compile time, that would not surprise me.

Are there other plugins loaded in the IDE? Menu Help > Plugin References

Try an install without other plugins even in the Plugins folder.

It does if a plugin you’re using for iOS is missing the required iOS Simulator architecture part, i.e. if the iOS Simulator part only supports x86_64, then on M1 Macs you will see a compilation error to that effect.

So this means the plugins all have the correct plugin parts?
Well so what issue can this be then? Since we only see “Compilation of …MyApp… failed” error code: -1 this is not very informative and there seems to be no logs indicating a plugin issue.

All plugins you use must include the universal iOS libraries.
Otherwise you run 2021r1 in Rosetta instead.

Hello,

I have same problem on MacBook Air M1 running todays Big Sur update 11.3 and Xcode 12.5 when trying to run an IOS sample project from Xojo examples or a simple project I made with 2020 v2.1. Build seems to work. Problem occur only when trying to run it in the simulator. Tried to remove previous app from the Simulator and also tried 2 differents simulator devices (iPhone 8 and iPhone 11 Pro).

PS: I dont have or use any plugins.

Thanks,

So a blank iOS project does not work either in Simulator either, right?

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.