"You must first sign the relevant contracts online."

After fiddling around for a few days, no longer to be able to noratize :wink: my applications with the error message given in this thread’s title line, now I’ve noticed what’s going wrong:

When you see this err msg in the log (me, using AppWrapper’s notarizing tool),
you’ve to confirm new agreements with both iTunes connect and Apple Developer accounts first at their respective web sites.

You need to check iTunes Connect as well, even if you don’t do iOS.

Hope this helps others who fall into despair.

I am going to parse the error code and handle this in a future update to App Wrapper.

When I say handle; I mean make it clearer and hopefully I can offer you an URL to the contracts.

Nice to give it a try with AppWrapper.

We need to be logged in with the URLs listing the contracts at https://appstoreconnect.apple.com/login
and if there is a contract waiting, the web site remind us.

Found the information given in the first thread at the following places:
Apple Developer Forums/Notarization throws error
Apple Developer Forums/Unable to submit an dmg for notarization

Until now, it was only required for me to sign agreements with Mac AppStore, but this time there was an infrequent reason to sign the iTunes Connect contract as well.

The things that get me about this are:

1/ if they want something signed, why just leave a message lying around and break stuff until you go wondereing whats wriong? They HAVE our email addresses, how hard can an email be?

2/ Have I misunderstood what a CONTRACT is… in what other sphere can one party unilaterally change the terms at will.?

I suspect that most “contracts” that we sign contain clauses allowing them to do just that.

Non-English speakers like me at the first place. :wink:

I spent about an hour or so trying to automate getting rid of the Xcode agreement as there is a terminal command for this. I failed as I can’t seem to get sudo to work without me having to put up my own dialog for capturing their admin user name and password. Which I don’t want to do.

My old code for getting the system to handle this no longer works and a brief look online, I don’t see the replacement. Any pointers anyone? All I can find is stuff saying that I need to build an XPC process (which can’t be done in Xojo) then get my main app to request the XPC process has it’s security raised (or lowered) and then it calls the terminal commands without needing sudo.

I reviewed your posting above, but unfortunately, I can’t help.

You mean the license agreement that’s shown on Xcode’s first launch and after an update?

I found your post minutes after the issue first happened to me, so I was not in despair :wink:
But oh did it help, thanks!

It took a while for me to get into it. :wink:

That ‘appeared’ to automatable because it can be run from the command line. The online agreements not so much.

I was reading this morning that Apple might be closing accounts of Developers who breach their T&Cs, I think it’s about time that I tried to read them without falling asleep.

I nearly wanted to ask “What $h*t is missing this time?” when I got the same message again now.
This time, no hint was given when logging in to the Apple Developer account site.

This time, go to “Certificats, Identifiers, Profiles” and scroll down to the bottom of the site.
Below “Services”, there is a greyed out “Apple Pay Merchant Identity Certificate”, noted with red written “You need to accept the agreement ‘Apple Pay Platform Web Merchant Terms and Conditions’.” (Yo’ll find it when you click the highlighted in blue “+” symbol).

Edit: Still get the err msg when trying to notarize, after signing this crap certificate.

FWIW, I usually head to appstoreconnect when I get that message. Appstoreconnect usually has a giant yellow banner with which contracts to sign. I don’t currently see any messages, so I can’t verify if they’re still working that way - but have you tried checking appstoreconnect?

Yes, after g**gling a bit more I found the appstoreconnect.apple.com as well, re-directed from itunesconnect.apple.com. It was “Review the updated Paid Applications Schedule.” which prevents me from updating my applications.

Now it works again.

I need to remember to visit this site first.

They do. I saw the Banner for a few days as i cancelled my Dev.Subscription an few days ago. :wink:

Depends on how often you need to notarize an application and if you’ve already signed the current one.