XsEdit XojoScript editor talk

I just released version 1.2 of XsEdit, the open-source, advanced XojoScript editor. You can find it at:


These are the recent changes:

  • When window position is restored, the Toolbar visibility will be considered.
  • Window staggering code fixed.
  • Commenting will start at the first non-whitespace character.
  • Fixed bug where line-continuation character within a comment was treated as a true line-continuation character.
  • In Test Run, ability to ignore the remaining Print and Input events in the script (a sort-of cancel function).
  • Copying code will copy with indents.
  • Option to save a script with indents.
  • Added keyboard shortcuts to menus for Windows and Linux.
  • CurrentBuildTarget returns an integer instead of a string.

Hi @Kem Tekinay , I am able to build for OSX and it’s working very nice. But when I try to build it for MS Windows, the compiler / linker get hanging at the very end of the process. Can you please try ?

I’m able to compile XsEdit without error on Windows 7 using Xojo Version 2015 Release 2.4.

Strange… I am using 2015r2.3 on Win7 and the compiler / linker stops at approx 99%. No problems with other projects.

Hmm, that is strange, could it maybe be an anti-virus or firewall issue?

I’ve had before that the first time I compile a new project my anti-virus sometimes prevents me from doing so.

I unfortunately don’t have 2015r2.3 on my computer to test with, but can also compile without error using 2015r2.2.

Ok, I’ve tried on another Win7 machine. Same result, with version 2015r2.2, r2.3 and r2.4 (did not expect difference between these versions here but just to be sure)
When the compiler stops I see: “Compiling IDEEmulatorExtras (70of70)”

I’m stumped as to why this is happening.

Me too… and think I cannot do much to figure out what’s going on.
Just waiting for @Kem Tekinay , hope he can help.

If it won’t let it finish, the problem must be in the build script that copies the syntax definitions. Try disabling that temporarily to see.

Of course Kem, you’re right. So fixed. Thx.

I’ve updated the project to run in 64-bit and also fixed a bug or two. Right now it’s in the develop branch and I’ll do a release after the next version of Xojo is released so I can update any IDE script commands.